Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

3D Models and the absolutely terrible workflow (in general)

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
adrian.carpenter
349 Views, 5 Replies

3D Models and the absolutely terrible workflow (in general)

Hi,

 

I am finishing up a design, I have posted a few times here commenting on just how poor parts of Fusion Electronics actually is, it's clunky, it crashes *a lot*, it's unintuitive to the point that if you don't use it super regularly, the "weird things" you have to do leave your mind and you spend hours trying to figure out how to do something that is seemingly easy.

 

I'm not even at that point today, I'm at the point where I have a library, that contains a schematic symbol and footprint for an esp32-wroom-32e module, that workflow works ok.  What I'm trying to do now, is go through the footprints on my design and add 3D models, sound simple?

 

Yes, I thought so too, but hours spent trying has to lead me nowhere, in fact, it lead me down a road where I managed to get a 3D model into a symbol which I was then unable to remove, Fusion would not allow me to undo this action, I was stuck with the 3D model (that didn't work) and I could not find a way to delete the 3D model, fusion would just tell me it's in use and that was that.

 

So, I ended up re-creating the symbol & footprint (well, cut and paste) and then assigned that new symbol to the schematic at which point the "lock" on the symbol was released because the previous symbol was now not in use, I was then able to delete the old footprint and the 3D model from my library which I'm trying to keep clean and organised, but Fusion has other ideas about that.

 

Once I did that, I then went back into my library and renamed the symbols back to the original naming and I was back to the point before I attempted to get a 3D model to work.

 

But now I'm back and I have no idea why it didn't work.  The symbol showed the 3D model in the library browser, and when selecting the symbol in the schematic editor both the footprint and the 3D model were displayed, but pushing the 2D to the 3D board representation just throws up a warning telling me that the 3D model might not exist, I have no idea why, both in the schematic and PCB side they both show the 3D model, and in the browser, I can see my module, but alas, there are no bodies in it, it's empty.

 

I'm stuck and I'm incredibly frustrated why this is seemingly so difficult or unintuitive, when you go through the process you get random "save" windows appear with no explanation of what or where you should be saving stuff when you add a 3D model, there's not a hint, this is a more general bugbear with Fusion 360 in that the error messages are, for the most part, just junk because in my experience so far, they offer no information.

 

I must be missing something, it can't be this hard to get a 3D model to work, especially when it's showing in the library and the symbols+footprints, I don't understand why it wouldn't show.  This isn't just an isolated incident, it happens no matter what I try, and I'm loathed to try other experiments because of the hassle I had removing a 3D model from a library.

 

When I created the package, I could see the footprint and I aligned the symbol to the footprint, everything as far as I'm concerned looks right.

 

The fun doesn't stop there either, the board I am working on I just had to add some milled slots too, and again in a "this is not intuitive" kind of way, the suggestion is to use the "dimension layer" for slots, but I continue and exporting Gerber and uploading to JLCPCB shows the correctly milled areas, but the CAM preview doesn't show slots in F360, and this also applies to the 3D view of the PCB, devoid of slots.

I've searched, and I've read various things and I'm still not sure if fusion is capable of showing these, some posts seem to indicate that instead of using a line on the dimension layer, I need to use a closed polygon, but I've tried that in the centre of the board with a simple square on the dimension layer and neither the CAM output nor the 3D view show any changes, all I see is the plane running away, there is no cutout.

 

This leads me to the next issue, the CAM export.  Because I have these slots, I have to enable the dimension layer in the CAM generator, I can save this preset and it works fine if I go through the CAM processor and select that profile every time, but there appears to be no obvious way of making the "generate cam output" button use my new profile as standard, it just uses a supplied one, maybe I've missed an obvious setting somewhere, but I cannot find anything that looks vaguely like it will do this.

And then we hit the jackpot, something I've seen mentioned here quite a few times, converting bitmap to symbol.

 

I'm staggered that it's been years of people asking for something better than the, and I'm being kind here, abysmal method of doing it via a ULP.  The settings inside that window are just terrible, I don't know why there has been a need to make it so complicated because I've actually implemented this myself in another PCB design software that I was a developer on, you only need one or another of either the target width or height of the bitmap you want, there's no need to select units, scale factors or anything else that makes it much harder to understand what you're going to get.

That window needs 2 input boxes, one for width and one for height, they're mutually exclusive so if you set the target width, the height is calculated by the aspect ratio, and vice versa.  The input boxes in it are awful too, I find myself having to put in a random number so that I can then use the cursor keys to put the right digits in the right place, the input boxes won't allow you to go to an empty state, so instead, they make it far more convoluted than it needs to me.

The next issue with bitmaps is the choice of input, indexed Windows BMP?  Come on guys, it's 2021, nearly 2022, there are a million libraries out there for dealing with image formats, and plenty of tools or methods to produce non-dithered images which could just as easily be used because you can reduce the actual number of use colours in the image, I use this method myself.

 

This pain is even worse on macOS because it, quite rightly, doesn't support an image format that is dead, so I now create my image in a vector tool, export that as a PNG at high-resolution (this is the important step because the import into fusion is poor via the ULP), so I generate the high res PNG, I then have to drop to the terminal and use ImageMagick's convert tool to convert my high res, antialiased true colour image into a true colour image, but one that contains only 2 different colours, RGB(0xFF, 0xFF, 0xFF) and RGB(0x00, 0x00, 0x00).  This, in turn, goes through convert again, to take that image and turn it into an indexed BMP file, by this point we know we only have 2 colours because my workflow from vector->BMP handles that.

At this point, I can open this file via the ULP and it correctly shows just 2 colours (black and white) and now I end up scaling this image down, but to make life easier, I use decade multiples for the original input size so that the scale factor is simple to calculate.

 

It's at this point that you realised that it's just silly that you need to enter scale factors or multipliers and that the ULP itself should calculate these, the only thing we as users should need to enter is either the desired width or height of the resulting symbol in F360, the only thing the user needs to be concerned with is using a source image that is of high enough resolution to create a pleasing final result.

I've attached a screengrab showing the warnings I see regarding the 3D model.

 

adriancarpenter_0-1638438328992.png

 

5 REPLIES 5
Message 2 of 6

The new set local model doesn't work either.

 

What am I missing here?  The model I'm trying to use, well, import into the 3D package is a 3mf file, consisting of a number of bodies.  It appears in the editor fine, I've moved the model so that it aligns with the footprint, but I just cannot this model to show.

 

Message 3 of 6

Hi @adrian.carpenter ,

 

There is a lot to unpack in that one post dealing with multiple things you've run into. For now I want to focus on getting the models to work for you. 

 

The one thing that jumps out at me is you mention the models are 3mf files. From what I know, in the libraries only step and native Fusion models work with the system. I would recommend saving the 3mf file as a Fusion 3D model and then assigning those models to your components. 

 

I agree that at the very least the import-bmp.ulp should be updated to simplify it's interface. I'll make a note of that as a feature request. As you've noted the real solution is to have proper image import.

 

As you've noted there is no way to setup a default CAM job to run with the one click export, this is a standing feature request and I'll add your voice to it.

 

For slots, or official recommendation is to use the milling layer. The dimension layer should only be used for the board outline or any non-plated cutouts on your board.  Using the milling layer should give you a better result in the CAM preview. When drawing the slot you want to have a closed contour (note not polygon, the polygon command is not involved here) made up of 0 width lines and arcs.

 

If converting the 3mf models turns out to be the solutions please let me know, that means we need to take steps to inform the user that the model needs to be in a specific format.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 4 of 6

Thanks for the reply, I'll go back and read what you've said and see if I can get any further with your extra information.

 

I think simplifying the ULP would help people struggling with what is an awfully complicated window, I can see users being incredibly daunted by the various fields, including the scale factor, which they don't need to know about, I don't know why whoever created that ULP in the first place did it that way, it's totally backwards, you shouldn't have to get a calculator out to figure out what to put in the boxes.

 

Simplifying that window to a single "mm" and "inch" radio box and another radio box that says "Target Width" or "Target Height".  A text box would reside against those options.

Everything else is calculated, the user doesn't need to know anything regarding scale factors or dots per inch, the only thing that matters is the size that the user wants the resulting image to be, the caveat being that it's width or height, the aspect ratio is preserved.

All they do is run the ULP, select the bitmap and then set the width or height of the symbol and hit ok, it's already much easier for people to understand, no more needing to understand the DPI and how the scale factor affects things.

 

I can only imagine (although I haven't looked) that this slight reorganisation of import-bmp ULP would be reasonably simple and it would make it just so much easier for other people to use.  

 

The good thing about this is that you can work out whether the imported BMP has enough resolution to look decent on the PCB as well.

 

Additionally, information for macOS users, in particular, needs to be added because of the aforementioned problems with indexed BMP files, using brew and installing ImageMagick provides the necessary ability, these are the commands I use to take my greyscale image (greyscale because of antialiasing - you actually need to use just black and white otherwise you will have problems), it's important that the "greyscale" PNG has enough resolution, because once we use ImageMagicks convert command to create the monochrome image, we will end up with jagged edges where the antialising was on the border of being black or white.

brew install ImageMagick

convert <hi res export from affinity>.png -monochrome <hi res monochrome>_mono.png
convert <hi res monochrome>.png -depth 8 -type palette <indexed colour image>.bmp

 

Those are the terminal commands, you need brew to install ImageMagick and you will also need Xcode and the Xcode command line tools installed to successfully create the ImageMagick binaries.

 

While this is a little convoluted because of indexed image requirements, this solves a very real problem for Mac users who are wanting to use the import-bmp ULP without resorting to creating the image on a windows machine and then transferring the resulting BMP so it can be used with the ULP.

Message 5 of 6

I honestly can't figure this out.  When I go to the new option of inserting a model, it always creates a new one, I can't use the one I created, I have a symbol with the 3d model in and I can see the footprint in it as well.

This is the result from inserting the mesh into a design and then saving that design and then going to the new local model option and inserting the "native" object into the design, here you can see the footprint in the background.

However, nothing changed when I actually went to the 3D view, the footprint is still missing, I can see that the right file was in there, but all the bodies are missing, and therefore I end up with an empty space where the symbol should be.

I then removed the local footprint thinking I'll just re-add the one I created, but what I hit that option I can only create a new model again, I can't link it to the one I just created.



demo.jpg

 

 

Message 6 of 6

The main issue was what Jorge said, a corrupt or just weird model that fusion didn’t like.

 

I have a handle of managing libraries now, I think there’s a huge amount of work that needs to be done on the UI and workflow in general of fusion electronics, but, for the moment I have a handle on its quirks and can usually work my way around stuff.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report