Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

3D Model Issue, different outcomes for the same Library

12 REPLIES 12
SOLVED
Reply
Message 1 of 13
sh9WZ6F
364 Views, 12 Replies

3D Model Issue, different outcomes for the same Library

Hi,

 

Just wanted to let you know, that there can be different outcomes with the same Library.

 

Screenshot 2023-04-17 171140.png

R5, R13 and R14 are all 0402 Resistors. They were from the standard rcl Library and looked like the 0402 Capacitor C8 in the Picture.


I replaced R5 with my own design and outputted it to 3D to check if everything was correct.
After that was confirmed, I replaced R13 and R14 too, but when I rendered again, they were tilted.
How can this be? I am using the same Library for all 3 resistors, but I get different results.

 

 

Thanks for reading!

 

12 REPLIES 12
Message 2 of 13
jorge_garcia2
in reply to: sh9WZ6F

Hi @sh9WZ6F,

 

I hope this message finds you well. This is a defect we are chasing down, thank you for letting us know that it continues.

 

Let me know if there's anything else I can do for you.

 

Best Regards,



Jorge Garcia
​Product Support Specialist for Fusion 360 and EAGLE

Kudos are much appreciated if the information I have shared is helpful to you and/or others.

Did this resolve your issue? Please accept it "As a Solution" so others may benefit from it.
Message 3 of 13

Thanks for the post.  Can you tell me the rotation angle of each of those parts in PCB (the 2D rotation in the 2D board editor)?  ie - is there any chance you can screen show the properties of the parts that display at the right rotation and the others that do not?  Thank you.

 

Regards, matt - Autodesk

Message 4 of 13
sh9WZ6F
in reply to: sh9WZ6F

Hi,

thank you for coming back to me.

I got the Issue resolved, but for You I will go back to that Version and explain.

 

First the Angles:

 

Right:

R5 = 180°

(C8 = 270°)

 

Wrong:

R4 = 90°

R13 = 270°

R14 = 90°

 

Right:

sh9WZ6F_0-1681829440102.png

 

Wrong:

sh9WZ6F_3-1681829593580.png

 

 

By the way, I could fix the error on this PCB today.

  • I exported the PCB from 2D to 3D without all 3D-Packages, saved the Project and closed it.
  • Then I reopened the Project and did the 3D export again with all 3D-Packeges included.
  • After that, the Resistors were placed correctly.
  • But 2 other Components were missing, which were imported from Library.io (for example from Würth PART-NUMBER 156125M173000)
  • I created copies of those two components in my own Library and replaced them.
  • Now every Component exports fine from 2D to 3D.

 

Interestingly enough, Fusion could not find the 3D Packages from Würth when exporting 2D to 3D.

But when I imported the Component from LibraryIO to my own Library, Fusion just downloaded the Package to my own Library.

 

 

Best regards,

 

Sebastian

Message 5 of 13

Hi @sh9WZ6F ,

 

So sorry for any trouble!

 

We have identified the reproducible steps about 3D PCB design mess up issue and the key point is the OS region is French, Dutch, Norway or others which might have format differences.
HelenChenElectronicsQA_0-1681897104012.png

 

Before this issue is fixed, the workaround is:
  1. Change the OS region to English instead from French, Dutch
  2. Break link for the problematic 3D PCB
  3. Push to 3D PCB again
Please kindly try the workaround before this issue is fixed.
We will keep you be posted once we have a fix about this issue. So sorry for any inconvenience.
 
HelenChenElectronicsQA_1-1681897103992.png

 

Hope you have a great day!
Best regards,
Helen 


Helen Chen
Principle QA for Fusion 360 Electronics
Message 6 of 13

Hi @sh9WZ6F,

 

Hope all is well.

Good news that today we have an update about Fusion 360 version 2.0.16007 which has a fix about the issue you reported.

Could you please upgrade to latest to have a try? It should work for you now without any extra steps.

 

Thank you very much for your reporting and so sorry for any inconvenience.

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 7 of 13
furaTT4KY
in reply to: sh9WZ6F

Same issue... Fusion is up to date. All three transistros are from the same library, same types, same values, same rotation, same pcb side. Windows in czech, Fusion in english.

 

Removing the transistor in the schematic and inserting it again will not help. Change rotation and postion also do not help.

 

Version:

Fusion 360 2.0.16007 x86_64
Windows 10 Pro 21H2 (19044.2846)

 

 

 

furaTT4KY_0-1682503929224.png

furaTT4KY_1-1682504151855.png

 

Message 8 of 13

Hi @furaTT4KY ,

 

Sorry to hear about.

Could you please remove the 3D PCB link firstly from 2D PCB and then push to generate a new 3D PCB to have a double check?

HelenChenElectronicsQA_0-1682504864054.png

 

Looking forward to your feedback.

Best regards,

Helen

 



Helen Chen
Principle QA for Fusion 360 Electronics
Message 9 of 13

If break 3D PCB link still doesn't help, could you please change the OS region to English and have a double check?

Looking forward to your feedback.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 10 of 13
furaTT4KY
in reply to: sh9WZ6F

No, that's not possible. I have many other assemblies and models linked to the PCB and I don't want to destroy the link.

 

I made a copy of the PCB (Save as) and then export to 3D and that fixes the 3D model.


How to grant this so that I don't have to break the binding between the models?

 

Message 11 of 13

Hi @furaTT4KY ,

 

Understood.

Could you please try below steps to have a check?

1. In 2D PCB > Push to 3D PCB > Click the 3 dots icon next to Components in the Push to 3D PCB command panel > Click Exclude All > Push

Screen Shot 2023-04-26 at 21.36.58.png

2. After it's pushed to 3D PCB, there is no 3D models show up which is as expected

3. Back to 2D PCB

4. Push to 3D PCB > Click the 3 dots icon next to Components in the Push to 3D PCB command panel > Click Include All > Push

Screen Shot 2023-04-26 at 21.37.19.png

5. Now the 3D PCB should have the 3D Models now, let's check the result for those transistors.

 

Thank you very much for your time.

Looking forward to your feedback.

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics
Message 12 of 13

Thanks for the response, this procedure works great. All components are now displayed correctly and model linkage has been preserved.

Message 13 of 13

Hi @furaTT4KY,

 

Awesome! Thank you very much for your feedback.

Glad to see that works!

 

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report