Community
Fusion Electronics
Working an electronics project and need help with the schematic, the PCB, or making your components? Join the discussion as our community of electronic design specialists and industry experts provide you their insight and best practices.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

3D model does not show for "footprint only" devices.

7 REPLIES 7
Reply
Message 1 of 8
jesper8W75R
346 Views, 7 Replies

3D model does not show for "footprint only" devices.

Device might be the wrong word, as the point is that there IS not device, and NO symbol.
A "footprint only" thing is something like a fiducial, or a special mounting hole, or maybe a logo.
These are made as a footprint only, as there is no corresponding schematic symbol.

They are added to the board directly in the board editor.


The problem is that the 3D model of these (if any are assigned) does not display correctly.
UNLESS, there is a schematic symbol.


Let me illustrate - I tried playing around with a fiducial.

I have TWO fiducial footprints, FIDUCIAL_ROUND and FIDUCIAL_ROUND2, they are similar in footprint.
FIDUCIAL_ROUND does not have any 3D model, which is how it would normally be used.
FIDUCIAL_ROUND2 have, for illustrative purposes, a 1mm solid cylinder as a model.

Screen Shot 2022-04-17 at 10.08.02.png FIDUCIAL_ROUND2

 


I put these on a PCB.
The first one is FIDUCIAL_ROUND which has a schematic symbol and added in the schematic editor (the symbol is just a simple drawn square).
The second is the SAME FIDUCIAL_ROUND, but added in the board editor.
And the third one is the above shown FIDUCIAL_ROUND2.

 

 

Screen Shot 2022-04-17 at 09.57.04.png

 

 

When pushing to 3D PCB, and checking components, I get this:


Screen Shot 2022-04-17 at 09.57.19.png

Which is incorrect. U$2, FIDUCIAL_ROUND2 definitely has a 3D model, as seen above.
And, F1 and U$1 is the SAME fiducial, just with and without schematic symbol.

 

Interestingly enough, after the push, I get this:

Screen Shot 2022-04-17 at 10.07.37.png

 

Now it realized that FIDUCIAL_ROUND2 actually HAD a 3D model and doesn't complain.
That FIDUCIAL_ROUND does not have a 3D model is kinda correct, as it doesn't, but it is the SAME as the used for F1, with the schematic symbol, and it doesn't complain about that.

 

And here is the 3D view:

Screen Shot 2022-04-17 at 10.23.39.png

Look Ma! No 3D models! Or actually, ugly boxes. Not what I expected.

Now, the observant reader would have seen that I checked "3D PCB with canvases" when pushing to 3D PCB.
That is a LOT faster, so I just used that.

Now, if unchecking that, to get a REAL NICE LOOKING PCB, you get this:

Screen Shot 2022-04-17 at 10.23.17.png

 

Huh?
Where did my fiducial go?

Well, there's another juicy bug in Fusion, which they claim they'll be fixing any year now.
It's only been a year since it was reported the first time, so...

I guess you can't expect much for the money you pay.

Have a great Sunday, folks.

7 REPLIES 7
Message 2 of 8
yiqiu.han
in reply to: jesper8W75R

HI, @jesper8W75R 

 

Thanks for providing detailed steps, that's really useful for us to diagnose the status.

 

The first one is FIDUCIAL_ROUND which has a schematic symbol and added in the schematic editor (the symbol is just a simple drawn square). The package information shown in the PCB components list is correct. The empty 3D package file would also result in check status in PCB component list. Shown as empty footprint in 3D PCB looks like meets your demand.

 

The second is the SAME FIDUCIAL_ROUND, but added in the board editor. And the third one FIDUCIAL_ROUND2 have, for illustrative purposes, a 1mm solid cylinder as a model. (I usppose this one is also added in the board directly).  The package information shown in the PCB components list is missing for above mentioned two devices. The reason why it is rendered as the default box in 3D PCB is that it has been added in the board editor directly. This is a recent regression that comes with the new place part panel. I will bring your posts to the development team and highlight this issue again.

 

If our prediction is not very accurate. Would you please share design project and library correspond with us from Fusion team hub for analysis? (yiqiu.han@autodesk.com  alina.peng@autodesk.com)

 

-Yiqiu

Message 3 of 8
jesper8W75R
in reply to: jesper8W75R

Thanks @yiqiu.han , I added you both to a Bug Tests Project, the Fiducial design is in there, together with a library with the footprints e.t.c.
It's not the same as from the pictures as I had deleted those files, but I recreated it and it works the same.

Adding you to this project, I found a couple of issues:

1. It is not possible to share a FOLDER. Only a PROJECT.
As I have only a very few projects, to avoid messing up the "flat" structure of the main data panel, I have all my designs in subfolders. 10-20 for Electronics so far, will be several hundred, if I move over old projects.
And for my CNC, I have also about 10 subfolders for parts, screws e.t.c.
This is a SERIOUS drawback.
I had to create a special Bug Testing project to be able to share these files with you.

2. A Folder cannot be "Moved".
You have to go to the destination, create a folder with the same name, then move the contents of the source folder to the new destination folder.
Reminds me of something like Windows 1.0 or so.
I am SURE you can do better.

Message 4 of 8
yiqiu.han
in reply to: jesper8W75R

Hi, @jesper8W75R 

 

Thanks for sharing the data with us. This is very convenient for us to investigate the status.

I have checked the files in the folder. 

 

The first one on the board is FIDUCIAL_ROUND. Added from the schematic.

The second one on the board is also FIDUCIAL_ROUND. Added from the board directly.

The third one on the board is FIDUCIAL_ROUND2. Added from the board directly.

 

Looked into the library correspond, both FIDUCIAL_ROUND & FIDUCIAL_ROUND2 has linked 3D package(although I have no access to them). In the PCB component list, we detect the existence of urn to show the availability of 3D package, since checking local file provides the best performance velocity. This means all devices that contain 3D package added from the schematic would be shown as checked status in the list. From my side, I still see the default box on 3D PCB is I have no access to 3D models, they locate in a different folder for which I have no permission.

 

The package information shown in the PCB components list is missing for above mentioned two devices. The reason why it is rendered as the default box in 3D PCB is that it has been added in the board editor directly. As I mentioned in the previous comment, This is a recent regression that comes with the new place part panel. 

 

The only new problem I have observed is that Polygon, Line & Acr in footprint are not rendered properly in 3D PCB, this is a known issue for our development team, and we have a plan to fix it in the coming releases.

 

Thanks,

Yiqiu

 

Message 5 of 8
jesper8W75R
in reply to: yiqiu.han

Yes, I hope there will be changes, so it is possible to add things in the board editor only, with or without 3D packages.
The funny thing here is that you cannot access the 3D packages, as there IS no 3D packages, in that way that I have never made any. But there is the default, that is just the sketch footprint. Anyway, it doesn't render properly.


"The only new problem I have observed is that Polygon, Line & Acr in footprint are not rendered properly in 3D PCB, this is a known issue for our development team, and we have a plan to fix it in the coming releases."

Yes, I reported this and several related issues in August last year and again a couple of weeks ago, as nothing had happened.
It would be nice to see it solved someday.
But, I have learned not to expect much from Autodesk.

 

Message 6 of 8
yiqiu.han
in reply to: jesper8W75R

I cannot access the cylinder 3D model you mentioned, the reason should be the hub/folder it locates I have no read access.

We have already planned to enhance the footprint problem mentioned in the coming future, and I will let you know once the problem is resolved.

 

-Yiqiu

Tags (1)
Message 7 of 8
jesper8W75R
in reply to: yiqiu.han

@yiqiu.han 
Yeah, well, the reason you cannot access that, is a result from your design of Project structures, libraries and models.

I am not going to give you access to ALL my projects because you need to look at ONE thing.


I'm looking forward to a solution to the footprint issue.

As well as my other 40 but reports.

 

Message 8 of 8

Hi @jesper8W75R ,

 

Hope all is well.

 

Good news that latest Fusion Production build 2.0.15775 is release today, which has an improvement about the issue you reported.

Could you please upgrade to latest version and have a try?

Hope it helps.

 

Hope you have a great day.

Best regards,

Helen



Helen Chen
Principle QA for Fusion 360 Electronics

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums