Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Visual Studio broke API, no longer able to import adsk

5 REPLIES 5
Reply
Message 1 of 6
dewaine50
695 Views, 5 Replies

Visual Studio broke API, no longer able to import adsk

Hi, I'm used to using the Spyder IDE and recently one of the updates to fusion removed my familiar developement process WITHOUT MY CONSENT OR ANY OPTION TO REVERT now nothing works. I'm getting an error where one of the libraries no longer exists. How do have this go back to normal? Am I even allowed to revert back to SPyder so this doesn't happen?

    import adsk.core, adsk.fusion, adsk.cam, traceback, sys, re
ModuleNotFoundError: No module named 'adsk'
Tags (2)
5 REPLIES 5
Message 2 of 6
PinRudolf
in reply to: dewaine50

Hi Dewaine,

 

I'm getting the same error message when I run the script in the terminal, however when I start the script from Fusion everything works as expected. Unfortunately you will have to start scripts from within Fusion now. You can still run in the terminal for syntax checking. When I do have a syntax error the terminal shows me the correct error and the ModuleNotFoundError is gone.

 

Also see the help files on VSCode. 

Message 3 of 6
Nilesh.Mohite
in reply to: PinRudolf

Hi @dewaine50  & @PinRudolf ,

Now with October release there is support for running/rerunning script from VSCode when launched in edit or debug mode from fusion.

Please refer below post by @goyals 

https://forums.autodesk.com/t5/fusion-360-api-and-scripts/some-vscode-fixes-delivered-with-fusion-oc... 

Thanks and Regards,

Nilesh


Nilesh Mohite
LinkedIn

If my answer helped you, please use  ACCEPT SOLUTION .
Also be generous with Likes!  Thank you and enjoy!

Message 4 of 6
dewaine50
in reply to: Nilesh.Mohite

Why can't I get Spyder back? Why is that outright not an option?

Message 5 of 6
JesusFreke
in reply to: dewaine50

You can download a standalone version of Spyder and use it separately, but it won't have any integration with Fusion 360.

Message 6 of 6
dewaine50
in reply to: JesusFreke

That is the worst possible answer. Is Spyder just not supported? If so why. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report