Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Spyder unable to install

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
saikishoret99
849 Views, 4 Replies

Spyder unable to install

Hi, I am Kishore. I have been using Fusion 360 since 6 months.Today I encountered a problem regarding scripting I am pretty much a newbie in programming. Today I tried to follow a tutorial and had tried to open a Spyder in F360, then it showed me the first image and then displayed error(second image), and  I am also attaching the log text file. Few months back, I was just checking scripting and  when I tried to open a script file and Fusion installed Spyder and opened the script and I pretty much not looked into scripting there after, and when tried today I got this error. In middle I upgraded my windows  OS from 8.1 to 10. And I have python 3.4 installed on my laptop and added in the path variables. please help me to reslove this issue.

Screenshot (27).png

Screenshot (28).png

4 REPLIES 4
Message 2 of 5
marshaltu
in reply to: saikishoret99

Hello,

 

Thank you for reporting issue to us. From install log, it shown Spyder has been installed. But I am not clear why Fusion 360 still prompted to install it. I need some more information to narrow the issue down:

 

1. Please go to the folder "C:\Users\<user>\AppData\Local\Autodesk\webdeploy\shared\Spyder" and check if Spyder has been installed?

    If it has been installed, there are quite some Python files under the folder and its subfolders.

2. Please check if the file "C:\Users\<user>\AppData\Local\Autodesk\Autodesk Fusion 360\delayedAppInfo" existed or not in your machine?

    If it existed, please post the file in the thread for investigation.

    Meanwhile you can also try to close Fusion 360 and delete the file and relaunch Fusion 360. It would help bring Spyder back.

 

Thanks,

Marshal



Marshal Tu
Fusion 360 Developer
Autodesk, Inc.

Message 3 of 5
saikishoret99
in reply to: marshaltu

Thanks very much for the reply.Deleting the file worked. I followed your instructions. Step1 : Yes, I find  many python files and subfolders in spyder folder and Step2 : I am also attaching the file you had asked to attach. Thank you.

Message 4 of 5
jctreichler
in reply to: marshaltu

Hi Marshal,

I am having a similar problem. When I create a new script and click edit Spyder does not open. I get no error dialog box. I uninstalled Fusion360 and reinstalled but the behavior is the same. When I go to "C:\Users\<user>\AppData\Local\Autodesk\webdeploy\” there is no shared folder, only “meta” and “production”. There is also no folder "C:\Users\<user>\AppData\Local\Autodesk\Autodesk Fusion 360\delayedAppInfo"

 I have rebooted Fusion many times.

I do have Anaconda2.7 installed with Sypder. Could this be interfering?

I am using Windows 10 and Fusion 360 “2.0.7046”.

Thanks - John

Message 5 of 5
jctreichler
in reply to: jctreichler

I updated VS Code and installed python version 2019.9.34911 and it works!

I could use some tips on troubleshooting because I could find no errors in the logs and no errors were popping up. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report