Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Removed AddIn will not run after reinstall on mac

3 REPLIES 3
Reply
Message 1 of 4
jinschoi
273 Views, 3 Replies

Removed AddIn will not run after reinstall on mac

I was trying to uninstall and reinstall an addin, and while poking around right clicked the addin in the Add-Ins tab and Removed it. This appears not to actually remove any files but just records that it's not to be run.

 

After reinstalling, it still does not get loaded and there doesn't appear to be a way to reset the removal from the UI. I found a JSLoadedScriptsinfo which has a list of all my plugins with "isRemoved":true set on the one I had removed. Changing that to false allowed it to run the addin again.

 

There should be a way to un-remove an addin. If there is, I'd like to know how.

Tags (2)
3 REPLIES 3
Message 2 of 4
goyals
in reply to: jinschoi

There is '+' button in both the tabs in 'Scripts and Add-in' dialog in Fusion. You can click on it to select the removed add-in again.



Shyam Goyal
Sr. Software Dev. Manager
Message 3 of 4
jinschoi
in reply to: goyals

Actually not the case. I just tried it, here's what happens:

 

I'm using the Shaper Utilities add-in as my example. I right click and Open File Location to show me where it lives (~/Library/Application Support/Autodesk/ApplicationPlugins/ShaperUtilities 360.bundle, which is actually a symlink to ~/Library/Containers/com.autodesk.mas.fusion360/Data/Library/Application Support/Autodesk/ApplicationPlugins/ShaperUtilities.bundle), then I Remove it.

 

Clicking "+" takes me to ~/Library/Application Support/Autodesk/Autodesk Fusion 360/API/AddIns. If I navigate back around to where the add-in lives, it is grayed out and does not give me the ability to re-enable it.

Message 4 of 4
goyals
in reply to: jinschoi

I am able to understand the problem now. Atleast re-installing the add-in should show it again in the dialog or ideally we should allow to select the *.bundle file in the file dialog on clicking '+' button. I created a ticket in our internal bug tracking system and here it's number UP-42291. We will investigate it. Thanks for reporting it.



Shyam Goyal
Sr. Software Dev. Manager

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report