Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Naming convention for JointMotion parameters

Message 1 of 1
188 Views, 0 Replies

Naming convention for JointMotion parameters

There are a couple of properties of the JointMotion class, namely 

which I think ought to have different names. The word "rotation" implies an ACTION, as in "rotate the object from this angle (or maybe whatever is the current angle) to this other angle".  But what's actually being specified (or accessed) via these two properties are ANGLES, not rotations. The rotationValue actually sets what ANGLE you want the object to be at, and returns the current angle of it. The rotationLimits specify the RANGE of angles at which the object can be set. It actually says nothing about any kind of visual rotation operation that the script my attempt (as in doing a for-loop that successively increments the angle of the Joint) .

Now, no doubt changing those parameter names would likely break a lot of existing scripts, but at the very least I think that the descriptions of those parameters should be changed to make it clearer that what you're specifying are  ANGLES and the range of valid specifiable angles, and it really has nothing to do with the rotation of the joint.

So far I've only worked with Joint control, but this issue of confusing an action with a position may well exist with other kinds of Joints.


Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th

Autodesk Design & Make Report