Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Keyshot8 Plugin for Fusion 360

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
pilotman737
2240 Views, 7 Replies

Keyshot8 Plugin for Fusion 360

I've upgrded to Keyshot 8 and the plugin is giving me an error I can't get around this error, if anyone has any ideas please let me know. I've re-installed both Fusion and keyshot but the same error persists. Pulling my hair out. I can import into keyshot but I loose the detail generated in Fusion, such as split faces and materials added. 

 

"Live link failed. Reason: Failed to connect. Please check your Keyshot installation and live link settings."

 

OSX Mojave

Keyshot 8

iMac PRO (2017) 32GB MEMORY

1TB SSD

7 REPLIES 7
Message 2 of 8
goyals
in reply to: pilotman737

Probably you need to update add-in as well. There is a separate add-in for Keyshot 8 available here https://apps.autodesk.com/FUSION/en/Detail/Index?id=1287458435152262401&appLang=en&os=Mac&autostart=...



Shyam Goyal
Sr. Software Dev. Manager
Message 3 of 8
pilotman737
in reply to: goyals

I have the Keyshot 8 Plugin, which to my knowledge is up to date. I have been writing to Luxion and their response to me was to go to Keyshot 8: Preferences > General > and scroll down to Live Linking section to make sure it is enabled. In my case it is enabled. I have Ports 3141 - 3151 assigned but I don't know what that means.

 

I have replied to Luxion again and they have not returned my message yet but I expect they will later today. I will reply if I find a solution. I have tried all of the other file formats for importing into Keyshot but they all lose significant detail in the translation, especially with assemblies and materials. The plugin is the only method that captures all the detail.    

 

Message 4 of 8
pilotman737
in reply to: pilotman737

I was on line with Luxion support and they could not remedy the problem. The programmer that worked on the plugin is reviewing the situation and they are going to get back with me.

Message 5 of 8
xAragornx
in reply to: pilotman737

I'm Having a similar issue where th import via the Key Shot 8 Plugin from Fusion 360 is either
1) importing the model into the scene hierarchy yet there is no 3D objects or
2) the plugin stalls out and Fusion 360 crashes

Was there ever a resolution to this problem?

Message 6 of 8
pilotman737
in reply to: xAragornx

In my particular situation I had what I believe to be legacy mac migration issues. Fusion 360 to Keyshot 7 + Plugin worked well for me. I bought a new iMac Pro with Mojave and upgraded to Keyshot 8 all at the same time. After a frustrating period of time dealing with crashes and incompatibility, the solution for me was to do a fresh Mojave install and a fresh install of all my programs. After doing this the Fusion to Keyshot 8 worked as it did with Keyshot 7.  With the plugin I still have a few issues but nothing so far I can't work around.

Message 7 of 8
xAragornx
in reply to: pilotman737

Ironically I am also having issues with using older files saved within Key Shot 6 to the new Key Shot 8. The problem seems to be with importing geometry from fusion 360 using the Fusion 360 to Key Shot 8 Plugin. For some reason, the position and scale are not importing correctly / to the specifications of how the geometry is positioned within Fusion. 

I'll most likely have to get Autodesk's help with this.

Thanks for the Reply!

Message 8 of 8
pilotman737
in reply to: xAragornx

I too have problems with the positions of components with some assemblies. I have to use the move command in Keyshot to put them back in place. If you get a solution please post.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report