Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fusion Auto-Updated, none of my python scipts/add-ins will run (source code available)

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
jakedbirk
137 Views, 2 Replies

Fusion Auto-Updated, none of my python scipts/add-ins will run (source code available)

Hello all, 

 

I have been aware that the python api was getting updated from 3.7 to 3.9 for quite some time now. It was my understanding that as long as the source code was available and you didn't use any pyc files, you did not have to do anything to be prepared for this update.

 

I've been using the api on a daily basis and believe (although I could be wrong) that the python in fusion had already been updated to 3.9 a while ago (as in a few days/weeks). Today the fusion 360 logo and start screen have changed, and none of my code runs (as in literally nothing happens when I press run)! This actually happened around 9pm, I was presenting my code at an expo (where it worked fine) at 5 pm.

 

To try and identify the problem, I tried to create a new script in python and see if it ran. Not even the default "hello script" will run for me! (and once again this is with a new script not an existing one). 

 

#Author-
#Description-

import adsk.core, adsk.fusion, adsk.cam, traceback

def run(context):
    ui = None
    try:
        app = adsk.core.Application.get()
        ui  = app.userInterface
        ui.messageBox('Hello script')

    except:
        if ui:
            ui.messageBox('Failed:\n{}'.format(traceback.format_exc()))

#When I try to run this code nothing at all happens

 

interestingly enough, some default scripts, like the bottle script run for me. Others, such as the spur gear, do not. 

 

I would be very appreciative if anyone could offer me guidance on why this is happening. I am at the end of a semester-long university course revolving around a fusion 360 API project that no longer runs!

 

Grateful for any help, 

Jake Birkmaier 

 

P.S. I am on Windows 10

2 REPLIES 2
Message 2 of 3
Rushikesh.kadam
in reply to: jakedbirk

@jakedbirk The April 19 update had some issues. Can you uninstall and reinstall Fusion 360 to check if it resolves the problem? Apologies for the inconvenience caused. 

 

 ---------------------------------------------------------------------------------------------------------------------------

If my reply was helpful, please click the "Accept as Solution" button. It helps others get the answer quickly! A "Like" is always welcomed




Rushikesh Kadam
Senior QA Engineer
Quality Assurance
Autodesk, Inc.


Message 3 of 3
jakedbirk
in reply to: Rushikesh.kadam

Thank you for this suggestion, it worked but all of the logos & startup went back to the pre-update look (which is fine, just a little strange/confusing). 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report