Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Fusion 360 to UGS Failed to post

2 REPLIES 2
Reply
Message 1 of 3
kulpio
201 Views, 2 Replies

Fusion 360 to UGS Failed to post

Hi everyone,

I am trying to get UGS Plugin to work with Fusion 360. I did everything I had to do to install the plugin (which is in my F360 plugin library) and followed the instruction on the Post to UGS pop up window.

However, I get the following error (screenshot attached).

Would anyone have an idea on how to get it to work, or what I did wrong?Also attached my "Post to UGS" pop up settings.

My CNC machine is a Shapeoko3 XL

I run on Mac

F360 has the latest update.


Post-to-UGS-Window.png

Error-Text.png

2 REPLIES 2
Message 2 of 3
kulpio
in reply to: kulpio

So I found the issue. It was my path for the UGS which should not include "Macintosh HD" for some reason. 

However now I get the following errors in UGS when I run the job:

An error was detected while sending 'T5M6': (error:20) Unsupported or invalid g-code command found in block. Streaming has been paused.

 

So why is it creating invalid g-code? 

Should I insert my tool library into UGS as well so it supports them?

... very confused and not very good at this.

Message 3 of 3
BrianEkins
in reply to: kulpio

It's best to ask the developer of the add-in.  No one here has any detailed information about specific add-ins.  This forum is for general questions about the Fusion 360 programming interface, not the add-ins that use it.

---------------------------------------------------------------
Brian Ekins
Inventor and Fusion 360 API Expert
Website/Blog: https://EkinsSolutions.com

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report