Community
Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot select anything while using the texture map controls

1 REPLY 1
Reply
Message 1 of 2
steeb88p
90 Views, 1 Reply

Cannot select anything while using the texture map controls

Hello! First time posting on the forums.

Actually, It's my first time posting on any forum!

So here we go.

(I Hope I'm on the right board and not breaking any rules I don't know about.)

 

I'm trying to make a render of an assembly using one of the 3d-Wood materials.

I'm in the Rendering Workspace.

I have all already successfully applied the material to my component and I would like to change the orientation of the wood grain. However when I select the "Texture Map Controls" tool, I can no longer select any body's or components.

 

Things I tried and checked:

  • I checked that the box labeled "Selection" in the Texture Map Controls pop up window is blue and ready for me to select something 
  • I have checked my that my selection filters are set correctly.
  • I have checked my component is not set to "Unselectable"
  • I tried using right click "Repeat Texture Map Controls" in the design workspace (same problem)
  • I tried selecting the component via the browser 
  • I tried selecting selecting the body via the browser.
  • I tried opening up the component to edit on its own and the "Texture Map Controls" tool works there! Just not in my assembly!

I'm not sure what I'm missing.

I would like to be able to edit the grain while I'm setting up the render of the assembly and not have to go into the component and keep tweaking it to edit it 

 

I'm attaching a screen shot because it feels smart.

 

Something else I noticed if is that if I change the material back to satin steel in while editing to component on its own, save, then go back to the assembly, and use "Get latest version" on the component it stays as the 3d maple material I set it to awhile ago. but if I change it to a different wood  using the same process it will change it to the wood i selected. clearly there is something missing

This is my first time using fusions rendering and materials for real.

 

Thankyou for coming to my Ted talk.

Send help.

 

Ps; I'm so new to this forum thing I have no clue what to put as "labels" and "tags" for this post . Recommendations for what to put there next time would be great (and any other tips for forum posting).

1 REPLY 1
Message 2 of 2
BrianEkins
in reply to: steeb88p

Welcome to the forum. You'll find there are a lot of people here that are happy to help.

 

There are several different forums related to Fusion. This one is intended for questions related to the API (programming interface). You'll have a better chance of having the right person see questions like this in the Fusion Design, Validate & Document forum.

 

However, I think I know what the problem is. All of the components in your assembly are from external references. Fusion doesn't let you edit the appearance of external references. You'll either need to open the component you want to edit and make the change in that file, or you can also do an "Edit in Place" to make the change, but you need to be in the Design workspace to do that. It's the little pencil beside the component in the browser.

---------------------------------------------------------------
Brian Ekins
Inventor and Fusion 360 API Expert
Website/Blog: https://EkinsSolutions.com

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th


Autodesk Design & Make Report