Fusion API and Scripts
Got a new add-in to share? Need something specialized to be scripted? Ask questions or share what you’ve discovered with the community.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannot Attach Xcode to Fusion

Message 1 of 8
898 Views, 7 Replies

Cannot Attach Xcode to Fusion

API support seems super buggy. I switched to using C++ because Python editing is broken, followed these instructions for debugging...


...and get the following error when I try to attach Xcode to Fusion 360...



Could not attach to pid : “1626”
Domain: IDEDebugSessionErrorDomain
Code: 3
Failure Reason: Error 1
Error 1
Domain: IDEDebugSessionErrorDomain
Code: 3


Message 2 of 8
in reply to: neil.mendoza

May i ask what was broken with python? were you using it with vscode? If so there is a known issue that has a simple workaround.


See this thread >

Matt Smith
Software Engineer - MSmithDev -
CAD/CAM/CNC - Micro Insert Inc. -
Message 3 of 8
in reply to: Mattxer

Thanks, I actually gave up on Python and wrote it in C++ debugging with a log file. Will try Python again next time I need to script something.

Message 4 of 8

I have the same problem, porting our add-in from windows to Mac and can't debug. Is there still no solution to this?


Could not attach to pid : “1935”

Domain: IDEDebugSessionErrorDomain

Code: 3

Failure Reason: Error 1

User Info: {

    DVTRadarComponentKey = 855031;

    RawLLDBErrorMessage = "Error 1";


Message 5 of 8
in reply to: rolandas.vegis

Hi  @neil.mendoza , @rolandas.vegis , @Mattxer

I had the same problem with debugging my add-in on macOS Catalina (running on VirtualBox). Turning off SIP (or System Integrity Protection) solved it.

You should be very careful about disabling SIP, because it is one of the primary mechanisms which macOS uses to protect itself (it is introduced in El Capitan-2015). So remember to re-enable SIP when you've finished your task.

Message 6 of 8
in reply to: rolandas.vegis

Is it possible that you don't have developer mode enabled? You can try running the following in a terminal:


sudo DevToolsSecurity -enable


Shot in the dark...



Kris Kaplan
Message 7 of 8
in reply to: KrisKaplan

Hi @KrisKaplan 

Before turning off SIP I googled and found "sudo DevToolsSecurity -enable" and tried it. But in my case it did not work.

I also tried many other suggestions. Only after turning off SIP, Xcode was able to attach to Fusion 360 process. My macOS is running on VirtualBox. Perhaps for other cases enabling DevToolsSecurity will work.

Message 8 of 8
in reply to: nnikbin

Had developer mode enabled, didn't do anything. Disabling SIP, does indeed work, thanks.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk DevCon in Munich May 28-29th

Autodesk Design & Make Report