Community
Forma Forum
Welcome to the Forma Community. Give feedback, report bugs, and tell us your ideas about Autodesk Forma
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Testfit Extension

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
caoimhe_loftus
193 Views, 7 Replies

Testfit Extension

Hi - when I try running the Testfit Extensions I get the following error: "Loading generator engine failed. Reload page to retry". I've tried reloading and a different browser but still get the same error.

Caoimhe Loftus

EESignature

Labels (1)
7 REPLIES 7
Message 2 of 8

Hello!

 

I suspect something on your network might block the script from loading. Can you open developer tools (typically by pressing F12) and see if there's any more details there? You can also check the network tab there and look for a failed request - it might give you more insight into why it's failing.

Message 3 of 8

Hi - thanks for the reply - I can see multiple errors. I've attached a snip but this doesn't include all of them. Is this what you expected?

Caoimhe Loftus

EESignature

Message 4 of 8

The error message indicate that loading one of the resource files fails for you. It seems to be getting a HTML document instead of the code (WASM) file. I can't tell you why, but I expect that you will get a readable error by going directly to https://testfit-extension.io/park.wasm - but if not click on "Network" tab in the window you opened,...

Message 5 of 8

I don't get any errors on that direct link - here are the network errors. I've filtered out the warnings. Let me need to see the detail for any of these.

 

errors network.png

Caoimhe Loftus

EESignature

Message 6 of 8

Try checking out the network tab. See https://learn.microsoft.com/en-us/microsoft-edge/devtools-guide-chromium/network/

 

You might need to refresh after opening the network tab. What you are looking for is the request for park.wasm, and you want to look at the response of it. Since it seems to be a HTML document due to the error you posted, I would guess it might be for example a corporate firewall that has replaced the URL with some other content, hopefully it will give you more information. In that case (or probably any case) you likely need to reach out to your internal IT to figure out what's going on.

 

For reference - it should look something like this (note that this is from Chrome):

 

henrik_steenJL382_0-1712143057059.png

 

henrik_steenJL382_1-1712143094748.png

 

Message 7 of 8

Thank you - I got it to work by temporarily disabling my firewall.

For reference this was the information I got when I checked.

Network headers.jpg

Caoimhe Loftus

EESignature

Message 8 of 8

I see. I'm mostly interested knowing what the "Preview" / "Response" tab shows (the contents the browser receives). It would also be useful to know what firewall you are using that is causing this, so we're able to guide other users in the same situation, as well as reproduce it to see if there's a way we can work around it. Feel free to reach out to me in a DM to share more details around this.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report