EAGLE Forum
Welcome to Autodesk’s EAGLE Forums. Share your knowledge, ask questions, and explore popular EAGLE topics.

EAGLE Forum

Reply
Post 1 of 16
Accepted Solution

Unable to launch Eagle

848 Views, 15 Replies
01-19-2017 08:58 AM

Hello,

 

I try to use Eagle 8.0 but I am not able to launch the application.

 

When I click on eagle.exe the Sign in window appeared:

 

Sign_in.png

 

I enter my email and my password. I click on "SIGN IN" button and ....

 

Abort.png

 

Thank you for your help.

 

I am working on Win x64

 

I have exactly the same issue. Running on Windows 10 64bit (1604 update).

After entering password, eagle exits with the same error. Unfortunately I have not found a solution yet.

So for the time being I am staying on Eagle 7.7. Have been fortunate to download latest version before Autodesk decided to pull them of the face of Internet. :-( So much for supporting existing Eagle customers. :-(

Hello fredSAZZ5,

 

You need to setup an Autodesk Account. You can setup your account by visiting accounts.autodesk.com. Once you have created an Autodesk account you will use that one to sign into EAGLE.

 

Please accept as solution if my post fully resolves or you issue, or reply with additional details if the problem persists

 

Best Regards,

 

Hi Martin,

You can always download older versions of EAGLE from ftp.cadsoft.de/eagle/program. 7.7 Has not been wiped off the face of the internet you just have to know where it is. ;)

Thank you for the link. Just found links, tha actually work, in another post here. :-)

 

Unfortunately the issue with v8 is what interests me more. I have Autodesk account. I am logged in already on the webpages, my email is verified. Yet still I can't launch the new Eagle 8. Is Free edition working already? After reading some posts here I am under impression that it might be still "work in progress" said mildly. Not sure if I want to throw money down the Autodesk throat just for trying the new features.

 

Seems like we will be staying on 7 series with our perpetual license if there is not working solution. Old licenses just worked, not like this "new better model". Quite a disappointment.

Same problem when using my autodeskaccount.

 

/S

Hi Martin,

 

Something is wrong then, if you have an Autodesk account it should just work. Did you recently create your account? It might take a few hours for everything to trickle through the system.

 

There are always a few kinks in new implementations, however what's really important is how quickly we resolve them. Once you are able to login, we would have to be down for 14 consecutive days to interrupt your work. That hasn't happened at autodesk since they changed over to licensing so you won't have to seriously worry about your work being interrupted.

 

I'll look into this.

 

Best Regards,

 

It has been few hours now and I am still unable to run Eagle. A system that needs few hours to crunch login data? Maybe in the '70, but this is 2017 and i find that hard to believe. Few minutes in bad weather, but not hours.

 

You say I have not to worry about your servers being unreachable to refresh licensing data. Funny when you realize there must be a reliable path over half the planet to some server so I could work, literally. And right now I even would not be able to work in case I had to replace a computer and reinstall because of a hardware fault. The whole "always connected" concept does not quite fit when downtimes are not tolerable. This is exactly I was affraid would happen when acquisition by Autodesk was announced. And it happened despite affirmations that not much will change in licensing.

 

But back to my current issue. Here are steps to reproduce. I will try to reproduce on a virtual machine tomorrow (UTC+0100 here).

* download and run Win 64bit installer

* finish installation, but do not restart (I have been busy with something else)

* launch Eagle (forgot it requested restart, WHY?! on Earth it requires reboot of the whole system ...)

* within eagle proceed with creation of new autodesk account

* -> first appearance of error message about invalid license after finishing the registration

* reboot system (remembered about reboot)

* -> any subsequent attempt to log into eagle fails with error "ABORT: invalid license"

 

I am able to sign in with my autodesk account on the website.

 

Environment: Windows 10 64bit Enterprise (update 1607) EN with cs_CZ locale settings and cs_CZ MUI installed.

 

Since I was curious, if there is some simple issue with network or something I captured some https traffic with your servers. It all seems to be working, altouhg there a few commented out lines in returned pages looking like some debugging leftowers.

 

Here is excerpt from the communication of what seemed relevant:

https://accounts.autodesk.com/Authentication/LogOn?resume=/as/ng00V/resume/as/authorization.ping&ack=tLMs***...

POST https://accounts.autodesk.com/Authentication/LogOn?resume=/as/ng00V/resume/as/authorization.ping&ack=tLMsCv***upa6bkA HTTP/1.1
Host: accounts.autodesk.com
Connection: keep-alive
Content-Length: 306
Accept: */*
Origin: https://accounts.autodesk.com
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.6.2 Chrome/45.0.2454.101 Safari/537.36
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
Referer: https://accounts.autodesk.com/logon?resume=/as/ng00V/resume/as/authorization.ping&spentity=null
Accept-Encoding: gzip, deflate
Cookie: optimizelyEndUserId=oeu14848***19r0.65093***322; cl-flags=cl-kmsi-enabled:1|cl-token-enabled:1; identity-prev-user=7yhnB8pP***fBT+aY=; _gat=1; _gat_UA-7938776-4=1; adsk_s_gpv=oxygen%3A%3Aaccounts%3Alogin%20successfully; s_visit=1; out=LH***3M; s_vi=[CS]v1|2C407A6***13199-40000***99E0[CE]; __RequestVerificationToken=cuo_YHA28Fx***pWCzTaxXlI1; optimizelySegments=%7B%223589050***22direct%22%7D; optimizelyBuckets=%7B%7D; _ga=GA1.2.17***47.148***35; flip-logo=true; optimizelyPendingLogEvents=%5B%5D; _ga=GA1.3.172***47.148***35
__RequestVerificationToken=_0F4LuRtpCwF3FO***f38lIO1AoD41&queryStrings=%3Fresume%3D%2Fas%2Fng00V%2Fresume%2Fas%2Fauthorization.ping%26ack%3DtLMs***pa6bkA&UserName=martin.darebny%40i***t.cz&Password=***&RememberMe=false

https://accounts.autodesk.com/authorize?resume=/as/ng00V/resume/as/authorization.ping&ack=tLMs***...

returned HTTP redirect 302 to:

https://auth.autodesk.com/as/ng00V/resume/as/authorization.ping?opentoken=T1RL***cIic83_SiUt&lang=cs

returned redirect 302 to:

https://contapi.circuits.io/123d-circuits/actions/forge/callback?code=bEO0n***qlQId&state=26__AND__%2F123d-circuits%2Factions%2Fforge%2Feagle__AND__a83a5e***a09

redirect this time 303 to:

https://contapi.circuits.io/123d-circuits/actions/forge/eagle?access_token=HP***R&refresh_token=Wp***Cn&token_type=Bearer&expires_in=86399&nonce=a83***09

HTTP/1.1 200 OK
Access-Control-Allow-Credentials: true
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept, X-AFC, X-Session, X-CSRF-TOKEN, Authorization
Access-Control-Allow-Methods: POST, GET, PUT, DELETE, PATCH
Content-Type: text/html
Date: Thu, 19 Jan 2017 20:50:46 GMT
Vary: Origin
X-Powered-By: Express
transfer-encoding: chunked
Connection: keep-alive
887
<!DOCTYPE html><html><head><meta charset="UTF-8"><title>EAGLE Online login</title><script type="text/javascript" src="qrc:///qtwebchannel/qwebchannel.js"></script><script type="text/javascript">//document.addEventListener("DOMContentLoaded", function () {
new QWebChannel(qt.webChannelTransport, function (channel) {
webAPIInterface = channel.objects.webAPIInterface; //global == bad
webAPIInterface.version(function(res){
//document.write('EAGLE version: '+res);
webAPIInterface.setEntitlements('LH***3M',
'martin.darebnyUQ4F3',
'martin.darebny@i***t.cz',
'Martin',
'Darebný',
'Wp9***Cn',
'HPr***KR',
'urn:autodesk.com:mobile:drapp urn:autodesk.com:services:acadws urn:autodesk.com:services:assetopt urn:autodesk.com:services:chargen urn:autodesk.com:services:geoloc2 urn:autodesk.com:services:infraworksmb urn:autodesk.com:services:infraworksord urn:autodesk.com:services:raas urn:autodesk.com:services:storage',
'65f65***2373b',function(result){webAPIInterface.startApplication();});
});
});
function escapeHtml(str) {
var div = document.createElement('div');
div.appendChild(document.createTextNode(str));
return div.innerHTML;
}
function getBRD() {
webAPIInterface.getBRD(function(res){
document.write(escapeHtml(res));
});
};
function loadLBR() {
//get the data from the content server
var xmlhttp=new XMLHttpRequest();
var url = "http://localhost:3002/123D-Circuits/actions/buildEagleLibrary?component=11290:1&component=11289:1&datamodel_version=5";
xmlhttp.open("GET", url);
xmlhttp.setRequestHeader("x-session","E2E***BC");
xmlhttp.setRequestHeader("x-afc","CR1ONL");
function loaded()
{
webAPIInterface.loadLBR(this.responseText);
}
xmlhttp.addEventListener("load", loaded);
xmlhttp.send();
//send the result to eagle
//webAPIInterface.getBRD(function(res){
// document.write(escapeHtml(res));
//});
};
function setLicence(licence) {
webAPIInterface.setLicence(licence,function(){
});
};</script></head><body></body></html>
0

As seen by Fiddler:

obrazek.png

 

If it can be of any help, I can send full unredacted trace privately.

 

I can confirm this, I've been trying to start EAGLE the whole day. After reading the previous post I edited my profile removing accented letters and finally I was able to run it.

Hi Jorge,

 

as mentioned in a different post, I have the same problem as Martin: abtaining a license with the autodesk account is not possible.

 

I created my autodesk account almost 12 hours ago. Things in the autodesk magic licenseing system should have settled now. But I still get the message, that the license is invalid.

 

Here I run eagle on linux OS.

 

 

With Regards,

Detlef

 

 

Thanks to martin.darebny... I changed the "é" in my surname directly on autodesk website and now it's working!

Hi Detlef,

Does your name on your autodesk account have any special characters? Any accents or non-latin characters? If it does then that needs to be changes as other have seen in this forum. A patch has been deployed for this I was told so it should behave differently now. However, the best solution right now is to change the characters.

Best Regards,

I wish I could even get a login screen -- the .exe hangs after the initial window frame is drawn, chews up a bunch of CPU time for a few moments and then it becomes unresponsive.  7.7 works fine.  Windows 10.  I even rebooted at one point, no change.

 

 

Just wanted to add my voice to this issue - as of today (24 Jan 2017) I am unable to launch Eagle without changing my name in my Autodesk Profile from

 

Ethan O'Connor

 

to 

 

Ethan OConnor

 

 

This workaround is fine but it would be great to have it addressed.

 

Thanks!

Post 2 of 16

Re: Unable to launch Eagle

01-19-2017 09:40 AM in reply to: fredSAZZ5

I have exactly the same issue. Running on Windows 10 64bit (1604 update).

After entering password, eagle exits with the same error. Unfortunately I have not found a solution yet.

So for the time being I am staying on Eagle 7.7. Have been fortunate to download latest version before Autodesk decided to pull them of the face of Internet. :-( So much for supporting existing Eagle customers. :-(

Post 3 of 16

Re: Unable to launch Eagle

01-19-2017 09:41 AM in reply to: fredSAZZ5

Hello fredSAZZ5,

 

You need to setup an Autodesk Account. You can setup your account by visiting accounts.autodesk.com. Once you have created an Autodesk account you will use that one to sign into EAGLE.

 

Please accept as solution if my post fully resolves or you issue, or reply with additional details if the problem persists

 

Best Regards,

 


Jorge Garcia
Product Support Specialist for EAGLE
Post 4 of 16

Re: Unable to launch Eagle

01-19-2017 09:45 AM in reply to: martin.darebny2
Hi Martin,

You can always download older versions of EAGLE from ftp.cadsoft.de/eagle/program. 7.7 Has not been wiped off the face of the internet you just have to know where it is. ;)

Jorge Garcia
Product Support Specialist for EAGLE
Post 5 of 16

Re: Unable to launch Eagle

01-19-2017 09:59 AM in reply to: jorge.garcia

Thank you for the link. Just found links, tha actually work, in another post here. :-)

 

Unfortunately the issue with v8 is what interests me more. I have Autodesk account. I am logged in already on the webpages, my email is verified. Yet still I can't launch the new Eagle 8. Is Free edition working already? After reading some posts here I am under impression that it might be still "work in progress" said mildly. Not sure if I want to throw money down the Autodesk throat just for trying the new features.

 

Seems like we will be staying on 7 series with our perpetual license if there is not working solution. Old licenses just worked, not like this "new better model". Quite a disappointment.

Post 6 of 16

Re: Unable to launch Eagle

01-19-2017 10:10 AM in reply to: jorge.garcia

Same problem when using my autodeskaccount.

 

/S

Post 7 of 16

Re: Unable to launch Eagle

01-19-2017 11:07 AM in reply to: martin.darebny2

Hi Martin,

 

Something is wrong then, if you have an Autodesk account it should just work. Did you recently create your account? It might take a few hours for everything to trickle through the system.

 

There are always a few kinks in new implementations, however what's really important is how quickly we resolve them. Once you are able to login, we would have to be down for 14 consecutive days to interrupt your work. That hasn't happened at autodesk since they changed over to licensing so you won't have to seriously worry about your work being interrupted.

 

I'll look into this.

 

Best Regards,

 


Jorge Garcia
Product Support Specialist for EAGLE
Post 8 of 16

Re: Unable to launch Eagle

01-19-2017 02:58 PM in reply to: jorge.garcia

It has been few hours now and I am still unable to run Eagle. A system that needs few hours to crunch login data? Maybe in the '70, but this is 2017 and i find that hard to believe. Few minutes in bad weather, but not hours.

 

You say I have not to worry about your servers being unreachable to refresh licensing data. Funny when you realize there must be a reliable path over half the planet to some server so I could work, literally. And right now I even would not be able to work in case I had to replace a computer and reinstall because of a hardware fault. The whole "always connected" concept does not quite fit when downtimes are not tolerable. This is exactly I was affraid would happen when acquisition by Autodesk was announced. And it happened despite affirmations that not much will change in licensing.

 

But back to my current issue. Here are steps to reproduce. I will try to reproduce on a virtual machine tomorrow (UTC+0100 here).

* download and run Win 64bit installer

* finish installation, but do not restart (I have been busy with something else)

* launch Eagle (forgot it requested restart, WHY?! on Earth it requires reboot of the whole system ...)

* within eagle proceed with creation of new autodesk account

* -> first appearance of error message about invalid license after finishing the registration

* reboot system (remembered about reboot)

* -> any subsequent attempt to log into eagle fails with error "ABORT: invalid license"

 

I am able to sign in with my autodesk account on the website.

 

Environment: Windows 10 64bit Enterprise (update 1607) EN with cs_CZ locale settings and cs_CZ MUI installed.

 

Since I was curious, if there is some simple issue with network or something I captured some https traffic with your servers. It all seems to be working, altouhg there a few commented out lines in returned pages looking like some debugging leftowers.

 

Here is excerpt from the communication of what seemed relevant:

https://accounts.autodesk.com/Authentication/LogOn?resume=/as/ng00V/resume/as/authorization.ping&ack......

POST https://accounts.autodesk.com/Authentication/LogOn?resume=/as/ng00V/resume/as/authorization.ping&ack=tLMsCv***upa6bkA HTTP/1.1
Host: accounts.autodesk.com
Connection: keep-alive
Content-Length: 306
Accept: */*
Origin: https://accounts.autodesk.com
X-Requested-With: XMLHttpRequest
User-Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.6.2 Chrome/45.0.2454.101 Safari/537.36
Content-Type: application/x-www-form-urlencoded; charset=UTF-8
Referer: https://accounts.autodesk.com/logon?resume=/as/ng00V/resume/as/authorization.ping&spentity=null
Accept-Encoding: gzip, deflate
Cookie: optimizelyEndUserId=oeu14848***19r0.65093***322; cl-flags=cl-kmsi-enabled:1|cl-token-enabled:1; identity-prev-user=7yhnB8pP***fBT+aY=; _gat=1; _gat_UA-7938776-4=1; adsk_s_gpv=oxygen%3A%3Aaccounts%3Alogin%20successfully; s_visit=1; out=LH***3M; s_vi=[CS]v1|2C407A6***13199-40000***99E0[CE]; __RequestVerificationToken=cuo_YHA28Fx***pWCzTaxXlI1; optimizelySegments=%7B%223589050***22direct%22%7D; optimizelyBuckets=%7B%7D; _ga=GA1.2.17***47.148***35; flip-logo=true; optimizelyPendingLogEvents=%5B%5D; _ga=GA1.3.172***47.148***35

__RequestVerificationToken=_0F4LuRtpCwF3FO***f38lIO1AoD41&queryStrings=%3Fresume%3D%2Fas%2Fng00V%2Fresume%2Fas%2Fauthorization.ping%26ack%3DtLMs***pa6bkA&UserName=martin.darebny%40i***t.cz&Password=***&RememberMe=false

https://accounts.autodesk.com/authorize?resume=/as/ng00V/resume/as/authorization.ping&ack=tLMs***...

returned HTTP redirect 302 to:

https://auth.autodesk.com/as/ng00V/resume/as/authorization.ping?opentoken=T1RL***cIic83_SiUt&lang=cs

returned redirect 302 to:

https://contapi.circuits.io/123d-circuits/actions/forge/callback?code=bEO0n***qlQId&state=26__AND__%...

redirect this time 303 to:

https://contapi.circuits.io/123d-circuits/actions/forge/eagle?access_token=HP***R&refresh_token=Wp**...

HTTP/1.1 200 OK
Access-Control-Allow-Credentials: true
Access-Control-Allow-Headers: Origin, X-Requested-With, Content-Type, Accept, X-AFC, X-Session, X-CSRF-TOKEN, Authorization
Access-Control-Allow-Methods: POST, GET, PUT, DELETE, PATCH
Content-Type: text/html
Date: Thu, 19 Jan 2017 20:50:46 GMT
Vary: Origin
X-Powered-By: Express
transfer-encoding: chunked
Connection: keep-alive

887
<!DOCTYPE html><html><head><meta charset="UTF-8"><title>EAGLE Online login</title><script type="text/javascript" src="qrc:///qtwebchannel/qwebchannel.js"></script><script type="text/javascript">//document.addEventListener("DOMContentLoaded", function () {
new QWebChannel(qt.webChannelTransport, function (channel) {
webAPIInterface = channel.objects.webAPIInterface; //global == bad
webAPIInterface.version(function(res){
//document.write('EAGLE version: '+res);
webAPIInterface.setEntitlements('LH***3M',
'martin.darebnyUQ4F3',
'martin.darebny@i***t.cz', 
'Martin',
'Darebný',
'Wp9***Cn',
'HPr***KR',                                         
'urn:autodesk.com:mobile:drapp urn:autodesk.com:services:acadws urn:autodesk.com:services:assetopt urn:autodesk.com:services:chargen urn:autodesk.com:services:geoloc2 urn:autodesk.com:services:infraworksmb urn:autodesk.com:services:infraworksord urn:autodesk.com:services:raas urn:autodesk.com:services:storage',
'65f65***2373b',function(result){webAPIInterface.startApplication();});
});
});
function escapeHtml(str) {
var div = document.createElement('div');
div.appendChild(document.createTextNode(str));
return div.innerHTML;
}
function getBRD() {
webAPIInterface.getBRD(function(res){
document.write(escapeHtml(res));
});
};
function loadLBR() {
//get the data from the content server
var xmlhttp=new XMLHttpRequest();
var url = "http://localhost:3002/123D-Circuits/actions/buildEagleLibrary?component=11290:1&component=11289:1&datamodel_version=5";
xmlhttp.open("GET", url);
xmlhttp.setRequestHeader("x-session","E2E***BC");
xmlhttp.setRequestHeader("x-afc","CR1ONL");
function loaded()
{
webAPIInterface.loadLBR(this.responseText);
}
xmlhttp.addEventListener("load", loaded);
xmlhttp.send();
//send the result to eagle
//webAPIInterface.getBRD(function(res){
//    document.write(escapeHtml(res));
//});
};
function setLicence(licence) {
webAPIInterface.setLicence(licence,function(){
});
};</script></head><body></body></html>
0

As seen by Fiddler:

obrazek.png

 

If it can be of any help, I can send full unredacted trace privately.

 

Post 9 of 16

Re: Unable to launch Eagle

01-19-2017 03:17 PM in reply to: martin.darebny2

Well ... when looking at communication dumps I said to myself "that can't be ...". It is!

 

I have found a workaround!

In my case the problem is caused by any non-latin characters in name or surname.

When I change my surname to contain "y" instead of "ý", it all suddenly starts to work.

 

YOU HAVE A BUG IN LICENCE VALIDATION CODE!

 

You might try beta testing next time ...

 

So if any of you are still having trouble to run Eagle, try to replace any national characters in your profile (name, surname) on autodesk website.

Re: Unable to launch Eagle

01-19-2017 04:23 PM in reply to: martin.darebny2

I can confirm this, I've been trying to start EAGLE the whole day. After reading the previous post I edited my profile removing accented letters and finally I was able to run it.

Post 11 of 16

Re: Unable to launch Eagle

01-19-2017 10:24 PM in reply to: jorge.garcia

Hi Jorge,

 

as mentioned in a different post, I have the same problem as Martin: abtaining a license with the autodesk account is not possible.

 

I created my autodesk account almost 12 hours ago. Things in the autodesk magic licenseing system should have settled now. But I still get the message, that the license is invalid.

 

Here I run eagle on linux OS.

 

 

With Regards,

Detlef

 

 

Post 12 of 16

Re: Unable to launch Eagle

01-20-2017 12:30 AM in reply to: fredSAZZ5

Thanks to martin.darebny... I changed the "é" in my surname directly on autodesk website and now it's working!

Post 13 of 16

Re: Unable to launch Eagle

01-20-2017 09:50 AM in reply to: legospieler
Hi Detlef,

Does your name on your autodesk account have any special characters? Any accents or non-latin characters? If it does then that needs to be changes as other have seen in this forum. A patch has been deployed for this I was told so it should behave differently now. However, the best solution right now is to change the characters.

Best Regards,

Jorge Garcia
Product Support Specialist for EAGLE
Post 14 of 16

Re: Unable to launch Eagle

01-21-2017 01:04 AM in reply to: fredSAZZ5

I wish I could even get a login screen -- the .exe hangs after the initial window frame is drawn, chews up a bunch of CPU time for a few moments and then it becomes unresponsive.  7.7 works fine.  Windows 10.  I even rebooted at one point, no change.

 

 

Post 15 of 16

Re: Unable to launch Eagle

01-24-2017 01:35 PM in reply to: jorge.garcia

Just wanted to add my voice to this issue - as of today (24 Jan 2017) I am unable to launch Eagle without changing my name in my Autodesk Profile from

 

Ethan O'Connor

 

to 

 

Ethan OConnor

 

 

This workaround is fine but it would be great to have it addressed.

 

Thanks!

Post 16 of 16

Re: Unable to launch Eagle

01-27-2017 01:22 AM in reply to: ericwertz

In my case (as solved in a different thread) the solution was to let Eagle install into its recommended directory, and not into C:\Program Files\EAGLE 8.0 as I had directed it to do.

 

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post