Reply
Explorer
3 Posts
Accepted Solution

Z axis up

6033 Views, 16 Replies
12-16-2014 01:39 PM

I am not able to get Z up.  I've selected it in my preferences, but that doesn't influence my workspace.

 Hey Bob,

 

Is this for new files created after changing the preference or changing existing files?  The option to change "Up" in the preferences only does so for new files created.  I do not know of a way to swtich exising axes but the workaround is pretty easy. Just rotate the bodies to be oriented along the z in instead of the y axis.  As a secondary / optional step you can also right-click on the view-cube (in the upper right hand corner) and change the "top" view to be for the z axis as well. That will help keep the navigation feel the same going forward.

 

Hope that helps!

Mike

Employee
69 Posts
27 Kudos
6 Solutions

Re: Z axis up

12-16-2014 02:07 PM in reply to: phlopz

Hi, phlopz,

I actually just learned about this functionality recently.  I've attached a photo, but it sounds like you've probably already tried this.  When you change the setting to z up, hit "apply," and then "OK," you say that the z axis doesn't convert to "up" in the environment?  If not, it's probably be a glitch, rather than a UI mistake.  When you open up the preferences again, has it changed from z-up to something else, or is z-up still displayed (as below), but not correspendoning in the workspace?

Thanks,
Tanner


Tanner Reid

Product Design Engineer

Community Manager
177 Posts
72 Kudos
20 Solutions

Re: Z axis up

12-16-2014 02:12 PM in reply to: phlopz

 Hey Bob,

 

Is this for new files created after changing the preference or changing existing files?  The option to change "Up" in the preferences only does so for new files created.  I do not know of a way to swtich exising axes but the workaround is pretty easy. Just rotate the bodies to be oriented along the z in instead of the y axis.  As a secondary / optional step you can also right-click on the view-cube (in the upper right hand corner) and change the "top" view to be for the z axis as well. That will help keep the navigation feel the same going forward.

 

Hope that helps!

Mike

Michael Aubry
Autodesk Fusion 360 Evangelist
Employee
69 Posts
27 Kudos
6 Solutions

Re: Z axis up

12-16-2014 02:15 PM in reply to: MichaelAubry

Good call, Mike!

 

Didn't realize this was only an option for new designs.  You could also potentially create a new file, change the z to up, and then important the original into it.

Let us know how it goes!

Tanner


Tanner Reid

Product Design Engineer

Community Manager
177 Posts
72 Kudos
20 Solutions

Re: Z axis up

12-16-2014 02:16 PM in reply to: TannerReid
Yup that would work too.


______________
Michael Aubry
Technology Evangelist - Fusion 360
Manufacturing

MOBILE 503 545 5283
TWITTER @Michael_Aubry

Autodesk, Inc.
5400 S.W. Meadows Road
Lake Oswego, OR 97035
www.autodesk.com<>

[Description: Description: Description: Description: Email_Signature_Logobar]
Michael Aubry
Autodesk Fusion 360 Evangelist
Explorer
3 Posts

Re: Z axis up

12-16-2014 03:09 PM in reply to: TannerReid
With Z up already selected in my preference window, I do not get the option
to "apply" when I re-click on the selection. I've also tried changing to
Y-up, clicking "apply" and then OK. Then, setting it back to z up. No good.

I'd really like to see all three axes labeled with an arrow pointing in
their positive directions and representing the "thumb" for application of
the right hand rule for rotations.

thanks for the coaching
I really appreciate the help you folks provide.

bob phillips
Community Manager
177 Posts
72 Kudos
20 Solutions

Re: Z axis up

12-16-2014 05:12 PM in reply to: phlopz

 Again, changing that setting won't change existing documents.  It will just change starting axes used on documents created going forward.  

 

Axes aren't labeled, but the colors are corespond to Red = x axis, Green = y axis, Blue = z axis.  Makes me think of RYGBIV like the rainbow.

 

Very Best,

Mike

Michael Aubry
Autodesk Fusion 360 Evangelist
Explorer
8 Posts

Re: Z axis up

11-06-2015 04:57 PM in reply to: MichaelAubry

 Hi Michael,

 

I am a noob here, but trying to learn fast.  My first design, I didn't change the default to Z axis up... how can I fix that design so that it is correct?  I have tried export/import into a new design, but even when the default is now correct, the design comes in with the Z axis wrong.  X is ok, Y is up and Z is inverse of what Y should be.  Colors are as you say though.

 

I did a lot of modeling, so I don't really want to start again!

 

Suggestions?

 

Stephen

AUTODESK EXPERT ELITE
6376 Posts
2296 Kudos
905 Solutions

Re: Z axis up

11-07-2015 01:35 AM in reply to: stephen.hayne

You might want to read through the thread. I pretty sure you can't change from Y up to Z up after you've started the design, why do you think you need to change by the way. You can change the views around so Right becomes Top for example by right clicking the view cube and selecting set current view as. Can you Export the f3d file and attach to this thread

 

Mark



Mark Hughes
Owner, Hughes Tooling

Explorer
8 Posts

Re: Z axis up

11-07-2015 10:41 AM in reply to: HughesTooling

Hi Mark,

 

I did read the thread carefully before posting, but I see now that I didn't understand the effect of the "2nd" "Set current view as ..." menu choice when right-clicking the cube.  I tried the "1st" one, but that didn't solve the problem.  So, for anyone coming across this thread, if the z-axis is not UP on a model, here is what you can do to change it without having to export, or new design from file, or copy/paste and rotate, etc., - btw, I have now done all of these to get my model into a new file with z up.

 

1) click on the cube to get the view of the "top" you want, i.e., if the current front is your current z, then click on front so that you have that view.

2) right-click on the front of the cube (assuming front from 1 above), and choose the 2nd "Set current view as " menu choice and then choose "Top"

3) select all parts of your model and rotate them so that they are in the new correct orientation

4) rotate the cube to an orientation that matches the "new document" home view, right-click the house symbol, choose the 1st "Set current view as home"

 

This will make your old z (which was front) to up and your model is now changed.  Whew - I hope I wrote this in an understandable way!

 

This was important to me because the post of the original model wouldn't work with my mills, since the z was in the wrong orientation...

 

Stephen

AUTODESK EXPERT ELITE
6376 Posts
2296 Kudos
905 Solutions

Re: Z axis up

11-07-2015 10:59 AM in reply to: stephen.hayne

stephen.hayne wrote:

Hi Mark,

 

This was important to me because the post of the original model wouldn't work with my mills, since the z was in the wrong orientation...

 

Stephen




Hi Steven

 

Are you using Fusion for your CAM, if you are it doesn't matter how the parts are orientated you can easily set the Z perpendicular to any face in the setup. I've done jobs machining from 2 or 3 directions without moving the model.

 

Mark



Mark Hughes
Owner, Hughes Tooling

Explorer
8 Posts

Re: Z axis up

11-08-2015 11:59 AM in reply to: HughesTooling

Yes, I am using Fusion 360, and now deeper into the CAM part.  I am helping a friend with two "old" but beautiful mills - 1) a Bridgeport with EZTRAK and , 2) an ACER with AGE2.  Again, I am a noob... so I don't know how to adjust the setup.  Could you quickly write how to change this in the "setup" (on the mill, or???)?

 

BTW, the current posts I am using do not work very well with these mills (eztrak conversional.cps for the Bridgeport/EZTRAK and a Prototrak post I got from the camforum.autodesk.com that had the G17 removed from output for the ACER/AGE2), so I am spending time trying to understand how to alter the posts to work with them.  I will be posting shortly to the POST forum... :)

 

Stephen

Explorer
8 Posts

Re: Z axis up

11-08-2015 12:35 PM in reply to: HughesTooling

Here is the exported file - I tried to change the Z in preferences and then start the rotation, but the deeper I got into it, I realize that the axes are still "wrong" in the bodies and sketches, which make moving things around very wierd.  BTW, this is an outline for an experimental aircraft avionic panel... side question, if I import this into a new document, where the axes are correct, I seem to lose all the history - how can I keep that history?

 

Stephen

AUTODESK EXPERT ELITE
6376 Posts
2296 Kudos
905 Solutions

Re: Z axis up

11-09-2015 05:45 AM in reply to: stephen.hayne

Hi Stephen

 

Is this the only part you need to reorientate or is there more. Are you going to use Fusion to machine the parts, if so I wouldn't bother reorientating anyway you can set it up correct in the CAM work space, See attached file  "Original Panel - z still not up v0 CAM.f3d"

 

Looking at your design you should work more with sketches, it is far easier to design something like this with a sketch, see attached file. Also were Sketch 5 & 6 drawn in Fusion or imported and why are they not drawn on the sketch XY plane. When I try to edit sketches 5 & 6 they are edge on.

 

Mark.



Mark Hughes
Owner, Hughes Tooling

Explorer
8 Posts

Re: Z axis up

11-09-2015 08:56 PM in reply to: HughesTooling

Everything was drawn in Fusion - this was my first design.  I used sketches that were then extruded to form the part I wanted, as per the base tutorials.  But, of course, I didn't make the z axis up in this first design - somehow my default preference was "Y" up.  As far as I can figure out, no matter what I do, I can't seem to recover so that I can use Fusion to CAM it, i.e., post it to my mill.  I've tried everything, and you can see the remnants in the file I gave you, in that even though I rotated everthing as per another message, the bodies/sketches of the panel cutouts were somehow left behind and still in the original orientation (edge on in the "new" orientation).  This is driving me nuts.  I've tried 7 different versions of designs, based on lots of other suggestions, and nothing will work.  Of course it doesn't help that its not possible to cut/paste objects between designs and preserve their history... but that is another thread, I see.

 

I've looked the CAM file you sent, and I'm sorry, but I don't quite see how what you did will solve the problem?  You have changed the orientation, but the Z axis is still wrong and so my mill won't process the post file...  at least that is what happened today - I will look at the code and see if I can make a quick fix.

 

However(!), I really appreciate the other sketch file, tho'!  I'm completely baffled as to how you got it all in one sketch.  I will study it and try to figure it out.  It is exactly what I need.  I was doing it in "pieces", extruding the bodies from each "sketch".  I know I am noob with this software, but I am an Information Systems professional with over 35 years of experience with all kinds of systems... guess I met my match with this one.  I have a bit of work ahead of me.

 

Thank you very much for your help.  If you could point me towards the tutorial the outlines how you created this sketch (with mirrored openings and sets of drill points), that would be great.

 

Stephen

 

PS - I am going to use Fusion to machine this panel.  I've already altered a couple of posts (EZTRAK and Prototrak) to suite the mills that my buddy has.

AUTODESK EXPERT ELITE
6376 Posts
2296 Kudos
905 Solutions

Re: Z axis up

11-10-2015 01:44 PM in reply to: stephen.hayne

I'll try and answer your questions, in this post I'll deal with CAM setup. I don't think you've understood that the setup in the model workspace doesn't restrict how you can set the job up in the CAM work space. I've done a screencast showing how you can have 2 setups on one part to machine different side, f3d file attached. Note when I post the code at the end the output matches the origin in the setup not the origin from the model.

Here,s a picture of the test part with pockets in 2 faces. Link to screencast

 

 

Watching the screencast I noticed I forgot to select the model in the setup, for a single part it works OK but with more parts in a design you need to select the part you're machining.

 

Mark



Mark Hughes
Owner, Hughes Tooling

Highlighted
AUTODESK EXPERT ELITE
6376 Posts
2296 Kudos
905 Solutions

Re: Z axis up

11-10-2015 01:56 PM in reply to: stephen.hayne

I thought I'd show you the output from the  "Original Panel - z still not up v0 CAM.f3d" file, notice the Z is up!

I had to set the work offset in the setup, I don't use offsets but some posts give an error if you leave it at 0.

 

 

Mark



Mark Hughes
Owner, Hughes Tooling