Reply
Contributor
27 Posts

not repsonding after every command

85 Views, 4 Replies
11-10-2015 10:53 AM

Greetings,

 

I'm working on a design with many small parts in it (several thousand) and it seems to have brought Fusion to its knees. I have turned off the visibility of nearly all of the parts, except the one I'm working on at a given time (usually a pretty simple part in and of itself), but even commands as simple as chamfer get hung up for 30-45 seconds, the browser tree turns black and I get a not responding message on the window bar until Fusion stops "thinking". It's happening on every command or tool I use. I have turned off all my  effects except ground plane and anti-aliasing, and set my selection to simple in the preferences. It doesn't seem to be my internet connection either as it happens even when I work in offline mode.

 

Grind grind grind.

 

Any thoughts?

 

Regards,

hanswurst

AUTODESK EXPERT ELITE
1104 Posts
711 Kudos
56 Solutions

Re: not repsonding after every command

11-10-2015 11:18 AM in reply to: hans

You don’t say what kind of system, OS, or display graphics you have- that would help the Autodesk folks get a perspective on the issue. You say you have anti-aliasing turned on- that can cause problems on some systems, you might try turning that off. What visual style are you using?

 

Is this design created in Fusion, or does it contain imported components? I have seen imported parts that were not easily interpreted by Fusion and while appearing OK, caused problems down the line. 

 

How is the design organized- into components, sub-components, or assemblies? Are you working in history or direct modeling? Would it be possible to break it up into sub assemblies that can be worked on independently and linked? 

 

I’ve seen Fusion come to a crashing halt when I bring in a DXF with many thousands of layers. But turning off the visibility restored most of the function. I don’t think Fusion is great at extremely large assemblies, but there are thing you can do- like turning off any sketches you don’t need- that will speed things up. A little more information, or if possible sharing the model, and I’m sure you will get some suggestions.

- Ron

Retina 5K 27" iMac, 4 GHz Core i7, OS 10.10.5, 24GB RAM, AMD Radeon R9 M295X 4096 MB

Contributor
27 Posts

Re: not repsonding after every command

11-10-2015 12:40 PM in reply to: Oceanconcepts

windows 10 / 64-bit

i7-4710 @2.5GHz

16 gb ram

nvidia geforce gtx 870m

 

shaded with visible edges only

everything was created in fusion

 

I have 1600 parts that I have moved into a separate design and inserted back into the design as an assembly. half of these are individual sub-components in a single component, half are bodies in a separate single component. Tthe design works fine without the insertion (or the parts themselves). The condition I described occurs whether the 1600 parts are part of the base design or as an insertion, regardless of whether visibility is on or off in either case.

 

Proprietary design, so I'd rather not share it - makes is difficult I know, sorry.

 

Thanks

Hanswurst

 

AUTODESK EXPERT ELITE
1104 Posts
711 Kudos
56 Solutions

Re: not repsonding after every command

11-10-2015 12:51 PM in reply to: hans

That’s a lot of information to go on, and it sounds like a good test case. Off the top of my head, and I’m not the expert here, I wonder if the link in the inserted component is what is slowing things down.  But this is really a question for the Fusion team- they are getting ready for an update release, so the usual speedy response might be a little less speedy.

- Ron

Retina 5K 27" iMac, 4 GHz Core i7, OS 10.10.5, 24GB RAM, AMD Radeon R9 M295X 4096 MB

Community Manager
2206 Posts
528 Kudos
227 Solutions

Re: not repsonding after every command

11-10-2015 01:39 PM in reply to: Oceanconcepts

This can be solved, but requires a little bit of selection set work.

 

CPU performance and GPU performance.

 

  • Externally referenced designs reduce CPU load. When a command requires a compute, the linked designs do not participate.
  • Large numbers of any kind of object increase CPU load. You need to make them un-selectable via right click menu.
  • Texture appearances, edges, faces, etc. affect GPU load. As you have discovered, you can make things invisible.

 

Use Selection Sets to manage this.

  1. Select all the components you wish to turn off and on visibility or select-ability.
  2. Right click, make a selection set.
  3. Use the selection set by picking the "select" button attached to it.
  4. Right click and use the visibility toggles or selectable/unselectable toggle.

 

 



Phil Eichmiller
Software QA Engineer
Fusion Quality Assurance Team
Autodesk, Inc.