Reply
Contributor
16 Posts
4 Kudos
Accepted Solution

Toolhead goes to non-home position after cut

56 Views, 3 Replies
a month ago

Still getting to learn F360 CAM, I've probably made 10 successful cuts with it.  Until, today.  I made two separate cuts for the piece, a chamfer, and a contour (both super simple, it's just a hexagon perimeter), and they both display the exact same weird behavior that no cut in the past has:

Cut goes fine.

When it finishes, The toolhead lifts to Z15.

Then it shoots of to the top-righthand corner of the machine while dropping Z straight into the bed, ruining the piece, and me frantically going to press the emergency stop.

This is an X-Carve, running grbl, using UGS to send the gcode.  

 

Below is the end of the gcode, showing from the last successful move (G0 Z15).

Here's what's weird:  If I compare this "failed" gcode to gcode that "works", they're the exact same.

 

... bunch of gcode from a cut that fails...

G0 Z15
M9
G28 G91 X0 Y0
M30
%

 

... bunch of gcode from a cut that works:...

G0 Z15
M9
G28 G91 X0 Y0
M30
%

 

What am I missing there, thanks!

Have you tried setting useG28 to No? This should do what you want.

 

G28.JPG

Contributor
16 Posts
4 Kudos

Re: Toolhead goes to non-home position after cut

a month ago in reply to: warpcat

So, I think I figured out what's causing it. It's the line:
G28 G91 X0 Y0

 

This is sending it to machine home after the cut, not the work home (where I zeroed it before the cut). In this case, when I turned on the machine to do my last cut, I had done an experiment previous, where I had lowered the chuck all the way to the wasteboard : That was now machine home when I turned the machine on, and that's where it decided to go after the cut was over. If I remove that G28 line, the toolhead raises, stops, and all is well.

 

At first I was perplexed as to why this new behavior was happening: I compared gcode made my fusion360 vs meshcam (which I have been using) : Meshcam simply issues a
G0 Z2.54
at the end, raising the bit and leaving it there. The postprocessor I'm using for F360 must be adding in this code, and thus creating new unfamiliar behaviors. I'll just manually remove that line until I figure out how to make my own postprocessors.

AUTODESK EXPERT ELITE
3643 Posts
870 Kudos
338 Solutions

Re: Toolhead goes to non-home position after cut

a month ago in reply to: warpcat

Have you tried setting useG28 to No? This should do what you want.

 

G28.JPG

Neal Stein



New to Fusion 360 CAM? Click here for an introduction to 2D Milling, here for 2D Turning.

Find me on:
Instagram and YouTube
Highlighted
Contributor
16 Posts
4 Kudos

Re: Toolhead goes to non-home position after cut

a month ago in reply to: Steinwerks

Thanks Steinwerks, that actually fixed it.  I had some confusion in the meantime:  I was using two other postprocessors I'd found online, one of which, a 'ShapeOKO' one (which has the same name as one I'd used successfully in MeshCAM), and had nearly the same settings as the generic grbl one you listed above, except disabling its G28 has no effect.

 

So yah, back in business again, thanks for the tip.