Community
Civil 3D Forum
Welcome to Autodesk’s Civil 3D Forums. Share your knowledge, ask questions, and explore popular AutoCAD Civil 3D topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Pipes not show ByLayer when XREF'd

8 REPLIES 8
Reply
Message 1 of 9
Neilw_05
337 Views, 8 Replies

Pipes not show ByLayer when XREF'd

I created a pipe style that displays just the centerline on layer zero and ByLayer for linetype, color, etc. This way my pipes display according to the layer I put them on.

 

When I XREF my pipes into other drawings, they do not display according to their layer properties. I don't want to DREF the pipes into my other drawings as I don't need the functionality. How to make this work?

Neil Wilson (a.k.a. neilw)
AEC Collection/C3D 2024, LDT 2004, Power Civil v8i SS1
WIN 10 64 PRO

http://www.sec-landmgt.com
8 REPLIES 8
Message 2 of 9
Hidden_Brain
in reply to: Neilw_05

does it work when its set to byblock?

Message 3 of 9
Neilw_05
in reply to: Hidden_Brain

No difference. Curious why you thought it would?

Neil Wilson (a.k.a. neilw)
AEC Collection/C3D 2024, LDT 2004, Power Civil v8i SS1
WIN 10 64 PRO

http://www.sec-landmgt.com
Message 4 of 9
Hidden_Brain
in reply to: Neilw_05

I have been facing a lot of problems lately with styles and blocks used in styles not displaying correctly in 2018 sp2. I have been setting a lot of them to byblock lately
Message 5 of 9
copper.chadwick
in reply to: Neilw_05

@Neilw_05 ,

Good post! Thanks for be an integral part of the Civil 3D community. I see you are describing an issue where when:

  • Externally Referenced Pipe networks
  • Style set to show the centerline only
  • To which is set to layer 0 and ByLayer for all of the other properties
  • Civil 3D 2019? or Which version?

This results in the pipe centerline not displaying correctly, specifically displaying with the properties of the layer the Xref is inserted on? (I am leading some symptoms here as it might be a known issue, and also offers some things to review in your instance)

Are all of the above symptoms correct? It may be a known issue if so.


Copper Chadwick
Designated Support Specialist
Message 6 of 9
Neilw_05
in reply to: copper.chadwick

All symptoms are correct. I am using 2018.

Neil Wilson (a.k.a. neilw)
AEC Collection/C3D 2024, LDT 2004, Power Civil v8i SS1
WIN 10 64 PRO

http://www.sec-landmgt.com
Message 7 of 9
copper.chadwick
in reply to: Neilw_05

@Neilw_05 ,

OK, thank you. One last question, as this is a "known issue" (one of a few), so at least one more question to put this into the right bucket.

  • Are you using a .STB or .CTB plot style? (if you are using a .STB that is one, and if not, then another)
  • What version are you on and did you try applying the Autodesk Civil 3D 2018.0.1 hotfix then the subsequent 2018.1 and finally the 2018.2 updates to see what it might change?

 

So in advance, I want to say that this is a known issue, and I do not believe that you are doing anything incorrectly, the perfect temporary solution is to not use Layer 0 for the pipe centerline. Unfortunately, that is the only thing that can be done for the moment, approaching it as such, is going to be the time sensitive and proven workaround.

 

Meanwhile I want to be able to push your case to development and capture your specific instance.

 

In a few instances applying that series in special sequence of 2018 hotfixes and updates can resolve this, but it does not always work, I want to get your instance pushed to the development teams.


Copper Chadwick
Designated Support Specialist
Message 8 of 9
copper.chadwick
in reply to: Neilw_05

@Neilw_05 ,

I was wondering if you had a chance to find that information so that I can get the exact information to the development team or made any progress in the issue? If so, please hit the Accept as Solution button if a post fully solves the issue or answers the question.​ Thank you for your participation, your accepting a solution adds value to the post for the community as a whole, and helps other members find answers to their issues.


Copper Chadwick
Designated Support Specialist
Message 9 of 9
Neilw_05
in reply to: copper.chadwick

Thank you for providing that info Copper. I just now saw it so I haven't reviewed it yet. I'll get back to you when I have some answers.

Neil Wilson (a.k.a. neilw)
AEC Collection/C3D 2024, LDT 2004, Power Civil v8i SS1
WIN 10 64 PRO

http://www.sec-landmgt.com

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Rail Community


 

Autodesk Design & Make Report