Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why can I not render my Aero?

7 REPLIES 7
SOLVED
Reply
Message 1 of 8
valhallen
811 Views, 7 Replies

Why can I not render my Aero?

Hey Arnolders (Arnoldians? Arnoldies?)!

So I cache, I don't cache, I change shaders, but I cannot render a simple explosion at 512 x 512 for 64 measly frames. At some point, usually frame 21/22 but sometimes frame 10 it gets to 98%, stops, crashes.

Here's the setup - I'm trying to render Emission/Normals/Motion vectors for an flipbook import to Unreal.
I am at present doing my normals by taking the gradient of an sdf built from the aero.  Now .. I have cached that SDF, I have cached the main aero and I am using aiVolumeSampleRGB nodes to get those values into the shader's emission channel. See attachments. 

This is a ridiculously simple setup, and the Arnold renderView is fine with it - I can render the "problem" frames manually just fine.

But when I go to batch render, it will get to 98% on a certain frame (10, 21, 22, 30 are the main culprits so far) and just hang, then eventually stop.  Same if I use "render sequence". 

I'm running Maya Indie 2022, BF 2.3, Arnold 6.2.0.1 and MtoA 4.2.1.

WTF is going on?  I mean I can manually render, but I really shouldn't have to .. please help?


Labels (2)
7 REPLIES 7
Message 2 of 8
Stephen.Blair
in reply to: valhallen

Can you check with the latest MtoA and Arnold (MtoA 4.2.3) ?



// Stephen Blair
// Arnold Renderer Support
Message 3 of 8
valhallen
in reply to: valhallen

Installing now 😄

 

Message 4 of 8
valhallen
in reply to: valhallen

Yeah nah, same issue, same frame (21).  Same thing, can render that frame in arnoldRenderView just fine 😞
I'm just not doing anything that complicated here, PC is Win10, 32Gb Ram, i7

 

Message 5 of 8
Stephen.Blair
in reply to: valhallen

If you upload the scene somewhere, I'll take a look.



// Stephen Blair
// Arnold Renderer Support
Message 6 of 8
valhallen
in reply to: valhallen

@Stephen.Blairyou're magnificent, I've uploaded the .ma and the first 30 frame cache files to
https://drive.google.com/drive/folders/1-2L9qSeDRuqAaxjOXgf_zw-VolFK_H1V?usp=sharing

You will need to change the filename property in the "read_bifrost_object" compound.

Thank you

 

Message 7 of 8
valhallen
in reply to: valhallen

So have re-cached with less properties in an attempt to get this to work.  Still no joy. Something about frame 21 it just won't do 😞

 

Message 8 of 8
Stephen.Blair
in reply to: valhallen

Unfortunately, it seems as soon as I use either voxel_normal or voxel_fog_density for either density or density_channel, it crashes after it gets to 95%

 

The Arnold Render View crashes too.

 

I was able to export the frames to ass files, and kick that. But that requires an Arnold license (to remove the watermark). 

 

I'll open a ticket. 



// Stephen Blair
// Arnold Renderer Support

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report