Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

When I create A fluid... nothing happens

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
grayando1
754 Views, 6 Replies

When I create A fluid... nothing happens

Hello, Im farily new, and looked for an answer but still have the same problem....

I set the animation counter to 1 ~ first frame... I select my sphere that I want to be the emmiter, then select Bifrost add fluid.... In the hypergraph it is created, but at the center 0, 0, 0.... my sphere is below a tap model I have made....

When I click play, the emission box does not move to the selected object and I can not see anything happenining where it is at o, o, o...

Ive been going over this all day and cant get it to work....

 

grayando1_0-1586192512440.png

 

6 REPLIES 6
Message 2 of 7
grayando1
in reply to: grayando1

Im using Windows 10
Maya 2020 student version
Maya is installed to D : / to save space on my small but fast c : /

Bifrost version 2.0.3.0

Message 3 of 7
wongt
in reply to: grayando1

Hello,

Can you upload your scene.  From you description, it doesn't look like a workflow issue.  I would like to check things like scene scale and make sure if all connections are correct.  Thanks.

EDIT:  you can also try lowering your Master Voxel Size (bifrostLiquidPropertiesContainer1) from 0.5 to 0.1.  This should increase accuracy if it's only off by a bit.

Message 4 of 7
grayando1
in reply to: wongt

Hello there and thank you for the speedy reply and offer to help.... very kind of you, plz be gentle, Im a noob....

The tutorial did not mention anything about setting scale? Is this the first thing to do when setting up your scene?

https://1drv.ms/u/s!AvwyfT4tZm1FhxJrlnLtnlMo-B-B?e=hCuYOy would not let me upload the file here....

Message 5 of 7
wongt
in reply to: grayando1

Scene scale is quite important in Bifrost Liquids.  It looks like that is the culprit in your scene as well.  Essentially Bifrost interprets 1 maya scene unit = 1meters.  It looks like the sphere you want to be an emitter is ~.5 units which makes it hard for the Bifrost default values (mvs=.5) to evaluate.  If you change your Master Voxel Scale from 0.5 to something smaller like 0.1, you should be able to see the liquid around the sphere.  The mvs can be found on the bifrostLiquidProperties1 node under the tab 'Resolution'.  You may also want to turn on the 'Continuous Emission' flag found in emitterProp1 node under the Properties tab.

Message 6 of 7
mspeer
in reply to: grayando1

Hi!

 

Bifrost uses by default a certain detail size for the simulation, which will not work if the objects are too small.

So either increase the object size or do what @wongt suggested, a lower value for Master Voxel Size will work.

Message 7 of 7
grayando1
in reply to: wongt

Thank you so much... it was driving me insane... '' )

 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report