Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unusual liquid particle movement HELP NEEDED

8 REPLIES 8
Reply
Message 1 of 9
Anonymous
597 Views, 8 Replies

Unusual liquid particle movement HELP NEEDED

Hi to those on the forum reading this post right now! 

I am experiencing some very weird behavior with my liquid particles that I am simulating and was hoping someone out here might be able to figure out what the cause is. 

 

I am trying to create a scene where waves are lightly crashing against an object lodged into the shore of a beach. I've set up my simulation by creating a boss ocean and using the output as a motionfield for my liquid. Even though the ocean wind direction is a straight 270 degrees, and the motionfield direction magnitude to 0 (and zero'd out the xyz for good measure), my water particles keep moving to the right of the container I've set up! [Please watch attached video for reference] 

 

I have triple checked my geometry to make sure all the top vertices of the beach floor are level along the y-axis so I know its not an issue with the ground plane. Is there some setting that I am missing or need to turn off?? I am new to water simulations and have been working through various youtube tutorials.... I've been at this for over a month and I keep getting the same thing over and over again. I just want my water to flow back down the slope like it would in real life.... please help!!! 

 

Bifrost version 2.2.1.2-202106080857-835896f

Maya 2019 (student version) 

Windows 10 64bit

Labels (3)
8 REPLIES 8
Message 2 of 9
Anonymous
in reply to: Anonymous

Not sure if this helps at all but I've been following these specific tutorials:
https://youtu.be/OThS0plEv0A
https://youtu.be/RPKTQF8yur4

The only difference between my scenes and their scenes is the size of the geometry; mine being overall wider and a much smaller scale.
Message 3 of 9
syracoj
in reply to: Anonymous

are you able to forward me your scene file? You can zip then attach it here.

Message 4 of 9
Anonymous
in reply to: syracoj

Here's the mb file, you might get some start up errors cause the cache and the textures wont be linked anymore. I changed some of the values from my initial posting as I was trying to figure things out but it's still behaving the same way. 

Appreciate any help you can give!!

Message 5 of 9
Anonymous
in reply to: syracoj

@syracoj were you able to figure anything out from the mb file? 

Message 6 of 9
syracoj
in reply to: Anonymous

@Anonymous 

thanks for the scene file. Will take a look at it today.

Message 7 of 9
syracoj
in reply to: Anonymous

 

I set all the colliderProp nodes Thickness attribute from 1 to 0 (under the conversion attribute group) on the node.

 

I also remodelled the collision geometry (“bottom_geo”) as well as Container_geo so that their polygonal thickness was at least 1 Maya unit thick.

 

I took the boss mesh that is being used as the 4th motionField and meshProp4 geometry input and did an extrusion on it to give it some thickness (at least 1 Maya Unit thick). Since I extruded I had to reposition it by moving it down so it was somewhat centred with the Bifrost liquid main body.

 

On the 4th motionField itself, even though it was greyed out, I turned on ‘Enable Additional Velocity’ then zeroed out the x axis Additional Velocity. After that I turned ‘Enable Additional Velocity’ back off. This step shouldn’t make any difference but I did it for good measure/just to make sure.

 

I also disabled all the meshProperties that were connected to motionFields that were not enabled. Essentially just leaving the motionField4 and meshProp4 intact since they are being used with one another.

 

In order to get this all to work I had to uncheck all the cache and initial state attribute groups to assure it wasn’t looking/trying to load a cache file I did not have.

 

After this, when I did a playblast, I could no longer see the strange particle motion moving along x as was seen before.

 

Message 8 of 9
Anonymous
in reply to: syracoj

@syracoj 

Thank you so much for your help!! That looks 10x better than anything I was getting! 

If possible, could you please explain how you went about finding this solution? Was this process of changing the colliderProps thickness attribute, having thicker geometry, having only one meshProp with a corresponding motion field (didn't even realize thats what the meshProp was!), and zeroing out the additional velocity  on the motion field all sort of "standard practice" when it comes to bi frost simulations like this? Or at least, when the scale is so small? 

 

As well, based on your solution, I'm assuming you can change the geometry of the colliders without having to unlink and relink them to the liquid node? Does this also apply for motionfields? Could I have changed the BOSS spectral wave output properties without having to creating a new motionfield? 

 

I'm very keen on actually learning the proper processes of building simulations and I want to try again from scratch following this advice so any answer would be appreciated! 

 

Once again, thank you very much for your help! 

 

 

Message 9 of 9
syracoj
in reply to: Anonymous

When we set the collider thickness to 0 the resulting solid of the collider better fits the collision primitives geometric shape. Increasing the thickness adds additional offset padding to the geometric shape. So if you want it to match as close to the colliding objects geometric shape set it to 0.

 

If you open up the node editor and press tab/type: bifrostShape you can create another bifrostShape and connect the bifrostLiquidContainers solid output to its (new bifrostShape) object port. On the new shape you will want to set it to display voxels. The solid is the collider. If you switch the collision thickness from 1 to 0 you will see on the shape the change in the voxels in the viewport. This can give you a visual indication of what is going on.

 

For solid water tight collision geometry I try and model the collision objects thickness to be greater than or equal to at least 1 Maya unit (cm in Maya but the cm is interpreted in Bifrost Liquids as 1 meter) when I can. If I need something smaller than that then I use the shell mode rather than solid mode (also on the colliderProp node).

 

The motion field is taking the motion of the animated input mesh, which is fed through a meshProp node and then into the motionField and using its motion to kind of accelerate the particle fluid.

 

Zeroing out the additional velocity on the motion field was just a precaution. Even though it was greyed out (indicates it shouldn’t be used), I wanted to make sure that it wasn’t somehow (perhaps by way of defect) causing the particles to be pushed along the x axis because of this setting.

 

You can change any of the prop nodes or colliders by rewiring them in the node editor.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report