Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Square smoke

5 REPLIES 5
SOLVED
Reply
Message 1 of 6
A01653369
546 Views, 5 Replies

Square smoke

Hello, I'm new to bifrost. I created a smoke graph and every time I try to render, I get square smoke? It's like if I was on minecraft or something. I don't know if one of my settings is off or what's happening. I'm trying to render with Arnold. Can't find anything in any forums, please help. My student life depends on it.

Screenshot_6.jpgScreenshot_5.jpgScreenshot_4.jpgScreenshot_7.jpg

5 REPLIES 5
Message 2 of 6
mspeer
in reply to: A01653369

Hi!

You have in source_air:

Fog Density Mode (set to "set").

This is a very simple creation method which instantly sets all affected voxels to this value, this will look like Minecraft, at least at the first frame.

 

Possible solutions:

1) Lower the Fog Density

2) Play back the simulation and render an other frame.

3) Use a higher resolution (lower Detail Size)

4) Use an other "Fog Density Mode"

 

Message 3 of 6
A01653369
in reply to: mspeer

Hi!
Thank you for your answer, I did seem to manage to make it so the smoke is not square anymore. I did playback the simulation to another frame but it was still squared. I tried lowering the density and it helped a bit, on the other side, changed the fog density mode to add, and changed the resolution mode and that seems to have worked fine.

Now my problem resides in the render not being able to process more than 99 percent. It will render in about a minute or less up to 99 and then it just freezes and stays there, have waited for about two hours before killiing the render, don't know if there's something I did wrong there as well. 

Message 4 of 6
mspeer
in reply to: A01653369

Hi!

What resolution do you render?

How do you render?

What freezes?

Is this just Maya Render View or Arnold Render View that stops at 99% without a freeze?

 

Message 5 of 6
A01653369
in reply to: mspeer

I started with 1080p but then went to 720 and now I'm at 540. The render takes pretty much no time to get to 99 percent, but then it just freezes there. I've done it in batch render, in render sequence and am using Arnold. The animation is cached, I've rendered other scenes and have never encountered this problem. I've tried ecporting in exr(which is what I normally use) iff, png and jpg. Nothing seems to work. I've even redone de simulation from stratch. when using maya or arnold view, maya ends up just crashing. 

and I don't think its a pc problem, but just in case, my pc especifications are:
threadripper 2990x
2080 super
64ram
1tbm.2
1000 psu

Message 6 of 6
mspeer
in reply to: A01653369

Hi!

 

There is (or was) a problem when rendering in Maya sometimes the render stopped at the last bucket at the render never finished or at least was not written down, but Maya does not crash.

So just to make sure I understand this correct, in your case Maya is freezing/crashing?

Does this happen at the first frame of a sequence or at the last frame?

Does Maya also crash if you render the scene without caching it first?

 

Please provide:

1. an Arnold log with Verbosity Level set to "Debug".

2. The Maya file you try to render.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report