Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Set strands shape tube does nothing

6 REPLIES 6
SOLVED
Reply
Message 1 of 7
labbejason
596 Views, 6 Replies

Set strands shape tube does nothing

Hi world,

 

Just wanted to check how to use a `set_strands_shape` node to work as a tube shape. Right now it looks like it does nothing. Not sure if this is a bug or not?

 

Thanks!

Jason

Tags (2)
Labels (1)
6 REPLIES 6
Message 2 of 7
mjcg91
in reply to: labbejason

It's not a bug, it's just that the mode doesn't do anything at the moment.

As an alternative, you could use extrude_strands from MJCG_compounds. It has a tube extrusion mode so you can generate a mesh out of your strands.

 

 

Maxime Jeanmougin - Technical Artist
https://maximejeanmougin.com

Join the Bifrost Addicts community on Discord:
https://discord.gg/bifrost-addicts
Message 3 of 7

The viewport won't render tubes yet.  If you have a quite recent version of Arnold (I tested with 4.1.1), it should work, however.

Message 4 of 7
sachinshrestha
in reply to: labbejason

It’s primarily to set the render time curves in arnold to tube shape for cylindrical shading (if you are doing hair/fur).

LinkedIn: https://www.linkedin.com/in/sachinshrestha/
Twitter: https://twitter.com/_sachinshrestha
Instagram: https://www.instagram.com/noizfactory/
SoundCloud: https://soundcloud.com/noizfactory
Message 5 of 7
labbejason
in reply to: sachinshrestha

Gotcha, thank you guys.

 

Maxime, I was already using your extrude_strands so looks like I'll stick with it! Awesome job on it, by the way, it works very well.

Message 6 of 7
Pham_Nhat
in reply to: mjcg91

Hey bro i meet the same problem and i dont see "extrude_strands" in my bifrost

Message 7 of 7
Grahame_Fuller
in reply to: labbejason

Hi,

 

The extrude_strands compound is not one of the ones included in the default installation of Bifrost. It was written by Maxime Jeanmougin (mjcg91 on this forum) and is included in his MJCG compounds pack. You can download that here. For information about installing compounds, see these instructions.

 

I hope that helps.

 

gray


Grahame Fuller
Learning Content Developer

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report