Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

Scene evaluation problem at scene startup with Bifrost

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
chokmah
563 Views, 9 Replies

Scene evaluation problem at scene startup with Bifrost

Hello dear Autodesk users,

I am trying to create a spine RIG module solver with Bifrost. All works fine (except some up vector problem I intend to adress ^^).
But, when loading the scene my Bifrost graph isn't evaluated ... until I move one controller.


Before moving a controller (at scene startup):

chokmah_0-1613065890927.png

After moving one of the two controllers, all works fine :

chokmah_1-1613065925728.png

 

Can anyone help with this. Perhaps I didn't something wrong with Bifrost. I don't really know.

Here is the scene I'am working on :

Thanks in advance ๐Ÿ™‚

9 REPLIES 9
Message 2 of 10
jonah.friedman
in reply to: chokmah

Hi Chokmah,

 

I can confirm your issue, and have logged it as BIFROST-5606. We recently fixed a very similar issue in internal builds. 

 

It seems to be something with the parent offset matrix of joints in particular. For me connections to locator's parent offset matrices do not have the same problem. 

Jonah Friedman
Bifrost Product Manager
Message 3 of 10
chokmah
in reply to: jonah.friedman

Hmmm interesting ....

I'll try the connect my matrices to locators instead, and tell back to you if it worked for me.
Thank you a lot for your help.


I hope Maya developpers team will manage to adress this issue (In fact I am sure you'll do it ! ๐Ÿ˜‰ )

Thanks again ๐Ÿ™‚

 

Message 4 of 10
chokmah
in reply to: jonah.friedman

Test done. I can confirm you are right. The problem is only about joint. It works fine with nulls.
I'll use null  nodes as offset parent for now until the issue is solved.

Thanks again @jonah.friedman ๐Ÿ™‚

Message 5 of 10
chokmah
in reply to: chokmah

Erratum ! 
I did some more tests.
The problem don't affect joints nor nulls if no polySurface is bound to the joints
It occurs only when binding a polySurface to joints.

I hope it will help finding the bug origin : $

Message 6 of 10
syracoj
in reply to: chokmah

If you add a time node inside your bifrost graph and connect it to the output node does this preserve your rig?

Message 7 of 10
chokmah
in reply to: chokmah

I did add a time node is the graph as you suggested @syracoj :

chokmah_0-1613074527939.png

But the same issue appends at same start. ๐Ÿ˜•

 

Message 8 of 10
syracoj
in reply to: chokmah

and which version of Bifrost are you using? I tried on 2.2.0.1 and 2.2.0.2 for Maya 2020 and it seemed to work. I also had cache playback on with EM-P. I do notice that if I set EM to DG rather than Parallel that on scene open it displays the problematic behaviour on my end but if I press rewind it kicks it in to gear. I am on Mac and it wouldn't be completely unheard of of having differing behaviours on the different platforms.

Message 9 of 10
chokmah
in reply to: chokmah

I did the test to set EM to parallel (with th Time node connected to the output of my Bifrost graph) and the problem is gone ! 
You were right @syracoj ! ๐Ÿ™‚
Thanks for your help too.


But it should work with EM set to DG right ?

Message 10 of 10
chokmah
in reply to: chokmah

ps : My Bifrost version 2.2.0.2 for Maya 2020

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums