Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Particles to vdb volume problem

3 REPLIES 3
Reply
Message 1 of 4
a.mayaUser
237 Views, 3 Replies

Particles to vdb volume problem

Hi guys,

is something changed in the latest bifrost regarding the workflow to cache particles as vdb?

I'm using the convert_to_volume and it works fine in the viewport, but crashes miserably when try to render the volume in redshift.

 

Not sure at this point if I'm missing other nodes in the network:

PtoVDB.jpg

Thanks in advance

Tags (3)
3 REPLIES 3
Message 2 of 4
sepu6
in reply to: a.mayaUser

You should be able to write a VDB and make sure you are writing VDB points. If you want to be 100% use the Write VDB node. 

Message 3 of 4
a.mayaUser
in reply to: a.mayaUser

Thanks @sepu6 

I did some more tests, it looks like some properties are causing the problems.

 

What I noticed is that the resulting point preview in viewport from the Redshift Volume is wrong: it shows just a cubic grid full of points, which is not the case.

 

So, first thing I removed all the properties except for point_position from the convert_to_volume node, which gave me the grid I was expecting, with the points in the right place and right away a renderable volume without crashes or errors.

Not sure why the properties in the convert_to_volume are like this by default though * !point_position !point_normal Isn't the exclamation mark equals to not in this case? Meaning all properties except point_position and point_normal?

 

Then I tried to add point_velocity, and already got the crash immediately as I started the render with motion blur and velocity grid enabled.

 

This is not happening if I try to cache directly from an aero solver. For some reason the resulting cache has two velocity grids, voxel_velocity and voxel_velocity0, and I'm not sure why, but they both render without crashing, except the motion blur is not noticeable.

 

Using the write_vdb_volume or the file_cache seems to makes no difference in this case.

 

Any other suggestions?

 

edit: corrections

Message 4 of 4
sepu6
in reply to: a.mayaUser

Without looking at the file, not sure to be honest.  

 

* !point_position !point_normal Isn't the exclamation mark equals to not in this case? Meaning all properties except point_position and point_normal?

 

Correct all properties will be passthrough besides point position and normal. You also have to make sure that the write node is getting that as well, they usually have a properties param too. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report