Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Maya instantly enters safe mode when adding Bifröst fluid

1 REPLY 1
SOLVED
Reply
Message 1 of 2
klaassenlucas
1006 Views, 1 Reply

Maya instantly enters safe mode when adding Bifröst fluid

When I add a bifröst flluid in my Maya document, it instantly enters safe mode this is what the script editor says:

CreateBifrostLiquid;
// Error: failed to initialize and bind the compound to the bifrost container node. // 
// Error: failed to initialize and bind the compound to the bifrost container node. // 
// Error: file: /Applications/Autodesk/bifrost/maya2019/1.5.7.0/bifrost/scripts/addBifrostLiquidSetup.mel line 28: setAttr: No object matches name: |bifrostLiquidProperties1|bifrostLiquidPropertiesContainer1.gravityDirectionX // 
Cached Playback: The presence of unsupported Bifrost node 'bifrostLiquidPropertiesContainer1' has triggered Safe Mode, and caching is disabled.
                 You can continue work, but caching has stopped.
                 Remove animation from 'bifrostLiquidPropertiesContainer1', or delete the node entirely, to resume caching.
Cached Playback: The presence of unsupported Bifrost node 'bifrostLiquidContainer1' has triggered Safe Mode, and caching is disabled.
                 You can continue work, but caching has stopped.
                 Remove animation from 'bifrostLiquidContainer1', or delete the node entirely, to resume caching.
 
# Warning: Cached Playback: Safe mode - cache disabled as unsupported nodes were found in the scene. See the Script Editor for details. # 
// Warning: line 1: 2019/10/27 09:42:58: AutoSave skipped since current scene is itself an auto-save file. // 

 

1 REPLY 1
Message 2 of 2
wongt
in reply to: klaassenlucas

Hello.  Dynamics is currently not supported with Cached Playback.  As such, Maya turns off this feature when a simulation node is detected.  Dynamics should work as it had in previous releases (except for the message you noted).  Please report any issues if it doesn't.

From the Documentation:

Cached Playback Limitations

While Cached Playback works for most animation in Maya, there are a few areas that remain unsupported, such as Dynamics simulations, Non-linear animation (such as the Time Editor, and Trax), as well as XGen. When Cached Playback encounters errors sending data to the cache, the status line and the Cached Playback icon turns yellow to indicate that Caching is disabled and it is in Safe Mode. See Safe Mode in the Cached Playback status line states topic for more on what you can do to fix the situation.

For a list of the times that Cached Playback is disabled, see Cached Playback limitations and Cached Playback unsupported nodes.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report