Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Malware warning

Message 1 of 5
965 Views, 4 Replies

Malware warning

Today I opened Maya and tried to load any Bifrost file and my simulations don't work. I get this error message:


file -f -options "v=0;" -ignoreVersion -typ "mayaBinary" -o "D:/MyRedneckNeighbor_VFX/vomit/scenes/vomitBlob7.mb";addRecentFile("D:/MyRedneckNeighbor_VFX/vomit/scenes/vomitBlob7.mb", "mayaBinary");
requires -nodeType "bifrostContainer" "bifrostshellnode" "";
requires "stereoCamera" "10.0";
requires -nodeType "bifrostFoamMaterial" -nodeType "bifrostShape" "bifrostvisplugin" "";
requires -nodeType "aiOptions" -nodeType "aiAOVDriver" -nodeType "aiAOVFilter" -nodeType "aiSkyDomeLight" -nodeType "aiAreaLight" -nodeType "aiStandardSurface" -nodeType "aiStandardVolume" "mtoa" "4.2.1";
requires "stereoCamera" "10.0";
// Warning: line 1259: The default image may not be modified. Use the -i/image flag instead. //
// File read in 0.81 seconds.
# Autodesk.MayaScanner : : Infected by Malware!
// Error: line 0: UnicodeDecodeError: file C:/Program Files/Autodesk/Maya2022\Python37\lib\encodings\ line 23: 'charmap' codec can't decode byte 0x8f in position 129: character maps to <undefined> //


Could this malware warning be causing this?

Message 2 of 5
in reply to: mgr0704



Try using the Maya Security Tools to clean the malware. You can get them here:


Does the problem persist after that?




Grahame Fuller
Learning Content Developer
Message 3 of 5
in reply to: Grahame_Fuller

Hi Gray,

Thanks for responding. I installed the plugin and when I opened my Bifrost file it notified me that it found a problem with the file and asked permission to fix it, which I did, but the same problem persists in that Bifrost simulation file and all my others. Also, any new file I try to create does not show or render simulation, as well as Bifrost examples, though some of those never worked for me. I also get the same message in the script editor:

# Autodesk.MayaScanner : : Infected by Malware!


But now I see I get that message for whatever file I load Bifrost or not.


It is possible I suppose the two are unrelated, but I can't think of what I have turned off so that Bifrost simulations won't display. All other files work fine, Bullet, Mash, etc.

Message 4 of 5
in reply to: mgr0704



Do you need or use the

If not, I recommend to delete it, or even better reset your Maya Preferences in your user documents folder.
For a complete reset of ALL Preferences, rename the maya folder to maya_backup.

Message 5 of 5
in reply to: mspeer

Hi mspeer,


Thanks, that solved the problem. I should have thought of that, although it was years ago I had reset default prefs  for some other problem.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report