Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to properly set the scene scale for mpm cloth ?

4 REPLIES 4
Reply
Message 1 of 5
xye863HV
735 Views, 4 Replies

How to properly set the scene scale for mpm cloth ?

Hi, I am using mpm solver to simulate cloth on a character that's about 13 centimeters high. So I try to set the scene unit in meters to 0.1. But after I do so, I had to put the detail size from 0.1 to 0.01, otherwise the collider will just go through the cloth object. Then the scene's simulation is slower than unit in meter 1.0.  And I am still getting some under water effect (cloth resting in really slow motion) after I scaled down the unit.  What parameters should I change to properly scale the cloth simulation to match my character size?

4 REPLIES 4
Message 2 of 5

 

 

Hello

 

Attached is a scene that handles tight-fitting cloth, and also assumes the modeling scale is cm and not meters.  I simply made two spheres. The inner sphere has radius 13 Maya units = 13 cm (assuming your scene-scale is cm).  The outer sphere had radius 13.3, meaning there is a 0.3cm offset between the inner sphere (the collider) and the outer sphere (the cloth).  

 

First of all - you must set the Scene Units to Meters parameter to map cm->m.  That is of course 0.01 as 1 meter = 0.01 cm. (In your post, you say you set it to 0.1 which means MPM solver thought your scene was in decimeters, not centimeters).

 

In order for the MPM cloth solver to "see" that small difference of 0.3cm between the collider and the cloth, we must set the detail_size on the solver to be close to that number.  The detail size is ALWAYS expressed in meters.  So the default value of 0.15 is likely not going to work.  In my example (attached) I used 0.05 - meaning the MPM solver will resolve simulation detail at 5cm (0.05m = 5cm).  Now, 5cm is a lot bigger than 0.3cm, but it looks like it's enough to resolve the collisions without problem - even when animating the interior sphere.  The general rule of thumb is to try to use as large a value as possible on detail_size, so just experiment to see.  Perhaps even larger values will work; I did not try.

 

Anyway hopefully this helps!  Just replace the cloth sphere, with the character's cloth geo, and the inner sphere, with your character's animated geo, and see if it works.

 

Message 3 of 5

 

Ok it looks like this forum doesn't let me upload Maya scenes!  Weird!

 

So here is a dropbox link to the scene I just mentioned:

 

https://www.dropbox.com/s/vmwkk3m3qaws29v/tight_fitting_cloth.ma?dl=0

Message 4 of 5


@marcus.nordenstam wrote:

 

Ok it looks like this forum doesn't let me upload Maya scenes!  Weird!


Known issue with the general forums... I always zip my scene files to upload them. Would be nice if this restriction got lifted, as well a the file size cap. With videos, you quickly run into file size issues.

--
MacBook Pro 13,3 - 2.7GHz - 16GB - Radeon Pro 460 - macOS Catalina 10.15
Message 5 of 5

Hi, I tried the settings in my scene, but my character is too small , it still couldn't work on it. For showing the problem,  I made an example scene of what I am trying to do. There is a body cylinder and a cloth cylinder in the scene,  they are the right size of my character's limb.  So in this file, I put the scene scale to 0.1 with detail size 0.01, and the simulation result looks under water.  I wish I could use scene scale 0.01, but then I have to put the detail size to 0.001, in which the simulation goes really slow. 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums