Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

File Cache Read and Read VDB unusable with large simulations

4 REPLIES 4
Reply
Message 1 of 5
doppelgaenger_digital
533 Views, 4 Replies

File Cache Read and Read VDB unusable with large simulations

I cached out a pretty high res aero explosion. When I switch back to Read Mode on File Cache Node or ReadVDB Bifrost just hangs on reading in the VDB files. Waited for several minutes without feedback. Can read in from VRay Volume Grid and aiVolume.

4 REPLIES 4
Message 2 of 5

VRay and Arnold don't need to do a conversion, so they will always be faster at reading VDBs than Bifrost since Bifrost converts to our adaptive tile tree structure. Several minutes sounds like a long time, however. Is every frame in your simulation hanging upon reading (even the first frame) or is it only a certain frame? Are you displaying the volume in the viewport? If so, can you try avoiding outputting the volume to the viewport to determine whether the performance bottleneck is in the viewport in the read_OpenVDB node. If at all possible, if you could provide the VDB file in question that would really help debugging this problem as well.

Message 3 of 5

I think it's best you take a look yourself.

I attached the sim file and a few cache files in the link below.

 

https://www.dropbox.com/t/KzYdsQhRHWzAFEdj

 

 

 

 

 

Message 4 of 5

Thanks @doppelgaenger_digital. I was able to reproduce your problem. This appears to be primarily a viewport issue. If I disable viewport rendering, your 4.6GB VDB file loads in about 28 seconds on my machine. If I put "voxel_fog_density" in the properties field on read_OpenVDB the time taken further reduces to 12 seconds which is comparable to the time it took in Houdini at 9 seconds.

 

If I enable viewport rendering, I was able to display the simulation after about 45 seconds but it has lots of artifacts because I don't have enough VRAM on my GTX 1070 to fit the whole simulation - maybe you'll have more luck. To achieve the 45 seconds I am using the beta version of Bifrost which has some performance fixes to the viewport. To benefit from these changes you'll have to either get on the beta version or wait for the next release, although I suspect you don't have to wait long.

Message 5 of 5

hi morten!

 

thank you for investigating! I end up on constant crashes with bigger sized volumes (~3GB and above) on my system when I try to preview in viewport. I can mesh my volume and preview. But this is not the best solution for now.

 

Threadripper 3970x
128GB Ram
GTX1080

Win10
Nvidia Studio Driver 471.41

 

Looking forward to further improvements to maybe dynamically adjust volume rendering in viewport, for better visualization and interactivity!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report