Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: Cannot set parameter

13 REPLIES 13
Reply
Message 1 of 14
pitshn
657 Views, 13 Replies

Error: Cannot set parameter

Hi,

Whenever i import a bifrost simulation from the bifrost browser, i get this error "// Error: Cannot set parameter: bDrawVolume". For example for the smoke trail, i only get the animation from the sphere and nothing for the smoke.

 

I am using Maya 2022.

Thank you.

13 REPLIES 13
Message 2 of 14
Aslan.Jafari
in reply to: pitshn

Sorry to hear about the issue you are having.

 

I have a few questions before investigating this issue further.

Which version of bifrost are you currently using?

Which operating system and version are you using?

Can you create a basic_aero_graph from the Tab search menu and simulate or do you encounter the same issue?

Can you convert a geometry to volume via convert_to_volume and display the result in the viewport?

 

Thank you

 

 

 

 

 


Aslan Jafari
Sr QA Analyst
Message 3 of 14
pitshn
in reply to: Aslan.Jafari

hi,

 

sorry for the delay, i sorted it out by resetting the prefs folder. renamed the old one and restarted maya and all worked again. Thank you for replying and sorry for wasting your time.

Message 4 of 14
pitshn
in reply to: pitshn

But i have another issue though if i may raise it here too.. whenever i increase the particles rate (in the source_particles parameter in bifrost) above 100 or enable live forever, the simulation stops after a few frames depending on the rate.

My pc specs:

Processor AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor

I have included a screen capture.

 

thank you

 

Message 5 of 14
sepu6
in reply to: pitshn

can you post the scene? I do not think that is coming from the particles, I believe is from the bruce compound, the curve influence. 

Message 6 of 14
pitshn
in reply to: sepu6

I have attached the scene in the previous message... I can send it again if you can't see it.

and yes, I am using the curve influence with the MJCG strands_wrap. I was following a tutorial and I can't figure out what might be the problem

Message 7 of 14
sepu6
in reply to: pitshn

I just see an .mp4 not a Maya File

Message 8 of 14
pitshn
in reply to: sepu6

here is the file... Sorry

Message 9 of 14
sepu6
in reply to: pitshn

Is working correctly here with the latest curve influence from Bruce as you can see. I had an error on your file because you are using an older compound. I would recommend updating it. 

 

https://forums.autodesk.com/t5/bifrost-forum/curves-influence-tool-update-demo/m-p/10159190#M4865

 

PEQ3RbX6P5.gif

Message 10 of 14
pitshn
in reply to: sepu6

hi, i updated the coumpound and tried again but i keep getting the same problem.

 

Could you check this second file for me again please?

thanks

Message 11 of 14
sepu6
in reply to: pitshn

is working fine, I open the file didn't change anything. 

 

Maya 2022.2 - BF 2.3.1

 

5l7s4unTke.gif

Message 12 of 14
pitshn
in reply to: sepu6

on your one, it looks like the LIVE FOREVER isn't enabled. But still even without it my simulation stops within 60 frames. I am confused and looks like i just have to work with lower rates until i find a solution.

Message 13 of 14
sepu6
in reply to: pitshn

Even if I enable "life forever" it works fine. Again I grabbed your file and I just press play, I didn't change anything so the file that you shared "tut2" the parameter "life forever" wasn't enable.

Message 14 of 14
pitshn
in reply to: sepu6

Well, i tried everything i could... Upgraded to bifrost 2.3.1.0, deleted all the other versions, unistalled maya 2020 but nothing changes. Maybe I need to reinstall Maya 2022 and clean up everything which is so annoying...

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report