Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

Emission/Temperature fill the whole boundingbox instead of colorising the smoke

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
MacKayver
844 Views, 9 Replies

Emission/Temperature fill the whole boundingbox instead of colorising the smoke

Hi to all,
I simulated and cached a bifrost smoke trail. Now when I try to render it my temperature/emission settings allways fill the whole volume boundingbox instead of colorising the smoke. If I change the Emission Mode from blackbody to density I haven't that problem but that will never look like fiery smoke.
 
What did I mistaken
 
Thanks ๐Ÿ™‚
 
heatup_the_whole_boundingbox.jpg
Labels (3)
9 REPLIES 9
Message 2 of 10
Grahame_Fuller
in reply to: MacKayver

Hello,

 

Have you tried the procedure described in this topic (Apply shading to aero and combustion simulations): https://help.autodesk.com/view/BIFROST/ENU/?guid=Bifrost_Common_simulate_dynamic_effects_create_aero...

 

Let us know if that helps,

gray


Grahame Fuller
Learning Content Developer
Message 3 of 10
JMM71
in reply to: MacKayver

Hi.

Your Black body kelvin is very high in the temperature settings of your volume shader

I've just applied the same settings to an aero sim and got the same result as your render

Try bringing it down from 50 to between 1-2. It might sort your problem. Currently I think you settings are so high as to make the ambient temerature glow.

 

Hope that helps

Message 4 of 10
MacKayver
in reply to: JMM71

Hi, thanks for your answer.

 

I tried a lot of different values. Yes whit a low Blackbody Kelvin the atmospheric glow is gone, but I also got only gray smoke. I want to lite up that smoke, it needs to look more like fire. But all my value changes on emission and temperature are seems to only effect the atmospheric Surroundings - not my smoke.

Message 5 of 10
mspeer
in reply to: MacKayver

Hi!

 

Please attach a scene-file, that's far easier for troubleshooting and to provide exact settings that will work.

Message 6 of 10
MacKayver
in reply to: mspeer

Hi, that would be great. Here is the scene-file.

Message 7 of 10
mspeer
in reply to: MacKayver

Hi!

 

It seems the difference between the ambient temperature and the source_air temperature is not high enough.

So there are 2 solutions:

1. In aero_solver_settings set Ambient Temperature to "0".

2. In source_air set Temperature to a higher value like 10000 or set Temperature Mode to an other value.

To check the rendering of a certain temperature voxel value set Mode to "set".

 

For aiStandardVolume1 set Temperature to "0.1" or lower and Blackbody Kelvin to "100".

 

 

However I have 2 questions, maybe @Grahame_Fuller  can answer them.

 

1. Why are Voxels with temperature values but without any density being rendered in Arnold, but not in Viewport 2.0?

Is this a bug in Arnold or Viewport 2.0?

 

2. Why does even a temperature with 20ยฐC lead to a visible glow with Blackbody Kelvin only set to "10" (other shader values at default "1")?

Usually all Temperature related attribute values of the aiStandardVolume need to be drastically lowered, with really high temperature values in the scene.

Message 8 of 10
mspeer
in reply to: MacKayver

Hi!

 

You can of course also try different values for Temperature, Blackbody Kelvin and Blackbody Intensity, which can change the look, but the key is to get at the simulation much higher temperature values for source_air than for the ambient temperature.

Message 9 of 10
Grahame_Fuller
in reply to: mspeer

Hi mspeer,

 

In response to your questions:

 

  1. I think this is a known issue on our side (for reference, BIFROST-2915). In brief, the viewport does not give a physically correct preview. However if for some reason you want to make the rendered view look more like the viewport, you can use the temperature for both the temperature channel and emission channel in the shader โ€” this results in the temperature being multiplied twice.
  2. I'm not sure yet โ€” this needs some investigation. I'll post again when I learn more.

Cheers,

gray


Grahame Fuller
Learning Content Developer
Message 10 of 10
MacKayver
in reply to: mspeer

WOO HOO (sorry a little too excited)!

To set the Ambient Temperature to "0" in aero_solver_settings was the key! Now all the values are working fine, even the Viewport looks like the RenderView.

 

Thanks to all of you. What a awesome Community!

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report