Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Bifrost particles not following emitter

4 REPLIES 4
SOLVED
Reply
Message 1 of 5
stefan.fuessinger
812 Views, 4 Replies

Bifrost particles not following emitter

Hi,

 

I'm trying to emit from a moving emitter. I looked at the deafult behaviour in this video and the particles are following the movement of the emitter and adopt the velocity vector of it:

 

https://www.youtube.com/watch?v=u4W7BZYnTNk&t=104s

 

Unfortunately, when I create an Aero container, the particles have no velocity at all. Did the default behaviour change since Maya '18. I'm using Maya 2020.

 

It also seems like only every second frame particles are emitted.

 

Thanks,

Stefan

Labels (2)
4 REPLIES 4
Message 2 of 5

Hello,

Particle emission with inherited velocity works fine for me in Maya 2020 with Bifrost 2.0.5.1 on Windows when emitting from a moving sphere. Is your velocity scale under emitter props -> conversion -> velocity scale by any chance set to zero?

Note that there's also the option of using our second generation Aero solver running in the Bifrost graph (create a bifrost graph and instantiate a basic_aero_graph or start from an example graph in the Bifrost browser).

Cheers,

Michael

 



Michael Nielsen

Principal Engineer
Message 3 of 5

Hi Michael, thanks for the reply.

 

I didnt change anything from default. I also tried to setup the scene in the bifrost graph, giving me the same result.

 

I only changed the gravity magnitude to zero. My conversion setup is attached.

 

I also attached the scene file. I'm using bifrost 2.0.3.0.

 

thanks and regards

 

 
Message 4 of 5
mspeer
in reply to: stefan.fuessinger

Hi!

 

a) Please don't set the Gravity Magnitude to "0", this will effect your simulation. I recommend to set it back to the default value.

 

b) Your object is very small in relation to the simulation grid size, so either increase object size or simply in

bifrostAeroPropertiesContainer1:

Properties -> Solver Properties -> Master Voxel Size (set to a lover value like "0.200" or "0.100", or even lower)

 

 

Message 5 of 5
stefan.fuessinger
in reply to: mspeer

Thanks alot. Didn't think the gravity would affect the simulation in this way. I didn't decrease the master voxel size for testing purposes.

 

Thanks again

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums