Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

BIFROST GRAPH EDITOR no longer posting output on viewport - tried updates and scene cleanup. Is something broken?

8 REPLIES 8
Reply
Message 1 of 9
Polytikal1
197 Views, 8 Replies

BIFROST GRAPH EDITOR no longer posting output on viewport - tried updates and scene cleanup. Is something broken?

Hello! I was using read openVDB on a heavy scene with several references. I assumed the VDB would be a light haul, but the system crashed. My scene is in .ma format, and I had already removed unknown nodes and optmized. The graphs (multiple attempts, with multiple VDB folders) will no longer post an output on viewport. I am able to identify the location of the volume container, but no volume within. I tried with assigned material and without, since I had been working with it without assigned material on the default shader mode. I have reinstalled maya and bifrost 2.6 and arnold. They are all updated, and it still doesn't post. I am not getting any messages or errors in script editor. 

 

Has anyone dealt with this before? 

 

Could the visplugin be corrupted by something in the scene?

8 REPLIES 8
Message 2 of 9
Polytikal1
in reply to: Polytikal1

Also, plugins are selection in plugin manager, and I use SSDs and one raid, and I tested on both the raided drive and the base SSD hardrive, which are no throwing any errors. I have 256GB of ram, and no other scene issues are presented, so this seems to be a bifrost challenge. Is there an attribute/node or setting that could have been corrupted in the scene that isn't throwing errors? 

Message 3 of 9
Polytikal1
in reply to: Polytikal1

I also tested "read_Alembic" to see if the issue extended beyond volume, and it does. I can select using "Modify" selector the container of the bifrost object, but there is no output in viewport. 

Message 4 of 9
Polytikal1
in reply to: Polytikal1

I can't say I understand how the problem occurred, but after my third attempt at installing and reinstalling bifrost 2.6 version, I can no see the sim on viewport. My concern is that it will happen again, if I don't understand the root cause of the problem in my scene. 

Message 5 of 9
Polytikal1
in reply to: Polytikal1

Could it be a namespace issue that corrupts visplugin? If I initially duplicated a bifrost graph pulling data from same file at different periods of time in the scene, does this conflict? 

Message 6 of 9
Polytikal1
in reply to: Polytikal1

Old take: THIS SEEMS TO BE THE CASE: 

 

Two folders, separate locations, same name, cannot be simulated (even with read node). If there is a workaround, then please let me know. Seems like a simple problem to fix, given that maya already automatically modifies the name of groups when duplicates are made. 

 

 

FINAL UPDATE: If you are running into this issue, consider whether you are using the same "read_.." node. Don't duplicate or change file within the same node. Just delete it and bring up another. I realize that this should be intuitive, but it wasn't at the forefront of my mind. Stay organized and keep your nodes clean. 

Message 7 of 9

I am afraid I am not really following what your problem is/was. If you think this is a bug and you have a reproducible scene file, we would love to have a look at it. You can send me a private message if you can't share it publicly.

Message 8 of 9

Thank you! I'm unable to send you a private message. In regards to this particular issue. I imported the scene into a new scene, and was able to get the info posted on a new graph in a newly imported scene. I'd love to DM a scene that is now corrupted to see if you can help me gain some hope. Feels lost after so much work, but to be upfront, I've made every mistake one can make, so I know that there needs to be cleanup. @morten.bojsen-hansen 

Message 9 of 9

How did you scene file get corrupted?

 

To DM you need to hover my name (for about 2 seconds), then click 'Send Private Message'.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Autodesk Design & Make Report