Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results forย 
Showย ย onlyย  | Search instead forย 
Did you mean:ย 

Bifrost does not work

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
Anonymous
2115 Views, 3 Replies

Bifrost does not work

Good morning bifrosters! I am having trouble initializing Bifrost. I just recently installed Maya 2019 for the first time, and I am currently learning the basics on how to get things done. Just by curiosity, I looked up for tutorials on Bifrost, but, whenever I click on one of the bifrost options on the ribbon, nothing happens and I get the following error:

(From the script editor)

CreateBifrostLiquid;
// Error: line 1: Cannot find procedure "CreateBifrostLiquid". //

I hope you guys know how to solve this, and even if not, every bit of help would be really apreciated ๐Ÿ˜„

 

Tags (1)
3 REPLIES 3
Message 2 of 4
wongt
in reply to: Anonymous

Hello.  I'm going to need a bit more information.  Are you trying to get access to the  Bifrost Fluids (liquids) or the new Bifrost Graph Editor?

For the Bifrost Fluids, you will need to switch to the FX menuset and go to the Bifrost Fluids menu (see image bifrostFluids.png). 

For the Bifrost Graph Editor, you can open that window through the Windows menu (see image bifrostGraphEditor.png).

 

From the error message you sent, it looks like you were trying to setup a Bifrost liquid.  If that was intentional, it looks like an initial BifrostLiquid was not created.  You will need that before creating Foam, Colliders, Fields, etc. 

You can create an 'empty' liquid by selecting Bifrost Fluids>Liquid or selecting a Maya mesh and then selecting Bifrost Fluids>Liquid.  The latter workflow will use the selected mesh as an emitter. 

Message 3 of 4
Anonymous
in reply to: wongt

Well, I can't seem to find any of those menus ๐Ÿ˜ž

(In one of the images, the buttons underlined in blue are the ones that trigger the error)

Tags (1)
Message 4 of 4
Anonymous
in reply to: wongt

Thank you for your help and sorry for any inconvenience that I may caused, but I have found the solution. It turns out that the some bifrost plug-ins were disabled, so that's why it didn't work in the first place, but again, thanks for your help ๐Ÿค 

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums