Community
Bifrost Forum
Welcome to the Bifrost Forum. This is the place for artists using Bifrost to ask and answer questions, browse popular topics, and share knowledge about creating effects procedurally using Bifrost. You can also visit the Bifrost Community on AREA to download an array of ready-to-use graphs, read Bifrost news and updates, and find the latest tutorials.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

alembic points to instances

9 REPLIES 9
SOLVED
Reply
Message 1 of 10
adrian_wyer
259 Views, 9 Replies

alembic points to instances

im reading a cache of points created in embergen and exported as alembic

they show up in bifrost/viewport but i can't seem to use the points to generate instances (i need to instance spheres to be able to render in redshift)

short term i can render in arnold, but not an option going forward

is there a method for pulling points from a cache and using them as you would as if you had scattered points yourself?

 

thanks

 

a

9 REPLIES 9
Message 2 of 10
adrian_wyer
in reply to: adrian_wyer

i thought this might work but the create instances node is red when connected; https://forums.autodesk.com/t5/bifrost-forum/x-particles-to-bifrost/m-p/12162732

weird that it will render in arnold but not allow me to do anything with the incoming data

Message 3 of 10
sepu6
in reply to: adrian_wyer

Yes, it does work, if you bring your own point cloud from a different DCC. Probably embergen is doing something weird to the properties/attributes. 

 

If you can post a scene? Just one frame would suffice 

Message 4 of 10
adrian_wyer
in reply to: adrian_wyer

brilliant, here's a frame of the cache.. maybe you can tell from the file what's not working correctly... ?

odd that it will read/display/render in arnold, but won't allow any access to the data in a graph

Message 5 of 10
sepu6
in reply to: adrian_wyer

it's working correctly for me 

 

maya_MBhSMrv248.png

Message 6 of 10
sepu6
in reply to: adrian_wyer

I re-read your post you wanted to get the point velocity into the orientation. Here you go.  If you check the point scope and see the velocity you will see that the cone matches the direction. I think that is what you want

 

maya_8uaKds43Yj.png

Message 7 of 10
adrian_wyer
in reply to: adrian_wyer

actually i just wanted to be able to merge the instance mesh, and go through a "bifrost geo to maya" in the node editor to be able to render in redshift... longing for redshift instancing support 😓

however from your scene i see what i was missing was the "first in array" i was trying to connect the alembic reader straight into the "create_instances" which didn't work... 

something ICE used to do that would be amazing to get in bifrost, is hovering over ports on none working nodes, and have a popup explain what the node was expecting, versus what you are feeding it... would be immeasurably helpful when learning where i have gone wrong!

thanks for the fix, all working now (if a little slow!)

 

Message 8 of 10
sepu6
in reply to: adrian_wyer

Yeah right now to see the properties (W between the connections) of an object it can't be an array, because it will tell you the size, so that is why I have to use a first-in array or get from array, so for example, if you look at the alembic is saying one since is just one object there. This will get better soon hopefully with some kind of spreadsheet/data browser etc. 

 

maya_d0hA36Yfq3.png

Message 9 of 10
adrian_wyer
in reply to: adrian_wyer

got it all setup and working via the merge instance mesh/ bifrost to maya mesh... but even using 1x1 planes for the particles, it's SO slow to do the merging and mesh out... renders fine, but the scene is unworkable....

will have to render in arnold for this pass...

thanks again for your help today

 

a

Message 10 of 10
sepu6
in reply to: adrian_wyer

Yep, one thing that you can do is go here and tell the RS Maya dev to add procedurals to Redshift that will alleviate the pain a little.  Both ABC and USD procedurals 

 

https://redshift.maxon.net/topic/42867/bifrost-graph-support-maya/16

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums