Communauté
AutoCAD – tous produits - Français
Bienvenue sur les forums AutoCAD d’Autodesk. Partagez vos connaissances, posez des questions, et explorez les sujets AutoCAD populaires.
annuler
Affichage des résultats de 
Afficher  uniquement  | Rechercher plutôt 
Vouliez-vous dire : 

AutoCAD : Problème ligne d'attache pour les cotations

13 RÉPONSES 13
RÉSOLU
Répondre
Message 1 sur 14
admin3U6L3
215 Visites, 13 Réponses

AutoCAD : Problème ligne d'attache pour les cotations

Bonjour, voilà ça fait un petit temps que j'utilise le même style de côte et pourtant la bonne mise en forme de la côte se fait plus sur mes nouveaux fichiers... En gros je veux une longueur fixe de la ligne d'attache, sauf que soit elle n'apparait, soit elle apparait mais est variable en fonction de l'espacement de mon accroche et de la côte. Ensachant que j'ai les mêmes paramètre qu'avant et que la case longueur fixe de la ligne d'attache est bien cochée.


Le titre du sujet a été modifié par un modérateur pour faciliter la recherche. Titre original:
Problème ligne d'attache pour les cotations

13 RÉPONSES 13
Message 2 sur 14
pendean
en réponse à: admin3U6L3

Greetings @admin3U6L3

 

Show your work please by sharing a portion of the problematic DWG file, and do your best to identify the correct DIMSTYLE you want to use in it and point out the dimensions that do not comply with it.

Message 3 sur 14
admin3U6L3
en réponse à: admin3U6L3

Il faudrait que les lignes d'attache soit fixe et dans ce plan ci-joint elles ne le sont pas...

Message 4 sur 14
tramber
en réponse à: admin3U6L3

Ton dessin est 3D. C'est ce que je note tout de suite.

tramber_0-1714459606683.png

Tu peux essayer FLATTEN sur ces objets.

Mais c'est un pis-aller. Il faudrait réparer attentivement le dessin pour le faire bien 2D.

Message 5 sur 14
admin3U6L3
en réponse à: tramber

Je n'ai que autocad LT donc pas de 3D... Et au final en travaillant toujours avec les mêmes côtes, d'un coup elles sont redevenu comme je le voulait mais impossible de mettre à jour les précédentes et ni de copier les propriétés dessus

Message 6 sur 14
admin3U6L3
en réponse à: admin3U6L3

Je remarque que maintenant que cla fonctionne même si j'efface et que je recommence ma cotation sur celle qui n'étaient pas bonnes, ça ne change rien. La ligne d'attache ne se met pas.

Message 7 sur 14
tramber
en réponse à: admin3U6L3

LT est parfaitement 3D. Ton dessin est 3D.

On peut travailler les objets un par un dans les propriétés, ca fait un bon apprentissage....

tramber_0-1714463065827.png

 

Sur LT comme sur une autre version, c'est pareil.

Je prends tous les objets, vais dans les propriétés et les sous-filtre type par type.

Comme cela c'est facile d'applatir les lignes de changer les élévations des polylignes ou le Z d'un centre ou d'un point d'insertion de bloc...

Il y a donc un peu de travail.

tramber_1-1714463188527.png

 

Message 8 sur 14
admin3U6L3
en réponse à: tramber

D'accord merci beaucoup autant pour moi !

Message 9 sur 14
tramber
en réponse à: admin3U6L3

Plus simple que Flatten, cela m'a pris moins d'une minute.

Tous les points que l'on voit dans l'espace sont des point d'accroche des cotations. De l'histoire ancienne, pour les futures, car ces points ne bougeront plus.

tramber_2-1714463326816.png

Utilise la commande VUE ou POINTVUE. Je pense qu'elles existent sur LT. Même si tout ce que je décris peut se faire sans changer de point de vue...

Message 10 sur 14
admin3U6L3
en réponse à: tramber

Je n'ai juste pas le même ruban, donc je retrouve bien mon Z dans les propriétés mais impossible de le mettre sur 0.00 puisqu'il dit qu'il ne peut pas être égal à 0

Message 11 sur 14
tramber
en réponse à: admin3U6L3

On prend tous les objets, on ouvre la palette des propriétés (je ne parle pas des rubans, on ne lance pas de commande ici).

On sous-filtre toutes les catégories une par une et on met du 0 dans les Z qui devraient recevoir cette valeur et ca marchera. Il ne dira rien de tel 😎 Un Z peut toujours être égal à zéro, il n'y a pas d'exception.

Message 12 sur 14
admin3U6L3
en réponse à: tramber

Je l'ai fait et malheureusement ça ne marche toujours pas 

Message 13 sur 14
rebcao
en réponse à: admin3U6L3

Bonjour,

 

Pour rattraper le problème des objets en Z, tu peux utiliser la bonne vieille méthode du DEPLACER 0,0,0 à 0,0,1e99...

 

   1. Tu ACTIVES, LIBERES, DEVERROUILLES tous les calques

   2. CONTROL + A puis commande DEPLACER

   3. Origine 0,0,0

   4. Point d'arriver *0,0,1e99  (* = si bouton DYN Actif)

   5. DEPLACER Précédent

   6. Origine 0,0,1e99

   7. Point d'arriver *0,0,0  (* = si bouton DYN Actif)

 

C'est une astuce qui "explose" la PRECISION d'AutoCAD...

 

Si tu es sur une LT 2024-2025 comme on peut utiliser du LISP, il me semble qu'il y a un LISP qui fait ça ?

 

Christian


Formateur Indépendant, Consultant, AutoCAD, AutoCAD LT, REVIT MEP, INVENTOR -
www.rebcao.fr

Christian REB

Message 14 sur 14
patrick.emin
en réponse à: admin3U6L3

Bonjour @admin3U6L3 

La communauté a essayé de répondre à votre question. Si vous pensez qu'une ou plusieurs de ces réponses vous aident, voulez vous avoir l'amabilité de cliquer sur le bouton  APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Merci de ne pas accepter comme solution le message que vous êtes en train de lire.
Si nos équipes de support technique ont pu vous apporter une solution ou contribuer significativement à vous aider en dehors de ce forum, pouvez vous partager ici la solution trouvée et cliquer sur le bouton  APPROUVER LA SOLUTION  de façon qu'elle bénéficie à la communauté?
Merci.


Patrick Emin animateur de la communauté francophone


Vous avez trouvé un message utile? Alors donnez un "J'aime" à ce message!
Votre question a eu une réponse satisfaisante? Voulez vous avoir l'amabilité de cliquer sur le bouton
 APPROUVER LA SOLUTION  en bas de la réponse qui apporte une solution?
Signez notre Livre d'Or

Vous n'avez pas trouvé ce que vous recherchiez ? Posez une question à la communauté ou partagez vos connaissances.

Publier dans les forums  

Autodesk Design & Make Report