Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Verdoppelung des Blockinhalts in unterschiedlichen Versionen

3 ANTWORTEN 3
Antworten
Nachricht 1 von 4
eSupport2005
361 Aufrufe, 3 Antworten

Verdoppelung des Blockinhalts in unterschiedlichen Versionen

Dieser Thread hier sollte meinem Problem entsprechen ausser, dass ich keine dynamischen Blöcke nutzen und nicht im LT sondern Architecture arbeite!

 

https://forums.autodesk.com/t5/autocad-lt-forum/block-issue-spontaneous-duplication-of-objects-withi...

 

Im Anhang ein beispiel... Am Schluss macht man die Arbeit doppelt. Das wieder zu trennen ist quasi unmöglich.

 

Bei diesem Beispiel hat jemand die Zeichnung vor dem Mittag geschlossen, nach dem Mittag wollte er sie öffnen.

Da kam eine Meldung, dass die DWG Wiederhergestellt werden muss (2 Fehler), dann noch mal mit 6 Fehler, ab da war der Blockinhalt von den zuletzt bearbeiteten Blöcken verdoppelt und verdreifacht mit eben der Version bevor sie bearbeitet wurden und der aktuellsten version...


Zeichnungen Vergleichen hilft einem da leider auch nicht, gibt es da schon Hinweise, wieso so etwas passieren kann?

 

Falls es sonst niemand hat, der dieses Problem kennt, dann schaue ich ob es Intern an unserem Setup liegt. Aber vor v2020 hatte ich das noch nie. Jetzt zum dritten mal passiert innerhalb der letzten Monate. Also auch nicht wirklich oft...

 

Aber der Fehler frisst so viel zeit, dass ich ihn gerne Pro aktiv abstellen möchte!

 

Danke für alle Hilfe


======================================================================
OS: Win 10
HW: HP Mini Z2
CAD: Revit -- AutoCAD Architecture
by zeddicus zu'l zorander: "nothing is ever simple"
3 ANTWORTEN 3
Nachricht 2 von 4
cadffm
als Antwort auf: eSupport2005

Moin,

 

 

>>"gibt es da schon Hinweise, wieso so etwas passieren kann?"

Das ist eine BlackBock, man kann aber vermutungen anstellen..

 

>>"Falls es sonst niemand hat, der dieses Problem kennt,"

Das Problem ist schon bekannt, aber für öffentliche Foren(bzw. die Recherche) ein schwieriges Thema,

denn viel häufiger ist es eionfach ein Anwenderfehler und die Recherche inkl. Ergebnis im CAD sind

dabei identisch - unmöglich herauszufinden ob es im gefundenen Text nun um das eine oder das andere geht.

(Dabei ist es egal wie gut oder lang derjenige schon Anwender ist)*

 

>>"dann schaue ich ob es Intern an unserem Setup liegt."

*Bei dir gehe ich von dem bekannten techn.Problem aus, in keinem Fall liegt es an einem "Setup"

 

>>"Aber vor v2020 hatte ich das noch nie."

Hättest du aber schon haben können, es ist nicht 2020 spezifisch.

 

>>"Jetzt zum dritten mal passiert innerhalb der letzten Monate. Also auch nicht wirklich oft..."

DAS ist ein Problem: Es ist nicht 1:1 reproduzierbar und vor allem ist es ein Datenbankproblem was erst mit

einem WHERST oder  PRÜFUNG sichtbar wird (als der Versuch von ACAD ein Problem zu beseitigen).

 

>>"Aber der Fehler frisst so viel zeit, dass ich ihn gerne Pro aktiv abstellen möchte!"

Und Ihr habt da noch ein geringes Problem (Häufigkeit) unter den Betroffenen.

___

 

Den Tip den ich immer gebe: Schaltet die inkrementelle Speicherung ab! ISAVEPERCENT=0

Das mag die Sache nicht zu 100% unterbinden denn es hilft wohl nicht bei jedem zu 100%,

vielleicht liegt das dann aber auch an der Weiterverwendung von ohnehin bereits problematischen Dateien, i don't know.

(Hinweis: Der Modellbereich ist auch nur ein Container wie alle andere Blöcke, das Problem kann also durchaus auch im Modellbereich auftauchen)

 

Von AutoDESK konnte ich dazu noch nie etwas lesen, Rückmeldungen von Usern, welche mit dem Problem an den Support gingen, waren ebenfalls ohne Mehrwert.

 

Ein jüngster Hinweis aus dem engl. sprachigen Forum noch:

Ein User ist der Meinung festgestellt zu haben: Es passiert wohl nur oder zumind. deutlich häufiger wenn

mehrere Dateien geöffnet sind.

Da ich und ein Großteil der anderen User aber immer mehrere Dateien offen haben und nichts passiert

messe ich dieser Beobachtung/Rückschluß nicht wirklich Bedeutung zu.

 

1. Bin recht sicher das es ein Speicherfehler ist in Zusammenhang mit der inkrementellen Speicherung,

wobei es wohl auch andere Fälle mit gleichem Resultat gibt.

2. Da dieses Problem a) nicht jeder b) nicht immer hat,

    kann auch der Speicherort relevant sein - aber nicht nur

    kann auch sonstiges am System(PC) relevant sein - aber nicht nur

 

Unterm Strich:

Backups/Kopie sind wertvoll

SpeichernUnter oder ISAVEPERCENT=0 sollten das Problem minimieren

 

WHERST/PRÜFUNG lässt die Objekte erscheinen, das Problem in der Datenbank besteht aber ja vorher..

und dies ist nicht einsehbar für uns, zumindest nicht für mich.

 

--

Wir hatten mal als Auftrag die Kontrolle von CAD-Daten nach strengen CAD-Vorgaben,

Jede zweite Einreichung an CAD-Daten eines AN im Projekt mußte ich eine Zeit lang immer ablehnen (nicht freigegebene Blöcke => doppelte Elemente).

Lösung: Ich stellte eine Zeit lang ein Programm zur Verfügung welches die Sache überwachte!

Da es nicht meine eigene Arbeit war und dies auch nicht beauftragt wurde habe ich nur

eine zeitlich begrenzte Version und nur für die Prüfung beim schließen der Datei zur Verfügung

gestellt -> Ergebnis: Ich bekam danach wieder wie gewohnt schlechte Dateien, aber das "Doppelt Problem" nicht mehr auf den Tisch 😋

 

Ich hatte auch ein Programm zum provozieren des Fehlers geschrieben.. Ergebnis: Auf meinem Rechner 0%

Auf dem Kunden-Rechner 0%

Es muss daher von mehreren Faktoren abhängig sein, eine Vermutung habe ich auch - aber 

in dem Bereich habe ich zuwenig Ahnung um das ganze zu untermauern.

 

Sollte ich mal das Problem haben würde ich alle Blockbearbeitne und Speichern-Vorgänge überwachen,

vielleicht erhält man so noch weitere Hinweise. Allerdings: Das geht nut wenn es wirklich häufig vorkommt,

3x im Monat oder 3x in der Woche reichen dafür kaum aus.

 

 

 

Sebastian

EESignature

Nachricht 3 von 4
eSupport2005
als Antwort auf: cadffm

Danke für diese sehr ausführliche Antwort.

 

Schade, dass diesem Phänomen niemand auf die schliche kommen kann...

 


@Tarek_K

Ich werde diesen Beitrag noch offen lassen, vielleicht gibt es doch noch eine Offizielle Antwort?

 


======================================================================
OS: Win 10
HW: HP Mini Z2
CAD: Revit -- AutoCAD Architecture
by zeddicus zu'l zorander: "nothing is ever simple"
Nachricht 4 von 4
cadffm
als Antwort auf: eSupport2005

I found the problem, which is mostly the problem i guess. [Explanation]

 

I showed AutoDesk exactly and explained what I know, everything else is in the hands of AutoDESK.

 

And for all users it simply means: ISAVEPERCENT = 0
to avoid future problems with the BEDIT.

(Attention: You can already have the problem in the file, it doesn't have to be visible for this, but I don't want to explain everything in detail again here.
If someone thinks this does not apply to his situation, he is welcome to contact us by PM)

Sebastian

EESignature

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen  

Autodesk Design & Make Report