Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Probleme von Subassembly Composer PKT Dateien aus Civil 3D Enhancement v1

16 ANTWORTEN 16
GELÖST
Antworten
Nachricht 1 von 17
Udo_Huebner
778 Aufrufe, 16 Antworten

Probleme von Subassembly Composer PKT Dateien aus Civil 3D Enhancement v1

Nach Installation des Civil 3D 2017 Enhancements v1 stehen ja weitere neue Querschnittsbestandteile als PKT Dateien zur Verfügung, die man gemäß folgender Anleitung in die Werkzeugpalette aufnehmen kann.

 

Leider bekomme ich beim Ausführen der Werkzeuge/Querschnittsbestandteile eine FehlermeldungUH-CIvil2017-v1-SACproblem2.pngUH-CIvil2017-v1-SACproblem1.png

Kenn jemand das Problem und ggf. auch die Ursache?

 

 

Gruß Udo Hübner (CAD-Huebner)
16 ANTWORTEN 16
Nachricht 2 von 17
Udo_Huebner
als Antwort auf: Udo_Huebner

Zur Ergänzung: wenn ich die PKT Dateien wie z.B. "BasicBench.pkt" neu mit dem Subassembly Composer 2017 speichere, kann ich sie anschließend problemlos mit AutoCAD Civil 3D verwenden. Evt. ist es ein Windows Berechtigungsproblem mit den in PKT Dateien eingeschlossenen DLL Dateien.

Über Feedback, bei wem es problemlos klappt und wo nicht, würde ich mich freuen.

Einen Workaround zur Verwendung der neuen Querschnitte hab ich nun schon selbst gefunden. Aber die eigentliche Ursache ist noch nicht geklärt.

 

Hier noch der Link, wie die Querschnittsbestandteile importiert werden.

 

Gruß Udo Hübner (CAD-Huebner)
Nachricht 3 von 17
Alfred.NESWADBA
als Antwort auf: Udo_Huebner

Hi,

 

ich kann es leider nachvollziehen, ich habe auch versucht, das PKT "BasicBench" mit dem SAC zu öffnen und mit einem neuen Namen zu speichern und dann dieses zu verwenden, gleiches Problem mit den Script.

Ich gestehe aber auch, dass ich das PKT jetzt nicht nach der Ursache durchgegangen bin.

 

Also leider keine Lösung, nur eine Bestätigung, dass es auch andere Betroffene gibt.

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 4 von 17

Hallo @Udo_Huebner, Hallo @Alfred.NESWADBA,

 

ich kann das hier bei mir nicht nachvollziehen. Ich habe die PKTs ohne Probleme geladen. Ich würde es gerne mit einer Ihrer PKT Dateien nochmal versuchen. Könnten Sie die hier anhängen?

 

 



MaximilianKroner

Technical Support Specialist

Nachricht 5 von 17

Hi,

 

eines liegt bei, aus Eurem Productivity Pack 😉

Quellverzeichnis bei Windows 10 Installation:

C:\ProgramData\Autodesk\C3D 2017\deu\v1 Enhancements Subassemblies\Metric

 

Interessant wäre, ob Dein Civil 3D 

  1. englisch ist
  2. das englische statt dem deutschen Codes-File verwendet

(das wären die ersten Unterschiede, die Ursache sein könnten).

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 6 von 17

Hi,

 

und nun die Datei (da diese zuvor nicht hochgeladen werden konnte).

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 7 von 17
Karsten.Saenger
als Antwort auf: Alfred.NESWADBA

Hallo @Udo_Huebner, @Alfred.NESWADBA,

 

das ist interessant!

Ich habe den Import der PKT Daten des Enhancement Kit's auf zwei Systemen (DEU und ENU) ohne Probleme durchführen können, allerdings auf Windows 7.

Da @maximilian.kroner das gleiche auf Windows 10 erfolgreich getan hat, glaube ich nicht an ein Problem mit der Windows Version.

Ich kenne aber einen weiteren Fall, bei dem ein polnischer Kunde sein selbst erstelltes PKT (nur eines von mehreren) aufgrund der gleichen Fehlermeldung nicht verwenden kann.

Wir werden hierzu weiter recherchieren und uns wieder melden.

 

Viele Grüße,

Karsten.



Karsten Saenger
Nachricht 8 von 17
Karsten.Saenger
als Antwort auf: Karsten.Saenger

Noch eine kurze Frage: Was steht im Panorama Fenster?
So etwas wie ".NET subassembly project, module, or class not found..."?

Karsten.


Karsten Saenger
Nachricht 9 von 17
Udo_Huebner
als Antwort auf: Karsten.Saenger

Hallo Karsten,

bei mir war die Meldung in der Ereignisanzeige:

... -Modul- oder -Klasse nicht gefunden. (Quelle: )

Wie man eigentlich noch auf dem Screenshot 2 in meinem ersten Beitrag erkennen sollte.

Gruß Udo Hübner (CAD-Huebner)
Nachricht 10 von 17
Udo_Huebner
als Antwort auf: Udo_Huebner

Laden kann ich Querschnittsbestandteile, bei denen die DLL Version in den Dateieigenschaften z.B.

10.5.604.0 ist (11bordsfase) oder ein neu mit Subassembly Composer 2017 erstellter oder neu gespeicherter Baustein (11.0.656.0).

Die Querschnittsbestandteile aus der Civil 3D 2017 Enhancemance v1" haben bei mir die dll Version (11.0.658.0) und lassen sich nicht verwenden. Ob das von Bedeutung ist?

 

 

Gruß Udo Hübner (CAD-Huebner)
Nachricht 11 von 17
Udo_Huebner
als Antwort auf: Udo_Huebner

Das Problem tritt auch noch bei anderen auf.

http://forums.autodesk.com/t5/autocad-civil-3d-forum/civil-3d-2017-v1-enhancements-subassembly-error...

Ich betreibe Civil 3D 2017 SP1.1 (11.0.771.0) / AutoCAD 2017 SP1 (N.104.0.0) deutsch derzeit unter Windows 10.0.14393

Gruß Udo Hübner (CAD-Huebner)
Nachricht 12 von 17
Karsten.Saenger
als Antwort auf: Udo_Huebner

Hallo @Udo_Huebner,

 

ich kann bestätigen, dass es funktioniert, wenn die PKT Datei im SAC geladen, dort eventuell umbenannt wird, und wieder gespeichert wird.

Was die Ursache dafür ist, warum es an manchen Systemen funktioniert und an anderen nicht, ist derzeit nicht bekannt; ich habe es der Entwicklungsabteilung gemeldet und gebe hier gerne ein Update, sobald ich Neues höre.

Viele Grüße,

Karsten.



Karsten Saenger
Nachricht 13 von 17
Alfred.NESWADBA
als Antwort auf: Karsten.Saenger

Hi Karsten,

 

>> ich kann bestätigen, dass es funktioniert, wenn die PKT Datei im SAC geladen, dort eventuell umbenannt wird, und wieder gespeichert wird.

Kann ich leider nicht bestätigen (siehe Post 3 in diesem Thread).

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 14 von 17
Udo_Huebner
als Antwort auf: Alfred.NESWADBA

@alfred

Hallo Alfred, kannst du angehängte (von mir neu gespeicherte) UHBasicBench.PKT Datei mit Civil 2017 (SP1.1 ?) verwenden?

 

Gruß Udo Hübner (CAD-Huebner)
Nachricht 15 von 17
Alfred.NESWADBA
als Antwort auf: Udo_Huebner

Hi,

 

ich bekomme leider beim Öffnen des Links eine Fehlermeldung, also komme ich zu den Daten leider nicht hin.

 

20160930_1647.png

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 16 von 17
Udo_Huebner
als Antwort auf: Alfred.NESWADBA

Hatte ich auch - ich musste meinen Browsercache löschen, da ist vor Kurzem was an A360 Drive aktualisiert worden - so ist das mit der Clouddatenspeicherung.

Hier noch mal der Link zu UHBasicBench.pkt,  sollte dann klappen http://a360.co/2dqhNPG

 

 

Gruß Udo Hübner (CAD-Huebner)
Nachricht 17 von 17
Alfred.NESWADBA
als Antwort auf: Udo_Huebner

Hi Udo,

 

Dein letzter Link hat funktioniert, und Dein PKT ebenfalls.

Und das hat mich dazu verleitet, nochmals mein "in SAC öffnen und neu abspeichern" zu überdenken ==> es funktioniert auch bei mir (als solches sorry für die neg. Rückmeldung!), wenn ich im SAC auch intern den Namen des Subassemblies ändere. Das war dann wohl zu wenig nachgedacht meinerseits.

 

Danke für hartnäckig sein 😉

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen  

Autodesk Design & Make Report