Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Blockattribute nach Änderung chaotisch in Mulitführungslinie

3 ANTWORTEN 3
Antworten
Nachricht 1 von 4
bluedots
107 Aufrufe, 3 Antworten

Blockattribute nach Änderung chaotisch in Mulitführungslinie

Guten Tag,

 

ich hatte einen funktionierenden Block mit Attributen, eingebunden in einer Multführungslinie.

Dann habe ich den gesprengt, um Schriftgröße, Position und Mehrzeiligkeit zu verändern. (Ja, man kann es auch im Blockeditor ändern, ohne zu sprengen).

Dann habe ich alles von oben links nach unten rechts markiert und als Block mit dem selben Namen gespeichert. (s. Anhang)

Wenn ich nun eine bestehende (!) Mulitführungslinie doppelklicke ist totales Wirrwarr bei den Werten und Attributnamen, siehe Screenhot.
Screenshot 2024-03-12 134935.png

 

 

 

 

Ich habe jetzt einiges probiert und auch ATTSYNC und RGA bringen keine Besserung.

Nur bei neu eingefügten MFL wird halt die Änderung aktiv, bzw. entsteht nicht das Problem.

 

Es gibt zwar über den Blockeditor (s. ganz oben) eine Alternative, aber dennoch:

Was habe ich an welcher Stelle falsch gemacht? Oder ist es ein Bug?

 

Danke schon mal!

 

Best regards
MfG
Torsten
----------
ACAD 2022
Win 10 Pro, 64 bit
AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
RAM 32 GB
NVIDIA GeForce GTX 1660 S
Beschriftungen (1)
3 ANTWORTEN 3
Nachricht 2 von 4
bluedots
als Antwort auf: bluedots

Mir scheint die Blockreferenz, also das "Original" macht hier Probleme, obwohl neu definiert...

Best regards
MfG
Torsten
----------
ACAD 2022
Win 10 Pro, 64 bit
AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
RAM 32 GB
NVIDIA GeForce GTX 1660 S
Nachricht 3 von 4
microcaddy
als Antwort auf: bluedots

Hallo,

ich habe mir Deinen Block einmal angesehen. Hier sind nur einige grundsätzliche Dinge missachtet worden.

Den Block mit Ursprung zu sprengen ist zunächst nicht verkehrt.

Anschließend die einzelnen Attribute und Texteinträge systematisch anklicken und in den Eigenschaften sehen, was dort eingetragen ist (Hinweis: Attributsnamen sind stets groß geschrieben).

INDEX_NO  - kann so belassen werden, da alles richtig vorgegeben ist

Änderung - dies ist MText - kein Attribut

AENDERUNG - hier stehen beim Wert sog. Textstrings (z.B. bedeutet \d, dass ein Absatz gesetzt wird) - wie dieser String dort hingekommen ist ist nicht festzustellen) deshalb dieses Attribut löschen und ein neues Attribut definieren (ATTDEF)

Anm.v.  - MText

DATUM  - ok, kann so übernommen werden

GEZ  - ebenfalls OK

 

Nun den Block neu definieren - dabei bei der Objektwahl zunächst KEINE Attribute wählen und diese anschließend in der Reihenfolge wählen, in der Sie in der Attributsübersicht erscheinen sollen.

 

Dann müsste also alle wieder funktionieren.

 

Viele Grüße

Wolfgang

 

 

Nachricht 4 von 4
cadffm
als Antwort auf: bluedots

@bluedots

Ob es AUCH an dir (deinen Arbeitsschritten) lag oder nicht, habe ich nicht geprüft - zumal diese uns nicht 1:1 vorliegen und die alte Blockdefinition auch nicht.

Wie auch immer, auf diesem Weg kam Acad bei der Aktualisierung von bestehenden Multiführungen durcheinander, Gestolpere kam es durch Änderung oder Ergänzung der mehrzeiligen Attributdefinition.

Kennt man die Änderungsschritte, kann man es leicht (auch selbst) testen.

 

Hast du den alten Block noch? Dann teilen und etwas genauer erzählen wie vorgegeangen wurde im Bedit.

 

@microcaddy 

>>"(Hinweis: Attributsnamen sind stets groß geschrieben).

Ausgerechnet für Autodesk-Nutzer, ein sehr guter Tip! Noch besser wäre es freilich, wenn Adesk nachbessern würde.

 

 

>>"AENDERUNG - hier stehen beim Wert sog. Textstrings (z.B. bedeutet \d, dass ein Absatz gesetzt wird)

Bitte vergesse diese Vokabel in diesem Zusammenhang wieder, niemand und nirgends wird "das" als TextString betitelt, außer das es als Teil in einem String (Text) vorkommen kann.

Es handelt sich um die (internen) MText- Formatierungscodes, diese werden direkt im Textwert gespeichert,

wie man auch in den Eigenschaften oder der LISTE  von MText und mehrzeiligem Attribut sehen kann.

Seit 15 Jahren können Attribute als Mehrzeilig angelegt werden und man kann einen großen Teil der MText-Möglichkeiten in diesen nutzen.

 

 

>>"- wie dieser String dort hingekommen ist ist nicht festzustellen)

Aber offensichtlich, es ist der vom User gewünschte Breitenfaktor und voreingestellte Absatz,

nur ist der Wert im falschen Attribut der MFührung gelandet.

 

>>"Nun den Block neu definieren / Dann müsste also alle wieder funktionieren"

Der Block ist ja in Ordnung, es bedarf keiner Block Änderung,

es geht nur um die falsche Attributwert-Zuordnung in den bestehenden Multiführungslinien.

 

 

- Sebastian -

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen  

Autodesk Design & Make Report