Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

AutoCAD 2019 Liniendarstellung fehlerhaft

20 ANTWORTEN 20
GELÖST
Antworten
Nachricht 1 von 21
alexander.adamsZKU33
2879 Aufrufe, 20 Antworten

AutoCAD 2019 Liniendarstellung fehlerhaft

Guten tag liebes Forum,

 

wir haben ein Problem mit der Darstellung von 2D-Linien in AutoCAD2019.

Schilderung:

 

1: Zeichnen von 2D-Linien als STRICHLINIE -> Linie wird korrekt im Papierbereich angezeigt und reagiert auch auf Änderung der Eigenschaften (Linientypfaktor, Stärke etc.)

2: Rein-und Rauszoomen aus der Zeichnung oder Bildausschnitt verschieben -> Linie wird durchgezogen dargestellt (also falsch), ist aber laut Eigenschaften natürlich weiterhin eine STRICHLINIE

3: Dann ganz weites Reinzoomen und /oder REGEN -> Strichlinie wird als solche wieder dargestellt

 

woran kann das liegen? Auf Dauer ist an flüssiges Arbeiten so nicht zu denken.

Der PC und der Bildschirm erfüllt alle Mindestvoraussetzungen mehr als genug. In AutoCAD 2018 und 2015 tritt dieses Problem bei gleichem PC nicht auf.

 

Vielen Dank für Lösungshinweise.

 

20 ANTWORTEN 20
Nachricht 2 von 21

Hi,

 

Please make sure you have updated AutoCAD 2019 with Update 1

Next to disable hardware acceleration (command _GRAPHICSCONFIG)

Also use command _AUDIT to make sure your drawing file has no errors embedded.

In case you have a second workstation ... does the same happen on that system?

 

If you can show the effect using a video recorder like Autodesk Screencast (>>>click<<<), this would help to see what you get, also upload your dwg-file so we can look into the objects and dwg-internal settings.

 

- alfred -

 

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 3 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

Alles was der englisch schreibende Mensch sagt und dazu noch die Frage nach Systemvariable
REGENMODE

Und: Nutzt Ihre eine Plotstiltabelle und last auch die Bildschirmanzeige entsprechend der Plotstiltabelle anzeigen?
Bitte mal mit einer Seiteneinrichtung testen in der "Plotstile anzeigen" deaktiviert ist.

Solltet Ihr jedoch 2015/2018 mit identscher Datei, gleichem Layout verglichen haben, so fällt mir auch nur die Grafik ein (ob windows oder Acad).

Bitte packe mal die DWG mit (nur) einer Linie und ggf Layout/Ansichtsfenster mit ETRANSMIT inkl. aller externen Daten und lade das Paket hier hoch.
Die Beschreibung ist generell nicht so eindeutig um daraus viele Rückschlüsse ziehen zu können, die DWG hilft vieles zu klären.
- Sebastian -
Nachricht 4 von 21
Alfred.NESWADBA
als Antwort auf: cadffm

Oh, sorry,

 

wäre deutsch ... das Verhältnis Schlaf zu Arbeit scheint nicht mehr zu passen.

Bitte wissen lassen, wenn auf Deutsch zu wiederholen wäre!

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 5 von 21

Anbei das Video.

Eine ganz neue DWG (clean) mit 2 Linien.

 

<iframe width="640" height="590" src="https://screencast.autodesk.com/Embed/Timeline/bf47d8a2-54ef-4a04-a56a-a83e04977257?t=0m0s" frameborder="0" allowfullscreen webkitallowfullscreen></iframe>

Nachricht 6 von 21
cadffm
als Antwort auf: alexander.adamsZKU33


Ok, das scheint normal zu sein seit 2015 bei eingeschalteter Hardwarebeschleunigung

(Befehl: 3DKONFIG)

 

Ist gut für die Performance, blöd für den User.

 

Dein System arbeitet richtig, sollte es ein echtes Problem für dich sein ab und zu REGEN zu nutzen,

dann teste ob du ohne Hardwarebeschleunigung glücklicher wirst.

 

 

- Sebastian -
Nachricht 7 von 21
alexander.adamsZKU33
als Antwort auf: cadffm

OK.

Gleicher PC, 3 Versionen:

AutoCAD 2019: Problem tritt auf, egal ob Hardwarebeschleunigung eingeschaltet ist, oder nicht

AutoCAD 2018: Problem tritt auf, egal ob Hardwarebeschleunigung eingeschaltet ist, oder nicht

AutoCAD 2015: Problem tritt nicht auf, egal ob Hardwarebeschleunigung eingeschaltet ist, oder nicht

 

Etwas ärgerlich, denn eigentlich geht man ja davon aus, dass neuere Versionen den Workflow verbessern. Hier scheint, ist ein Schritt zurück entwickelt worden.

Nachricht 8 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

Bitte schau mal in 3DKONFIG in den Details der 2D-Anzeige

"Glatte Liniendarstellung" AKTIVIERT? Falls nicht, aktivieren!

 

 

- Sebastian -
Nachricht 9 von 21

Hi,

 

bitte Befehl _GRAPHICSCONFIG starten und den Modus auf "Grundlegender Modus" umschalten, passt es dann?

Bitte, wenn der Dialog schn geöffnet ist, bitte uns einen Screenshot davon zukommen lassen.

Auch ein Screenshot von Dialog des Befehls _ABOUT wäre toll.

 

Ich hoffe, dass unter LT der Dialog ähnlich aussieht wie hier:

20180808_103247.png

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 10 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

so sollte es aussehen (muß wohl beides aktiviert sein, zumindest bei mir):

 

Falls diese Einstellung nicht funktioniert wäre es merkwürdig.

Falls du diese Einstellung nicht vornehmen kannst, bitt einen Screenshot vom ganzen 3DKONFIG Dialog posten,

mit aufgeklappten Details, danke.

 

180808-2.JPG

- Sebastian -
Nachricht 11 von 21
cadffm
als Antwort auf: cadffm

STOOOP,

du hattest leider recht und ich hatte Test-Fehler.

 

Nein, ich bekomme es auch nicht gesteuert, egal ob mit oder ohne HA.

 

Wir halten fest:

2013 funktioniert (habe ich getestet)

2015 funktioniert (hast du getestet)

2016-2019 werden die Linienmuster nicht automatisch regeneriert wenn man nach klein, wieder groß zoomt.

 

Hat noch jemand andere Aussage/Korrekturen dazu zu machen?

- Sebastian -
Nachricht 12 von 21
alexander.adamsZKU33
als Antwort auf: cadffm

Ja CADffm,

genau so sieht`s aus und alle, mir jetzt und vorher bekannten Einstellungen ändern daran nichts.

(2016-2019 werden die Linienmuster nicht automatisch regeneriert wenn man nach klein, wieder groß zoomt.)

Gibt`s einen plausiblen Grund dafür?

Nachricht 13 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

Ich habe es gefunden!

 

VTENABLE auf 0 und je nach Wunsch auch andere Einstellungen, ich nehme an bei dir steht es auf 3 (de...

 

Das Erklärt unterschiedliches Verhalten wenn man in den verschiedenen Versionen entsprechend andere Einstellungen von VTENABLE verwendet.

 

 

Passt die Erkenntnis bei dir als "Lösung" bei dir ebenfalls?

 

 

 

 

- Sebastian -
Nachricht 14 von 21
alexander.adamsZKU33
als Antwort auf: cadffm

Leider nein,

 

zwar stand es auf 3; ein Runterstellen auf 0 brachte keine Lösung.

Nachricht 15 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

Jetzt bin ich enttäuscht, so happy fo find this.

Ich werde jetzt für dich noch Kombinationen der 3DKonfig Einstellungen bei VTENABLE=0 testen
Und wehe es lag darin begründet 😉
- Sebastian -
Nachricht 16 von 21
alexander.adamsZKU33
als Antwort auf: cadffm

Das Problem setzt sich in AutoCAD 2019 LT bei Schraffuren weiter fort.

 

Ein Wechsel von Schraffurtypen und/oder Skalierung selbiger wird nicht eins zu eins im Papierbereich dargestellt.

Ein ganz tiefes Reinzoomen in Verbindung mit REGEN und KSICH hilft dann hier.

 

Bei älteren Versionen auf dem gleichen PC bei gleichem Projekt und gleichen Einstellungen der Parameter tritt dieses Phänomen nicht auf...

 

Nachricht 17 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

Bei Schraffuren wird es schwieriger für Dritte dir zu helfen, bitte stelle ein sehr einfach Beispiel(.dwg) bereit,

vielen Dank.

 

 Und einen Screenshot von der "schlechten" Darstellung!

- Sebastian -
Nachricht 18 von 21
cadffm
als Antwort auf: alexander.adamsZKU33

...und @alexander.adamsZKU33

ich erwarte eine Überweisung oder ein Bier beim persönlichen Treffen wenn es jetzt nicht doch

mit der Variable  VTENABLE zu beeinflussen ist! Allerdings wie weiter oben bereits geschrieben

nur in Kombination mit der oben genannten Einstellung von 3DKonfig.

 

Also noch mal:

VTENABLE 0 (um es einfach mal für alle Situationen AUS zu schalten)

Dann die 3DKonfig wie hier gezeigt: Antwort Nachricht 10

 

Falls dein neuer Fall "Schraffur" nur auf den Linientyp des Schraffurmusters bezogen ist,

dann wäre es ja keine neue/andere Sache, dann geht es exakt um die gleiche Sache.

Damit du dies überhaupt meinen könntest würdest du HPLINETYPE eingeschaltet haben

und den Schraffuren (warum auch immer) einen Muster-Linientyp zugeordnet haben.

Also eigentlich weit her geholt, aber meine Glaskugel hat gute Augen (ab und an).

 

Sollte aber wirklich das Schraffurmuster betroffen sein, dann bitte die Beispiel DWG und Screenshot, danke.

 

 

 

 

- Sebastian -
Nachricht 19 von 21
alexander.adamsZKU33
als Antwort auf: cadffm

VTENABLE 0

3DKonfig:

- Hardwarebeschl. ein

- mittlerer Modus ( klassischer Modus nicht wählbar)

- 2x Haken

 

--> keine Besserung

Nachricht 20 von 21

UPDATE:

 

Unser Systemadmin hat mit dem Autodesk-Support gesprochen.

Antwort: bei neueren Versionen (ab 2016) ist dies wohl so gewollt, "um die PC-Performance nicht negativ zu beeinflussen."

 

Da hätte ich mir persönlich nun wirklich weniger einflussreiche und visuell weniger wahrnehmbare Parameteranpassungen gewünscht !! 

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen  

Autodesk Design & Make Report