Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Anpassen von Linientyp in AutoCAD 2018 nicht möglich

7 ANTWORTEN 7
GELÖST
Antworten
Nachricht 1 von 8
peter.klein5KL32
992 Aufrufe, 7 Antworten

Anpassen von Linientyp in AutoCAD 2018 nicht möglich

Hallo,

 

ich benutze Autodesk Autocad 2018.

Ich habe das Problem, dass sich der Linientyp manchmal nicht ändern lässt bzw falsch angezeigt wird.

 

Mein Vorgehen ist wie folgt:

 

1. Ich zeichne eine beliebige Linie (Polylinie, Spline).

2. Ich ändere den Linientyp von 'Continous' (Volllinie) zu 'LT-1' (gestrichelt).

     Nun wird die Linie korrekt dargestellt, nämlich gestrichelt.

3. Ich stutze die Linie, damit sie nicht durch ein anderes Objekt verläuft.

     Plötzlich ändert sich die Darstellung und die Linie wird nun als Vollinie angezeigt,

     obwohl immer noch Linientyp 'LT-1' (gestrichelt) ausgewählt ist.

 

Gibt es bereits eine Lösung für dieses Problem, oder hat jemand einen Tipp für mich?

 

Vielen Dank im Voraus

 

 

 

 

 

@peter.klein5KL32 Der Beitragstitel wurde von @michele.mk zur besseren Auffindbarkeit bearbeitet. Originaltitel: Anpassen von Linientyp nicht möglich

Tags (1)
7 ANTWORTEN 7
Nachricht 2 von 8
Volker.BRUNKE
als Antwort auf: peter.klein5KL32

Hallo @peter.klein5KL32 ,

 

könntest du bitte eine DWG wo das Problem auftritt hier hochladen.

Ich vermute das lediglich deine Grafikkarte denlinientyp nicht richtig dastellt.

Wenn du eine Beispieldatei hochlädst können wir uns das und deine Einstellungen anschauen.

 

Wenn das Problem gelöst ist bitte entsprechenden Post als Lösung markieren damit andere User davon profitieren können

 

Gruss

 

Volker Brunke
staatl. gepr. Bautechniker






AutoCAD2023 mit SOFiCAD2023 & REVIT 2023

Nachricht 3 von 8
peter.klein5KL32
als Antwort auf: Volker.BRUNKE

Ja klar, ich habe eine DWG in den Anhang gepackt.

 

Alle drei Linien haben identische Eigenschaften: Schwarz - Breite 0.7 mm - Linientyp LT-1

 

Die oberste Linie zeigt die Ausgangssituation. Die mittlere Linie zeigt wie die Linie plötzlich aussieht, nachdem ich in der Mitte ein kleines Stück herausgestutzt habe. Die unterste Linie zeigt wie es eigentlich aussehen sollte nach dem Stutzen.

 

Meine Frage ist: Wieso sehen die mittlere Linie und die untere Linie nicht gleich aus?

Bzw was muss ich tun, damit die mittlere Linie so aussieht wie die untere?

 

Vielen Dank für die Hilfe.

Nachricht 4 von 8
Volker.BRUNKE
als Antwort auf: peter.klein5KL32

Hallo,

 

Zuerst einmal zur Farbe der Linien, für schwarze Linie nutze bitte die Farbe 7,

Dann siehst du diese auch Modellbereich wenn der Hintergrund auf Schwarz steht,

weil die Linien nur damit dann weiss dargestellt werden. 

 

Zum anderen ist es ist so wie ich gedacht habe,
Stelle bitte die Variabele PSLTSCALE auf 1 und achte auf den Maßstab in Modellbereich,

wie auch bei den Ansichtsfenstern im Papierbereich.

 

Wenn das Problem gelöst ist bitte entsprechenden Post als Lösung markieren damit andere User davon profitieren können

 

Gruss

Volker Brunke
staatl. gepr. Bautechniker






AutoCAD2023 mit SOFiCAD2023 & REVIT 2023

Nachricht 5 von 8
udo.huebner
als Antwort auf: peter.klein5KL32

Der Linientyp  ist wie folgt definiert: 1 Einheit Strich, dann 1 Einheit Lücke, dann wieder Strich

*LINE_LT_1,
A,1,-1

Damit am Ende immer ein sichtbares Liniensegment zu sehen ist, wird das Segment am Anfang und am Ende jeweils gestaucht oder gedehnt.

Das Problem hier: Die Ausgangspolylinie ist als Beispiel einfach zu kurz (nur 4 Einheiten). Ansonsten funktioniert alles wie dokumentiert.

Da der Linientypfaktor 1 ist und die Ausgangslänge der Polylinie nur 4 Einheiten lang ist, werden eben nur 1 sichtbares Segment der Länge 1 dann noch 2 Lücken der Länge 1 und an den Enden 2 sichtbare gestauchte Enden mit der Länge 0.5 gezeigt. Verkürzen (Bruch) der Polylinie, verändert die Darstellung weiter in eine Richtung die nicht erwartet wird, Die Strichelung fehlt aufgrund der Länge von weniger als 2 Einheiten zwangsläufig komplett.

Wird LTFAKTOR auf 0.2 gestellt, wird die Strichelung besser bzw. wie erwartet angezeigt.

 

 

 

Nachricht 6 von 8

Vielen Dank für Ihre Hilfe @Volker.BRUNKE @udo.huebner 

 

Den LTFAKTOR auf 0.2 zu stellen hat tatsächlich zur gewünschten Lösung geführt.

Anschließend wurde die gestrichelte Linie im Modell-Bereich (1:1) richtig dargestellt, im Layout-Bereich (4:1) waren die Abstände zwischen den Stichen jetzt allerdings ein wenig klein. Nach ein bisschen rumprobieren habe ich festgestellt, dass der LTFAKTOR auf 0.4 eine gute Einstellung für mich ist.

 

Abschließend habe ich deshalb noch eine Frage:

Ist es möglich den LTFAKTOR für den Modellbereich und für den Layout-Bereich getrennt voneinander einzustellen?

Nachricht 7 von 8
Udo_Huebner2
als Antwort auf: peter.klein5KL32


@peter.klein5KL32  schrieb:

...

Anschließend wurde die gestrichelte Linie im Modell-Bereich (1:1) richtig dargestellt, im Layout-Bereich (4:1) waren die Abstände zwischen den Stichen jetzt allerdings ein wenig klein.

Dafür setzt man im aktivierten Ansichtsfenster PSLTSCALE auf 1 (Paper Space LineType SCALE) . Dadurch wird der LTFAKTOR nochmals mit dem Ansichtsfenstermaßstab multipliziert. Anschließend muss noch REGEN aufgerufen werden. Ein Linientyp sieht dann in allen Ansichtsfenstern gleich gestrichelt aus.

 

Meine Empfehlung is LTSCALE 1, MSLTSCALE 1, PSLTCSALE 1 zu setzen. Die eigenen Linientypen sollten dann entsprechend ihrer gewünschten Ausgabestrichelung definiert werden. Dann muss man nicht in jeder Zeichnung wieder den LTFAKTOR (LTSCALE) individuell anpassen.

Nachricht 8 von 8
cadffm
als Antwort auf: peter.klein5KL32

Nein, entweder gleich(PSLTSCALE=0) oder nach der Ansichtsfensterskalierung skalieren lassen.

Aber das ist der perfekte Moment über den LTFAKTOR nachzudenken,

denn auch wenn 0.2 für diesen Linientyp in der Längeneinheit passt,

so muß wirkt es ja auf die Darstellung aller Linientypen.

Angenommen man nutzt noch 10 ISO- Linientypen und diese passen bei LTF 12 besser,

dann würde ich lieber 12 statt 0.2 nehmen und 

 

*Achtung, ab hier die Kernaussage*

 

den OBJEKT- Linientypskalierfaktor anpassen.

 

Also trennen nach Model und Layout geht nicht,

aber man hat ja in jedem Fall den Objekt-Linientypskalierfaktor zum Einstellen.

 

 

 

- Sebastian -

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen