Community
AutoCAD Produktfamilie - Deutsch
Das Forum für alle Fragen zu AutoCAD, LT, Architecture, Electrical, Map 3D, Mechanical, MEP, Plant 3D, Raster Design, Web App, sowie Autodesk Civil 3D und Advance Steel.
abbrechen
Suchergebnisse werden angezeigt für 
Anzeigen  nur  | Stattdessen suchen nach 
Meintest du: 

Alle auswählen in AutoCAD funktioniert nicht mehr.

15 ANTWORTEN 15
GELÖST
Antworten
Nachricht 1 von 16
Uhlhorn
758 Aufrufe, 15 Antworten

Alle auswählen in AutoCAD funktioniert nicht mehr.

Moin,

seit einiger Zeit funktioniert „alle wählen“ (Strg+A) nicht mehr und ich weiß nicht warum.  Ich bekomme nachstehende Fehlermeldung, kann damit aber nichts anfangen:

Fehler: no function definition: C:AI_SELALL
Letzte Funktion wird rückgängig gemacht!
Aufrufen von (command) aus *Fehler* nicht möglich, ohne vorheriges Aufrufen von (*push-error-using-command*).
Konvertieren von (command)-Aufrufen in (command-s) wird empfohlen.

Weiß jemand, was da vor sich geht?

Beschriftungen (1)
15 ANTWORTEN 15
Nachricht 2 von 16
cadffm
als Antwort auf: Uhlhorn

Hi,

 

bin nicht 100%ig sicher (gibt mehrer mögliche Auslöser), aber ich tippe darauf 

dir fehlt im aktuellen Profil der Pfad

 

C:\Program Files\Autodesk\AutoCAD 20nn\Support\de-de

- Sebastian -
Nachricht 3 von 16
Alfred.NESWADBA
als Antwort auf: Uhlhorn

Hi,

 

bin auch nicht sicher, aber dieser Audruck:

>> Konvertieren von (command)-Aufrufen in (command-s) wird empfohlen

könnte darauf hindeuten, dass andere(s) LISP geladen sein könnte, das etwas verbogen haben könnte.


Vielleicht auch relevant (gebe zu, bin zu faul zum Nachsehen in Deinen älteren Posts) ... hattest Du nicht AutoCAD for Mac? Wenn diese Erinnerung in mir stimmt, dann bin ich leider auch grundlegend raus, da sind manche Dinge anders und ich kann es nicht reproduzieren.

 

- alfred -

------------------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at ... blog.hollaus.at ... CDay 2024
------------------------------------------------------------------------------------
(not an Autodesk consultant)
Nachricht 4 von 16
Uhlhorn
als Antwort auf: Alfred.NESWADBA


@Alfred.NESWADBA  schrieb:

könnte darauf hindeuten, dass andere(s) LISP geladen sein könnte, das etwas verbogen haben könnte.

 

hattest Du nicht AutoCAD for Mac?


Mac-Version habe ich auch, aber ich arbeite nicht damit, weil ich eine Zusatzsoftware verwenden muss, die nur unter Windows läuft. Außerdem ist AutoCAD for Mac grottig umgesetzt, nahezu unbrauchbar.

 

Ich habe das LISP-Programm TLEN geladen. Und das Problem ist möglicherweise entstanden, als ich versucht habe das Programm automatisch bei Programmstart laden zu lassen. Möglicherweise habe ich im APPLOAD etwas verstellt.

Nachricht 5 von 16
Uhlhorn
als Antwort auf: Alfred.NESWADBA

@Alfred.NESWADBA Dein Hinweis zu LISP hat mich (möglicherweise) auf die Lösung gebracht: Mir fehlte in der Startgruppe der Eintrag für AcApp.arx. Den habe ich wieder hinzugefügt und nun funktioniert es wieder. 🙂

 

Danke.

 

(Vorbehaltlich, dass das das ganze Problem war, kann ich diesen Fall guten Gewissens als gelöst markieren.) 😉

 

Bildschirmfoto 2021-09-01 um 22.27.46.png

Nachricht 6 von 16
Uhlhorn
als Antwort auf: cadffm

@cadffm Es war der versehentlich gelöschte Eintrag in der Startgruppe. Trotzdem Danke. 🙂

Nachricht 7 von 16
cadffm
als Antwort auf: Uhlhorn

Die Idee von Alfred wegen der (Teil-)Meldung ist zwar nicht falsch, aber Adesk hat da selbst schon veralteten Code

in den Expresstools drin, der Code ist aber für FEHLER-Fälle und nicht relevant wir suche ja den Fehler,

nicht das Problem was danach entsteht.

 

Leider bist du auf meine Antwort nicht eingegangen!?

 

Mein Tip könnte in direktem Zusammenhang mit deiner Zusatzsoftware sein,

mit TLEN-laden (oder auch automatisch laden) eher nicht.

 

Also schau nach ob der Pfad in deinem Profil vorhanden ist!

OPTIONEN->DATEIEN->siehe Anhang

SuppPath.jpg

 

Eigentlich sollten genau diese gelistet sein, als erstes, weitere evtl. unten drunter.

 

Dann sollte auch

Befehl: (findfile "acad2020doc.lsp")

zeigen das diese Datei in dem *De-de Ordner gefunden wird, ist das so?

 

Vielleicht fehlt der Pfad

Vielleicht steht ein Pfad oben drüber in dem eine andere acad2020doc.lsp gefunden wird

oder die Zusatzsoftware hat die die Verändert (unwahrscheinlich).

 

 

 

 

- Sebastian -
Nachricht 8 von 16
cadffm
als Antwort auf: Uhlhorn


@Uhlhorn  schrieb:

@cadffm Es war der versehentlich gelöschte Eintrag in der Startgruppe. Trotzdem Danke. 🙂


Nein, die Startgruppe ist ausschließlich für benutzerdefinierte Dinge,

die AcApp.arx sollte automatisch geladen werden.

 

Wenn das nicht passiert ist das Problem an anderer Stelle, wenn das Problem gelöst ist, dann lädt die Datei auch wieder

automatisch.

- Sebastian -
Nachricht 9 von 16
cadffm
als Antwort auf: Uhlhorn

[Nur zur Erklärung, bei meiner Antwort #7 hatte ich deine 2 Antworten noch nicht gelesen]

 

- Sebastian -
Nachricht 10 von 16
Uhlhorn
als Antwort auf: Uhlhorn

Ich hatte wohl versehentlich den Eintrag in der Startgruppe gelöscht, als ich versucht habe TLEN automatisch zu laden. Wenn ich das noch korrekt in Erinnerung habe, hatte ich TLEN der Startgruppe hinzugefügt, weil ich dachte, dass man das so mit dem Programmstart automatisch laden könnte. Da das nicht funktionierte, habe ich den Eintrag wieder entfernt.

 

Spekulation:

Durch das Hinzufügen von TLEN zur Startgruppe wurde möglicherweise der ursprüngliche Eintrag ersetzt. Und durch das Entfernen hatte ich nun gar keinen Eintrag mehr drin.

 

Jedenfalls funktioniert nun ctrl-A wieder. 😉

Nachricht 11 von 16
cadffm
als Antwort auf: Uhlhorn

>>Ich hatte wohl versehentlich den Eintrag in der Startgruppe gelöscht,

Wie gesagt, der Eintrag gehört dort nicht hin! Du hast an anderer Stelle ein Problem das es nicht so wie gewöhnlich geladen wird

und sehr wahrscheinlich sind da auch noch andere Dinge krumm welche du noch nicht bemerkt hast.

 

>>"hatte ich TLEN der Startgruppe hinzugefügt, weil ich dachte, dass man das so mit dem Programmstart automatisch laden könnte.

Genau so funktioniert das, nur dass es nicht "bei Programmstart" sondern "mit jedem Dokument" geladen wird.

 

>>"Da das nicht funktionierte, habe ich den Eintrag wieder entfernt."

Weil du anscheinend schon an anderer Stelle ein Problem hast, denn gegen das laden über die Startgruppe spricht nichts.

(ok, kenne weder den Code noch die Datei DEINER version, aber mein erster Treffer zeigte ein problemloses Lisp)

 

 

>>"Jedenfalls funktioniert nun ctrl-A wieder."

Wenn dir das reicht - bitte.

 

 

aber eigentlich müsste man mal etwas fiesen Trouble wünschen (mache ich aber natürlich nicht)

damit der Wunsch nach einem ordentlichen System /berechenbar/ etwas höher im Kurs steht.

 

So eine "die Datei in die Startgruppe packen" kann man mal mittags machen wenn es vorwärts gehen muss,

aber nicht als Dauerlösung.

 

Neues Profil - Testweise

[Win]+[R]

"C:\Program Files\Autodesk\AutoCAD 2021\acad.exe" /product ACAD /p "Testprofil" /language "de-DE"

 

Oder dann auch Einstellungen exportieren und Zurücksetzen

 

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\AutoCAD 2021 - Deutsch (German)\Einstellungen auf Vorgabe zurücksetzen

(zunächst wird man nach Exportieren gefragt, was man als Sicherung immer machen sollte)

 

Zuletzt wäre da noch in Windows: Programm Reparaturinstallation

 

 

- Sebastian -
Nachricht 12 von 16
Uhlhorn
als Antwort auf: Uhlhorn

Mit vielem kann ich so adhoc nichts anfangen. Ich kenne Windows nur vom wegschauen und vieles bei Windows ist mir sehr suspekt (z.B. die Registry). Normalerweise arbeite ich unter UNIX-änlichen Systemen (macOS, Linux usw.).

 

Wenn ich eine Reparaturinstallation mache, muss ich dann auch die Zusatzsoftware (CATS) neu installieren? Und muss ich mir dann wieder die Oberfläche so einstellen wie sie jetzt ist?

 

Ich habe an AutoCAD eigentlich nichts verändert außer die Cursorgröße, die Farben und leicht die Anordnung der Fenster und den oben beschriebenen Vorgang. Daher weiß ich nicht, woher das Problem gekommen sein soll.

Nachricht 13 von 16
cadffm
als Antwort auf: Uhlhorn

Hi,

 

das neue Profil würde einiges ändern, aber das Vorherige ist nach wie vor da.

 

Zurücksetzen, hier fragt er zunächst nach dem Export(als Sicherung, also machen).

 

Reparaturinstallation

Ich würde sagen: Nix wird geändert aus Nutzer Sicht

- Sebastian -
Nachricht 14 von 16
Uhlhorn
als Antwort auf: cadffm


das neue Profil würde einiges ändern, … Nix wird geändert aus Nutzer Sicht


Was denn nun?!?

 

Ich soll irgendetwas zurücksetzen? Wo finde ich das? Und wie mache ich eine Reparaturinstallation?

Nachricht 15 von 16
cadffm
als Antwort auf: Uhlhorn

Da du bereits glücklich warst, belassen wir es dabei.

Ich wünsche mir einen schönen Urlaub.

 

AutoCAD zurücksetzen

AutoCAD mit neuem Profil starten

AutoCAD Reparaturinstallation

- Sebastian -
Nachricht 16 von 16
Uhlhorn
als Antwort auf: cadffm

Wie ich gerade erfahren habe, ist CATS jetzt auch für AutoCAD 2022 draußen. Damit wird AutoCAD 2021 ohnehin obsolet.

 

Trotzdem danke. Ich wünsche Dir auch einen schönen Urlaub. 😉

Sie finden nicht, was Sie suchen? Fragen Sie die Community oder teilen Sie Ihr Wissen mit anderen.

In Foren veröffentlichen