AutoCAD Plant 3D Forum
Welcome to Autodesk’s AutoCAD Plant 3D Forums. Share your knowledge, ask questions, and explore popular AutoCAD Plant 3D topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ports Incorrectly Positioned/Oriented on Custom Valve

3 REPLIES 3
SOLVED
Reply
Message 1 of 4
_Jeff_Roy_
140 Views, 3 Replies

Ports Incorrectly Positioned/Oriented on Custom Valve

Hi, 

 

I've created a set of custom valves at various sizes using imported STPs from a vendor and using plantpartconvert to add ports at the FOF on each. All of the valves are working correctly except for two which, inexplicably, are ignoring the location and orientation of the ports I added and are instead putting them at seemingly arbitrary points rotated 90 degrees from the orientation I used. .

 

So far, I've attempted the following troubleshooting to try and resolve this: 

- Delete any instances of these valves from my model

- Purge model

- Remove spec from project

- Remove part from spec

- Delete problematic sizes from part in catalog

- Delete blocks from original source drawing -> re-import STPs and do plantpartconvert again from scratch to ensure ports are placed / oriented correctly

- Re-add sizes in catalog part and map to new block

- Re-add valve part to spec

- Re-add spec to project

- Switch back and forth between specs within project to refresh parts

 

No matter how many times I go through the process of removing these parts / blocks everywhere I can think of, it continues to situate the ports incorrectly.

 

This is how all most sizes of this part are placing (correctly) in models using the exact same approach to creating them in my catalog:

 

_Jeff_Roy__0-1701108409886.png

 

And this is how the two largest sizes are behaving:

 

_Jeff_Roy__1-1701108452161.png

 

Any advice on how to resolve this would be great appreciated.

3 REPLIES 3
Message 2 of 4

@_Jeff_Roy_ 

 

I have run into this problem before.  Try this to resolve:

 

-Create a new DWG file, name "VALVE IMPORTER" or similar.  This DWG's sole purpose is to import .STP files (or .IGES etc).  Ensure view is set to TOP and UCS set to WORLD prior to import.  Never save this file.  If you do, remove from project and create a new one.

-Import model

-Use EXPLODE and BURST commands to reduce .STP file down 3D solids.

-Ensure 3D solids to model origin.  Use the center point of the valve body from Face of Flange to Face of Flange

-Confirm valve stem/operator in the vertical

-Confirm UCS set to WORLD

-Block your 3D solids.  Name whatever you want.

-Create new DWG file for the valve

-Confirm UCS set to WORLD in new valve DWG file

-Copy with base point 0,0,0 from Importer DWG to Valve DWG

-In the new valve DWG file perform PLANTPARTCONVERT

-Save and create valve in catalog as usual

 

The block based components and UCS settings are usually the source of headaches.  The use of an importer DWG file has also resolved issues for me and is now my SOP.

Message 3 of 4

Thanks very much for the detailed suggestion, I'll give this a try.

 

**Update: This method worked. Must have been something going on with the original source drawing I was creating the blocks in that was effecting these two valves but not the other ones. I am now able to place both of these new sizes without issue. Thanks very much for your help!

Message 4 of 4

You're welcome Jeff

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report