Community
AutoCAD Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Zoom > All doesn't work consistently

11 REPLIES 11
Reply
Message 1 of 12
j-dubya-merchant
755 Views, 11 Replies

Zoom > All doesn't work consistently

I find Zoom > Extents to be a very useful command -- it zooms to the edges of the visible geometry, both in Model Space and in Paper Space.  This is fine most of the time, but in some cases, depending on what Title Block I'm using, I want it to zoom to the edges of the Paper Border (which is a little bit further out than the geometry) in Paper Space, so I tried Zoom > All, and it does exactly what I want.  So I set a shortcut for Zoom > All.

 

However, I've noticed something weird with Zoom > All.  Sometimes, depending on the drawing file, Zoom > All zooms only to the visible geometry.  Excellent.  Exactly what I want.  But other times, it zooms out far enough to also include the Origin (when there's nothing drawn at or around the origin).

 

Or at least, that's what I thought.  Turns out, it's actually zooming out to include not the Origin, but the Drawing Limits, which is an obsolete feature.  I tried changing the Limits in one of the drawings in which I was having this problem, and running Zoom > All confirmed that this is what's happening.

 

LIMCHECK was already set to 0, so I tried setting it to 1 and then back to 0.  Zoom > All still includes Limits.

I deleted everything and drew a new circle.  Zoom > All still includes Limits.

I copied the circle to a new drawing.  In the new drawing, Zoom > All only zooms to visible geometry.

Both the new drawing and the original have the same Limits.  Both drawings have the same Units settings.

 

I've attached both the original drawing and the new drawing.  

 

Anyone have any idea why this happens in some drawings, but not all of them?  I've thought maybe it's the version of AutoCAD that was used to create the drawing, or a Drawing-specific System Variable, but I'm not sure.

 

I've I'd read about people having this type of issue with Zoom > Extents, but I'm trying to figure out why this is happening (inconsistently) with Zoom > All.

 

Thanks.

Tags (2)
Labels (2)
11 REPLIES 11
Message 2 of 12
pendean
in reply to: j-dubya-merchant

while you wait... Interesting finds in your ORIG file by the way (not found in your NEW file)

pendean_1-1709226669028.png

It chances your ZOOM>All too (still not a match to the NEW).

 

EDIT: read this on Extents Vs ALL

https://blog.gstarcad.net/whats-the-difference-between-all-and-extents-in-zoom-command-2/

 

Message 3 of 12
j-dubya-merchant
in reply to: pendean

while you wait... Interesting finds in your ORIG file by the way (not found in your NEW file)

pendean_1-1709226669028.png

It chances your ZOOM>All too (still not a match to the NEW).


 

Interesting!  I'm curious how you found this data.  Did you simply run the PURGE or -PURGE command?  Or something different?

 

EDIT: read this on Extents Vs ALL

https://blog.gstarcad.net/whats-the-difference-between-all-and-extents-in-zoom-command-2/


 

This article tracks with everything I've read thus far.  The "old" drawing in my original post works like the article describes.

 

What's weird to me is that across different drawings, Zoom > All only sometimes works like this.  Other times, like in the "new" drawing I attached in the original post, Zoom > All completely ignores the Limits.

 

It seems like Zoom > All is meant to account for the Limits, but honestly, I prefer when it doesn't.  If there's some way to actually control this behavior, that'd be fantastic.

 

But for now... I am baffled.

Message 4 of 12
pendean
in reply to: j-dubya-merchant


@j-dubya-merchant wrote:

while you wait... Interesting finds in your ORIG file by the way (not found in your NEW file)

pendean_1-1709226669028.png

It chances your ZOOM>All too (still not a match to the NEW).


 

Interesting!  I'm curious how you found this data....


This freebie https://apps.autodesk.com/ACD/en/Detail/Index?id=3773138176974634673&appLang=en&os=Win32_64

 


@j-dubya-merchant wrote:

...It seems like Zoom > All is meant to account for the Limits, but honestly, I prefer when it doesn't.  If there's some way to actually control this behavior, that'd be fantastic.


A quick poll around the office here and no one ever uses Zoom All apparently (I honestly can't recall the last time I deliberately did either). Seems unpopular for the same reasons.

It's been since the early 1990s that I even gave LIMITS or LIMCHECK commands a look either.

 

What problem to solve (or easy solution) are you trying to get to in general that you believe Zoom All is the fix if I may ask?

Message 5 of 12
cadffm
in reply to: j-dubya-merchant

ootb

Command: -Purge

RegApps

*

no

Sebastian

EESignature

Message 6 of 12
j-dubya-merchant
in reply to: pendean

 



This freebie https://apps.autodesk.com/ACD/en/Detail/Index?id=3773138176974634673&appLang=en&os=Win32_64



 

Fancy.  I may end up adding that to my tools.

 


A quick poll around the office here and no one ever uses Zoom All apparently (I honestly can't recall the last time I deliberately did either). Seems unpopular for the same reasons.

It's been since the early 1990s that I even gave LIMITS or LIMCHECK commands a look either.

 

What problem to solve (or easy solution) are you trying to get to in general that you believe Zoom All is the fix if I may ask?


 

Honestly, it's silly.  There is only one case that I've found in which Zoom > All is more useful to me than Zoom > Extents.

 

A lot of our Title Blocks have a Defpoints rectangle outside of the actual Title Block frame to set the plot boundaries (and, intentionally or not, the Zoom extents), and in the plot settings, the Plot area ("What to plot:") is set to "Extents".  With these Title Blocks, Zoom > Extents works fine.

 

However, with other Title Blocks, there is no outer Defpoints rectangle; for these, the plot boundaries are instead determined by setting specific numerical values within the plot settings.  So when I run Zoom > Extents, it zooms right to the edges of the Title Block border, even though the plot boundaries (the Paper Border in Paper Space) are further out than the actual Title Block border.  Zoom > All actually zooms to the plot boundaries, not just the visible Title Block border.

 

It's truly petty.

 

But at this point, I'm more so curious about why this anomalous behavior even occurs in the first place.

Message 7 of 12
j-dubya-merchant
in reply to: cadffm


@cadffm wrote:

ootb

Command: -Purge

RegApps

*

no


I tried this in both the "old" and the "new" drawings that I attached in the original post.  The Zoom > All behavior of both drawings was unchanged.

 

The "old" drawing still accounts for Limits.

 

The "new" drawing still ignores Limits.

 

I'm not sure if this is a Drawing-specific System Variable, some other backend variable that end users can't easily access, or just a bug.

Message 8 of 12
cadffm
in reply to: j-dubya-merchant

>>"The Zoom > All behavior "

This was just about how to purge registered unused Applications.

Not related to the topic.

 

About your issue:  I am away of my Acad, can't help.

But I guess you have files with a strange camera position.

 

 

 

Sebastian

EESignature

Message 9 of 12


@j-dubya-merchant wrote:

.... the plot boundaries are instead determined by setting specific numerical values within the plot settings. ....


And in that situation, those become the Limits in that Layout.  So you can Zoom to that area with:

 

(defun C:ZL (); Zoom Limits
  (setvar 'cmdecho 0)
  (if (> (getvar 'cmdactive) 0); [not transparent if not needed]
    (command "_.'zoom" "_non" (getvar 'limmin) "_non" (getvar 'limmax)); then
    (command "_.zoom" "_non" (getvar 'limmin) "_non" (getvar 'limmax)); else
  ); if
  (setvar 'cmdecho 1)
  (princ)
)

 

and it won't matter that the Extents are a smaller area than that, and you can skip your fake outline made for that purpose.

 

This is the kind of situation in which Limits are very useful for other-than-LIMCHECK purposes, and whether or not that is turned on.  I use them in the same way in most drawings, so I can [for example] park temporary stuff, optional layouts, notes to myself, etc. outside the Limits I set, but I can Zoom to the "real" area of meaningful drawing, ignoring the outside stuff that Zoom Extents cannot ignore.

Kent Cooper, AIA
Message 10 of 12


@Kent1Cooper wrote:

@j-dubya-merchant wrote:

.... the plot boundaries are instead determined by setting specific numerical values within the plot settings. ....


And in that situation, those become the Limits in that Layout.  So you can Zoom to that area with:

 

 

(defun C:ZL (); Zoom Limits
  (setvar 'cmdecho 0)
  (if (> (getvar 'cmdactive) 0); [not transparent if not needed]
    (command "_.'zoom" "_non" (getvar 'limmin) "_non" (getvar 'limmax)); then
    (command "_.zoom" "_non" (getvar 'limmin) "_non" (getvar 'limmax)); else
  ); if
  (setvar 'cmdecho 1)
  (princ)
)

 

 

and it won't matter that the Extents are a smaller area than that, and you can skip your fake outline made for that purpose.

 

This is the kind of situation in which Limits are very useful for other-than-LIMCHECK purposes, and whether or not that is turned on.  I use them in the same way in most drawings, so I can [for example] park temporary stuff, optional layouts, notes to myself, etc. outside the Limits I set, but I can Zoom to the "real" area of meaningful drawing, ignoring the outside stuff that Zoom Extents cannot ignore.

 

Interesting.  All very useful information!

 

I hadn't realized that the plot boundaries become the Limits in Paper Space.  And that seems like a pretty handy way to make use of Limits in model space.

Message 11 of 12
CGBenner
in reply to: j-dubya-merchant

@j-dubya-merchant 

Did the answer provided by @Kent1Cooper solve this for you?


Chris Benner
Industry Community Manager – Design & Manufacturing


If a response answers your question, please use  ACCEPT SOLUTION  to assist other users later.


Also be generous with Likes!  Thank you and enjoy!


Become an Autodesk Fusion Insider
Inventor/Beta Feedback Project
Message 12 of 12
Kent1Cooper
in reply to: CGBenner


@CGBenner wrote:

....
Did the answer provided by @Kent1Cooper solve this for you?


[I imagine not, at least not completely.  I tried in their sample drawings, and had the same issue in the "wrong" one, with Zoom All not "reaching out" to include the drawing limits, but being the equivalent of Zoom Extents.  I don't have any ideas about what could cause that.]

Kent Cooper, AIA

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report