Community
AutoCAD Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Xline glitching when zooming

10 REPLIES 10
Reply
Message 1 of 11
eva_svarovska
600 Views, 10 Replies

Xline glitching when zooming

Hello,

 

I'm experiencing glitches when using XLINES and zooming in. Xlines (usually not vertical or horizontal) starts disappearing and their intersection seems to be moved out of correct point when I zoom in to get finer selection. The issue is also shown in the attached screencast.

 

Tested in older version of AutoCAD 2021 and latest AutoCAD 2022, 2023 and 2024 on three different computers running Windows 10 or 11.

 

Tried changing GRAPHICSCONFIG as described here: https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/Lines-disappear-so... but it also didn't help.

Tags (3)
Labels (3)
10 REPLIES 10
Message 2 of 11
paullimapa
in reply to: eva_svarovska

For AutoCAD 2022, 2023 and 2024 try setting GFXDX12 to 0


Paul Li
IT Specialist
@The Office
Apps & Publications | Video Demos
Message 3 of 11
eva_svarovska
in reply to: paullimapa

Hi,

 

thanks for the answer! Setting GFXDX12 to 0 and restarting AutoCAD didn't help.

 

If you think it can be related to DirectX, I also want to mention that all three laptops that I have tried have discrete Nvidia graphics, GeForce RTX 3070 (laptop), GeForce RTX 2060 (laptop) and the last one has a bit older one non-Geforce, I don't have access to it right now to look at the exact type. Do you think it can be related? And I also tried to update the driver of the graphics card.

Thanks for your help.

Message 4 of 11

@eva_svarovska ,

 

This is the effect of zooming in that close, just don't.

If you turn on your coordinates, you will notice it only moves the 4th decimal or more.

 

You will also notice the UCS Icon change as you zoom in:

  

ValentinWSP_2-1702289288102.png   ValentinWSP_1-1702289267338.png ValentinWSP_0-1702289247782.png     

 

 

 

 

 



Please select the "Accept as Solution" button if my post solves your issue or answers your question.


Emilio Valentin
Message 5 of 11
pendean
in reply to: eva_svarovska

Why is your program window not fully expanded?

pendean_0-1702304966944.png

 


What small monitor or oversized text size or low res display setting are you running your AutoCAD in please? And why?

pendean_1-1702305010319.png

 

 

In all of your year-versions of AutoCAD you can also start GRAPHICSCONFIG command and change the 2D Display Settings pulldown from "advanced mode" to one of the other choices.

If all else fails, then turn off Hardware Acceleration as a last resort to see if that helps.

 

You also need to ensure you have the 2022.1.3 / 2023.1.4 / 2024.1 Updates installed too.

Message 6 of 11
TheCADnoob
in reply to: eva_svarovska

Laptops sometimes run on internal as opposed to high end graphics cards for different situations. 

 

I would see if you can tell which graphics card its using

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/How-to-force-your-...

 

https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/AutoCAD-uses-the-w...

 

 

 

CADnoob

EESignature

Message 7 of 11

@pendean non-maximized window was just for purpose of recording the video, I did this as the easiest option how to record video with reasonably big labels, so it's easily readable. Normally, I'm using standard maximized window either on FullHD or 2.5K monitor, the issue is present there as well. 

 

I did the following tests in AutoCAD 2023.1.4. I tried changing the settings in GRAPHICSCONFIG and the issue is present in all modes, even in software mode with disabled Hardware Acceleration and disabled Smooth line display. However, it seemed to me that disappearing lines seem to be present only in extreme zooming with disabled Hardware Acceleration (but it could have been only subjective perception, will see when working more in it).

 

@TheCADnoob Checked the links and set AutoCAD to always use external graphics card. It's also showed in GRAPHICSCONFIG, so I think AutoCAD is really using the powerful one.

Message 8 of 11
pendean
in reply to: eva_svarovska

@eva_svarovska Thanks for the extra details: you've reached the point where you need to engage with Autodesk Support, we're not seeing anything remotely like you are in our offices with our users in Windows10Pro/Win11.

 

Here is how to open a support case with Autodesk if you are on subscription to seek out Autodesk Support's help:
https://www.autodesk.com/support/technical/article/caas/sfdcarticles/sfdcarticles/How-to-find-my-sup...

Message 9 of 11
TheCADnoob
in reply to: eva_svarovska

I noticed that your X and Y were pretty high. Normally I would think they would need to be much higher to cause an issue but i am curious if you did a line that was 10 units long instead of 3000 units long does it make a difference in the way Xline behaves?

 

I cant duplicate the line disappearing but I can duplicate the geometry being off a little. This (in my case) can be fixed with a regen. does REGEN make your lines reappear?

CADnoob Regen to fix line.gif

 

TheCADnoob_0-1702425580028.png

 

 

CADnoob

EESignature

Message 10 of 11
eva_svarovska
in reply to: TheCADnoob

Hi, thanks for your answer, regen command works - the X-line appears, but it's quite time consuming or even not possible (while you have other command running) to do the regen again and again

Message 11 of 11
pendean
in reply to: eva_svarovska


@eva_svarovska wrote:

Hi, thanks for your answer, regen command works - the X-line appears, but it's quite time consuming or even not possible (while you have other command running) to do the regen again and again


Perhaps you need to fix your setup, tame AutoCAD a bit:

 

1) Assuming you are running a modern version.... have you installed the 2022.1.3 / 2023.1.4 / 2024.1 Update yet? ABOUT command will confirm what you have installed. If not, get it from your Autodesk Account Page here https://manage.autodesk.com/cep/#products-services/updates
Restart your PC afterwards.

2) If that did not help... Set GFXDX12 variable to 0 (that's a zero) then restart AutoCAD2022-2023-2024.

3) Also consider turning off LINESMOOTHING and LINEFADING variables.

 

4) If still no relief then start GRAPHICSCONFIG command and change the 2D Display Settings pulldown from "advanced mode" to one of the other choices.

5) If all else fails, then turn off Hardware Acceleration as a last resort and see if that helps.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report