AutoCAD Forum
Welcome to Autodesk’s AutoCAD Forums. Share your knowledge, ask questions, and explore popular AutoCAD topics.

AutoCAD Forum

Post 1 of 10

Problems with 3D orbit - acvmtools.arx

10353 Views, 9 Replies
04-26-2011 02:43 AM



A very frustrated first posting.


I have the following hardware:-


Dell Studio 1558 Laptop

Intel i5 CPU M450 @ 2.4 Ghz

4 Gb RAM

64 bit opperating system

ATI Radeon HD5470 Display Adaptor


I recently udated from AutoCAD 2011 (as part of Design suite premium) to 2012.


2011 was superb and opperated without issue. 2012 seemed to opperate fine at installation but has subsequently developed a fault relative to its 3D fuctionallity:-


It won't mouse wheel click **** rotate

It doesn't have the view cube

it wont mouse pan in perspective view

none of the orbit fuctions work


Bizarely the similarly previously available functions within 2011 have also disapeared.


At loading I get a failure to load acvmtools.arx error and any attempt to invoke anoy of the above noted 3D funcyionality throws up an error window:-


Exception in c:\program files\autodesk\autocad 2012 -english\acvmtools.arx A.....


!  Unhandled Exception C0000005 (Access Violation Reading 0x0010) at address 6903D268h


This obviously means something to someone.


I have tried to reinstall both 2011 and 2012 and the error remains.


I have check and rechecked my dispaly driver and this is (apparently) up to date.


This has now been goin on for some days and subscription help seems unable to arrive at a solution so far.  I am a very frustrated bunny.

Post 2 of 10

Re: Problems with 3D orbit - acvmtools.arx

04-26-2011 07:35 AM in reply to: john.s

Smiley Very Happy Yey I fixed it.


Saddly without the assistance of subscription centre.


The problem seems to revolved around Mudbox not working on my original video driver and recommending the loading of updated driver (even though Windows considered my ATI driver to be up to date). Both AutoCAD 2011 and 2012 functioned fine with the original driver.


To upload a revised driver I had to instal AMD's Catalyst Control which crashed during installation mucking up my display settings. I restarted and referenced the orginal driver and all was OK except I wouldn't be able to use Mudbox (which I didn't consider was any big deal any way.


However, returning to AutoCAD it had then devloped a fault which precluded the loading of acvmtools.arx (this is obvioulsy the module which controls the view cube and 3D viewing fuctionallity).


After the best part of two days wrestling it transpired (by trawling sundry articles on the AMD site) I needed to download a Microsoft patch which would then allow the installation of an updated version of Microsoft Visual C++ 2010, which would then allow Catalyst Contol to load which would then update my graphics driver.


I am assuming that, without the patch, my previous attempt to instal Catalyst failed to install the packaged MS Visual C++ correctly and  caused a conflic with the original version.


I might try reinstalling Mudbox now once I catch up on all the work that has been put back after fighting to get Autocad to work correctly again.......the 3D viewing in 2012 does look good though. I only wish it hadn't been such a pain in the bum to get it back.



Post 3 of 10

Re: Problems with 3D orbit - acvmtools.arx

04-28-2011 12:32 AM in reply to: john.s

As a follow up I have now installed Mudbox, which works with the new driver, and I was a bit unfair as it certainly doesn't suck. I may even start using it rather than rigging character skins.


I can't say that I am happy it took me so long to sort the problem out, and while I can appreciate it would have been difficult for subscription centre support to have come up with the solution, I am a little disappointed they didn't even seem to find the road let alone make their way along it to find the solution.

Post 4 of 10

Re: Problems with 3D orbit - acvmtools.arx

04-28-2011 12:39 AM in reply to: john.s

I just love it that people answer thier own postsSmiley Very Happy

If things don't change they'll stay as they are !
Windows 7 Ultimate 64bit
Post 5 of 10

Re: Problems with 3D orbit - acvmtools.arx

05-02-2011 07:33 AM in reply to: Quagga

It's sometimes the only way to get an answer I understand.....but even that isn't guaranteed. :-) 

Post 6 of 10

Re: Problems with 3D orbit - acvmtools.arx

06-29-2011 02:52 PM in reply to: john.s



I'm having the same problem here


Asus G73jh

Core i7


ATI Mobility Radeon HD 5870

Windows 7 64

AutoCAD 2010


Months ago i updated my video driver from ATI and everything worked just fine, but catalyst stoped working every time i turn on the pc.


Two days ago try to update my video drivers from ATI page, install does not complete and BSOD pops up, then it turns off.


it restarts and everything seems to be Ok but a few problems in 3DS Max.

then i choose to roll back to previous driver directly from control panel and Max went Ok but AutoCAD shows that error every time i change visual stye, or try to 3d orbit. in fact i can't 3d orbit at all.


i have checked drivers and all stuff, from AutoCAD performance tuner, Catalyst, and Asus website and it seems that i have the latest drivers.


It is killing me!!!!!!

Post 7 of 10

Re: Problems with 3D orbit - acvmtools.arx

10-31-2011 08:45 PM in reply to: john.s

I was having the same problem.


The original card on my sytem is an ATI Radeon X1150/1550. It was working fine until I decided to try an ATI Radeon HD 5450 in order to run some performance tests. the 5450 worked fine. however when I put the X1150/1550 back Autocad 2012 started showing that Exception Error for the acvmtools.


I tried to update the driver for the x1150, but this card is not officially supported on windows 7. The most up to date driver for this card is from microsoft. So, when I try to updated it, the systems says that the best driver is already installed.


Finally, in an old forum I found a solution. This forum was from the time Windows 7 RC came out. At that time there was not a windows 7 driver for this card. Then the work around to install the x1150 was to use an old catalist driver (7.1) which is intended for Vista.


I did installed that driver and Autocad stops complaining.

Observer I_D
Post 8 of 10

Re: Problems with 3D orbit - acvmtools.arx

02-07-2012 04:54 PM in reply to: john.s
Hi John, It's kind of an old post, but the only one i found that deals with a similar problem to mine: I'm also having issues when passing from 2011 to 2012 autocad with the same machine: Dell studio 1558 with ATI Radeon HD 5470 which is apparently not certified by autodesk (8 gb of RAM, 1 gb of graphic card mem and i7 cpu). Apparently the hardware accelerator cannot be activated. When using the software accelerator the software is acting weird and without acceleration it's lagging to an unusable degree. Never had such issues with Autocad 2011. I tried updating the driver, changing files, reinstalling etc. but without results other that damage to the registry integrity that forced me reinstalling windows (great...). What driver's version are you using? what catalyst version? Hardware acceleration's working for you (3DCONFIG/MANUAL TUNE)? any other ideas to help me getting my feet back on the ground? thanks in advance!
Post 9 of 10

Re: Problems with 3D orbit - acvmtools.arx

02-08-2012 01:06 AM in reply to: john.s



I'm not sure I am going to be of much assistance. Catalyst is a hatefull programe and wont even fire up the Catalyst Control Centre application so I can't tell you what version I have, or even if it is running at all. I assume it is as I can use Mudbox and do orbits. Windows Task Manager doesn't give any clues one way or another.


I have checked my 3DConfig and hardware accelleration is ticked although there is a yellow exclaimation mark along side.


As a result of your query I fired up AMD System Monitor, which can be tagged to run on the surface, I manipulated a 3D model with realistic materials and was surprised that the Monitor said everything was being processed by the CPU. Even with an output render the CPU will go to 100% useage without a flicker on the Radeon chip.  It gets more excited moving windows around on my desk top or, indeed, typing this reply.  That said,  it gets more excited when I stop doing anything so I am given to wonder if it it is telling me anything at all.


The fact that the technical department seem to keep their head down over this would suggest there isn't an easy fix.  Sorry I havn't really been any help at all.

Observer I_D
Post 10 of 10

Re: Problems with 3D orbit - acvmtools.arx

02-08-2012 02:02 AM in reply to: john.s

all right... 

thanks anyway. Can't find any more precise information on the net so maybe it's just my computer. 

Will try to install again and hopefully it will work, otherwise back to 2011 which is kind of annoying (autocoplete is nice...). I forgot to mention that i get the "heidi driver could not be loaded". If you don't get it should be ok i guess. 


thanks again

Post to the Community

Have questions about Autodesk products? Ask the community.

New Post