Community
AutoCAD Forum
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

AutoCAD - Leader Arrow Head and Line Color Controls

2 REPLIES 2
Reply
Message 1 of 3
lee.imbimbo86EM4
224 Views, 2 Replies

AutoCAD - Leader Arrow Head and Line Color Controls

I've got a weird issue, were my QLEADER command is suddenly acting weird, and I can't seem to figure out what variable is causing to act up.  The issue at hand is as follows:

 

I use a custom arrowhead block that I've used now for the better part of twenty years, without issue.  The 90 degree arrow head is supposed to be color Green (3)  and the Leader Line is supposed to be Gray (8).  In my floor plan file this is not an issue.  Still working normal, no problem.  The issue is coming with working in a siteplan file setup by my surveyor.  I've cleaned up the survey and got everything turned over to my layers, and everything is working until I went to put some notes on the drawing, and all of a sudden my arrow head will only be the color that the leader line is, again Gray (8).  to make matters worse if I draw a QLEADER in my floor plan file and cut and paste it into the siteplan file it works.  But the second I use the DIMUPDATE command to let's say change the scale or even draw another leader I'm right back to the arrowhead being Gray (8) not Green (3).

 

I'm fairly familiar with the various variables that control all this, as I come from the days of CAD when you didn't get fancy menus you could access to control them, but I don't have a clue which variable is controlling this.

 

Now for the twist, the arrow looks fine in modelspace, but in paperspace through the viewport it doesn't.  I've checked viewport overrides and the layer is not overridden to show in a different color.

 

Any Ideas?

 

[ The subject line of this post has been edited for clarity by @handjonathan Original: Leader Arrow Head and Line Color Controls ]

2 REPLIES 2
Message 2 of 3
pendean
in reply to: lee.imbimbo86EM4

Sample DWG file with the problem in it would be needed here: can you share?

Q: any reason you are still committed to the old QLEADER tool tied to your DIMSTYLE (and where your color issue likely resides since it was set up by someone else) instead of the more independent and more flexible to customize MLEADER tools?
Message 3 of 3
lee.imbimbo86EM4
in reply to: pendean

@pendean TBH the biggest reason I'm still using QLEADER is habit, and that's what my PGP file is synced to.  I've played with MLEADER and it seems like while useful to some degree there are other things that would hinder my work flow. That being said leaders drawn with MLEADER seem to be suffering the same fate as those drawn with QLEADER.

 

I went ahead and saved a base file that stripped out all the confidential data from this particular file.  I left the property boundary line and the notes with their leaders in question, and the viewport in paperspace.  it seems to isolate my issue.  But you'll see in model space they somewhat display correctly, with the exception of the SPLINE LEADERS, which are not.  But in Paperspace they do not.

 

I've tried the following things to no avail:

  • check all known relevant variables
  • cut and paste from a file where it is working
  • clear all viewport overrides
  • purge and reinsert text and dimstyles (I have a block family to do just this)

I have one more thing I can think of to try, but while it make work, it won't teach me about what is actually going on here.  I could basically WBLOCK out all the relevant data from the Surveyor's file and then insert it into one of my standard templates and explode it.  This kind of brute force method has worked for me before.  But while it may work, it doesn't really answer the question: "Which is what the heck is controlling this that I'm not currently aware of?"

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report