AutoCAD Forum
Welcome to Autodesk’s AutoCAD Forums. Share your knowledge, ask questions, and explore popular AutoCAD topics.

AutoCAD Forum

Reply
Post 1 of 42

AutoCAD 2017 - Wipeout Lag Bug

1370 Views, 41 Replies
03-25-2016 07:26 AM

In AutoCAD 2017, when moving, copying, drawing, etc. over a wipeout with many vertices, the program completely bogs down and becomes unresponsive for several minutes.  This behavior is similar to what was experienced in AutoCAD 2015 and 2016 with dense hatches and may be related, but I did not experience this problem with wipeouts in either 2015 or 2016.

In the attached drawing, try to move or copy the line to the right through the areas with the circles (where the vertices are densest).  Be prepared to hit the ESC key a dozen times unless you have time to wait.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 2 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-25-2016 09:19 AM in reply to: nrz13

I can't repeat your problem in R2016 or R2017 and I widened your wipeout to test it. Did I miss something?



Dean Saadallah
AutoCAD, LT and Architecture User
Blog | Google+ | PINS
Facebook | Twitter | LinkedIn

Post 3 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-25-2016 09:28 AM in reply to: pendean

Like similar issues in 2015 and 2016 with hatches, it may be dependent upon variables being set a certain way.  Here's my GRAPHICSCONFIG:

 

I retested it and it's not as bad as it was before, but still bad.  I'm not sure what's controlling that.  You might have to wave the line around over the dense wipeout area a few times for it to stick.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 4 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-25-2016 12:50 PM in reply to: nrz13

Like Dean, I also could not get the line to stick.

 

 

Regards,

Michael Partenheimer

Post 5 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-25-2016 03:25 PM in reply to: nrz13

Hi,

 

am I right that this hang-up's only appear while moving the line and havingobject snap INTersection active?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------

(not an Autodesk consultant)
Post 6 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-26-2016 09:08 PM in reply to: Alfred.NESWADBA

Partway there, Alfred.  The lag only appears when Apparent Intersection (≈80% of the lag) and Intersection snaps are turned on.  Good catch.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 7 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-26-2016 11:09 PM in reply to: nrz13

I'm not sure who marked this thread solved, but it definitely wasn't me.  This is a bug that was not present in previous versions of AutoCAD.  It's similar to bugs that were eventually fixed in 2015 and 2016 that dealt with delays and Intersection OSNAPS.  I definitely want this solved in 2017 as well.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 8 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 05:43 AM in reply to: nrz13

Maybe if you set AutoCAd 2017 to use DirectX 11 may help.

 

I can not reproduce your problem.

 

Win 7 enterprize 16g RAM  Firepro 3900

Post 9 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 05:50 AM in reply to: Alfred.NESWADBA

Alfred:

Were you able to reproduce this, or were you just guessing based on previous similar problems?  If you experience this, are you also running an uncertified NVIDIA card?


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 06:18 AM in reply to: nrz13

Hi,

 

>> Were you able to reproduce this, or were you just guessing based on previous

>> similar problems?  If you experience this, are you also running an uncertified NVIDIA card?

Having object snap INTersection active ... yes, I can reproduce hangups.

 

>> are you also running an uncertified NVIDIA card?

Yes, but that happens also with hardware acceleration OFF, so using the AutoCAD internal software driver. Therefor I'm sure it's not depending on certified or not certified.

 

But just saw that additional important setting: it only happens when dynamic input is ON, and with the same setting (dyn. input ON) I can reproduce the same lag's also with 2016.

I have not seen that as I don't have dynamic input active by default, just in 2017 as it's fresh installed and not all settings are done.

And again yes, when the wipeout-objects are deleted then no delay during moding the line over the existing objects.

 

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------

(not an Autodesk consultant)
Post 11 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 06:44 AM in reply to: Alfred.NESWADBA

Hmmm, that seems to confuse things even more because on my 2016 install (work computer), I can't reproduce it with hardware acceleration on or off.  I'm running SP1, but I'm guessing you are too.

I'll have to try with and without hardware acceleration on my home computer tonight to see if it behaves any differently.  I'll also look into DX11, although I believe I looked into that in the past and couldn't figure out how to get it to use DX11 (even though it's a DX11 card).


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 06:47 AM in reply to: nrz13

Hi,

 

>> because on my 2016 install (work computer), I can't reproduce it with hardware acceleration on or off

Having dynamic input ON?

 

- alfred -

-------------------------------------------------------------------------
Alfred NESWADBA
Ingenieur Studio HOLLAUS ... www.hollaus.at
-------------------------------------------------------------------------

(not an Autodesk consultant)
Post 13 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 06:51 AM in reply to: Alfred.NESWADBA

Yes, sorry I should have mentioned that.  I only ever use dynamic input (no command line).

Off topic:  I used to hate dynamic input, but I gave it a shot for a couple of days because I knew it to be more efficient since your eyes can stay focused on where you're drawing rather than darting back and forth from the command line.  After giving it an honest try for two days, I've never gone back.  You probably also know that you can adjust the placement for the dynamic input box that pops up.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 14 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-28-2016 05:07 PM in reply to: nrz13

I did some more testing tonight and determined that hardware acceleration makes no difference for me.

However, Dynamic Input did make a difference.  As far as I can tell so far, to reproduce this bug, try the instructions in my first post with:

- Dynamic Input on
- Apparent Intersection and Intersection OSNAPs on


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 15 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 08:19 AM in reply to: nrz13

I've attempted several setting changes in an effort to recreate the lag issue in your drawing and have still been unable to recreate it.

I did apply Hotfix 1 to my installation of AutoCAD 2017 yesterday.

 

Work: Win7 64bit, i7 3.5Ghz, 16GB RAM, AMD FirePro W5000 2MB, Dual Samsung LCDs @ 1920x1200, Samsung 250 GB SSD, Seagate 2TB HD

 

Regards,

Michael Partenheimer

Post 16 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 09:04 AM in reply to: Partenheimer

I plan on installing the Hotfix tonight and will report back.  Thanks.


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 17 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 10:21 AM in reply to: nrz13

R2017 Hotfix 1 only addresses these items:

The following issues are addressed by this hotfix:
Layers of Xrefs that are frozen in viewports are plotting ellipses.
In some languages the model documentation commands are not working.
The number of hits for GetLineContainment is incorrectly counted.
Xrefs show as needing reloading when opened from a network path to a shared folder.

 

http://up.autodesk.com/2017/ACD/Autodesk_AutoCAD_2017_Hotfix_1_Readme.html 



Dean Saadallah
AutoCAD, LT and Architecture User
Blog | Google+ | PINS
Facebook | Twitter | LinkedIn

Post 18 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 10:24 AM in reply to: pendean

Thanks for the additional info.  All the same, I'll still try it out in case fixing one of these other bugs happens to fix this one too (unlikely, I know).


____________________________________________________________________________________________________________________________________________
Work:  AutoCAD 2016 SP1, Windows 10 64-bit, Intel Core i7-2600K, 16GB RAM, Crucial M4 SSD, AMD FirePro V4900, 2 Dell Monitors (2560x1600)
Home: AutoCAD 2017, Windows 10 64-bit, Intel Core i7-3770, 24GB RAM, Samsung SSD, NVIDIA GeForce GTX 680MX, Apple Monitor (2560x1440)
Post 19 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 01:17 PM in reply to: nrz13

With ACAD 2017 and a Quadro K2200M video card I also can't repro the issue.

 

I turned on ALL the osnaps, and all the other settings everyone mentioned, and the only sticking I could get was for about a tenth of a second when it hit one of the osnaps

Post 20 of 42

Re: AutoCAD 2017 - Wipeout Lag Bug

03-29-2016 01:32 PM in reply to: NeutronStar13

Hello nrz13;

 

I tried to reproduce the issue on my system, but was unable to do so.

 

I have AutoCAD 2017 with no hotfix installed, Windows 7 Enterprise, i7 4900MQ 2.8GHz, 16GB RAM, and a Nvidia Quadro K2100M video card.

 

I tested with all Osnaps on, Dynamic input on.

 

I noticed the 680 MX isn't listed on the Certified Hardware site. Have you installed 2017 on the work system yet and tested it there, to see if it might be related to using the uncertified card? 


Steve Tamplen

Technical Support Specialist
Post to the Community

Have questions about Autodesk products? Ask the community.

New Post