AutoCAD Architecture Forum
Welcome to Autodesk’s AutoCAD Architecture Forums. Share your knowledge, ask questions, and explore popular AutoCAD Architecture topics.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Hatches are recognized as multiple objects

2 REPLIES 2
SOLVED
Reply
Message 1 of 3
impressif
287 Views, 2 Replies

Hatches are recognized as multiple objects

Hi Autodesk Community,

 

I have a problem with my hatches in AutoCAD Architecture: Hatches are recognized as multiple objects, therefore it doesn't open the hatch edit Menu on top (in German "Schraffureditor"), I always have to use the HATCHEDIT command to change anything (German SCHRAFFEDIT).

I also can't use "ADDSELECTED" because then it tells me that you can't use the command when selecting multiple objects.

 

I played around with some settings in the HATCHEDIT but nothing seems to work...

 

______________

Update:

I have found a workaround with the Settings from the "Screenshot workaround so far" - by creating the Hatch and then removing the Polyline that it created, then leaving me with only the Hatch left and the hatch is recognized as hatch again. So for every hatch I create I still always have to remove the polyline.

If I create the hatch without polyline in the first place, the borders of the hatch follow the surrounding lines and are very weird, so I need to have a polyline created for "good" borders.

 

-------------------

 

Fast help would be great, as I have an exam tomorrow and the day after... and using HATCHEDIT is a little slower...

Thank you so much for helping!

 

Sorry for my English and greetings from Germany!

2 REPLIES 2
Message 2 of 3
David_W_Koch
in reply to: impressif

@impressif 

 

Welcome to the community!

 

If you are creating associative hatches (hatches that remain associated with the boundary object(s) and update when the boundary object(s) are changed), then you should check the setting of the PICKSTYLE system variable.  

 

This controls how groups and/or associative hatches act when selected.  If PICKSTYLE is set to:

  • 0, selecting a member of a group or an associative hatch only selects the selected item.
  • 1, selecting a member of a group selects all members of the group.
  • 2, selecting an associative hatch selects the boundary object(s) as well.
  • 3, selecting an associative hatch selects the boundary object(s), and selecting a member of a group selects all members of the group.

From your description, it sounds like you are using associative hatches and PICKSTYLE is set to 2 or 3.  Set it to 0 (or 1, if you want to select all members of a group when selecting one) to only select the hatch while still keeping the boundary object(s).

 

If you prefer dialog boxes to command-line typing, you can control the setting of PICKSTYLE through two toggles in the Options dialog, on the Selection tab, in the Selection modes area:  Object grouping and Associative Hatch.  Check the toggle(s) to activate group and/or associative hatch/boundary selection; clear the check marks from the toggle(s) to deactivate that(those) feature(s).

 

Snag_e7f241f.png


David Koch
AutoCAD Architecture and Revit User
Blog | LinkedIn
EESignature

Message 3 of 3
impressif
in reply to: impressif

Hello David,

 

thank you so much for helping me and for putting in time and effort to solve my problem! It was exactly that. 

It was set to 3.

I had spent hours on trying to fix the issue and would've never guessed that.

 

Thanks so much again! 🙂

 

Greetings

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report