Community
Arnold GPU Forum
General discussions about GPU rendering with Arnold.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

The final rendering of the bubbles still presents a black problem.

18 REPLIES 18
Reply
Message 1 of 19
66175545
293 Views, 18 Replies

The final rendering of the bubbles still presents a black problem.

Please tell me, the rendering depth is set as shown in the picture, but the final rendering bubble still appears black, is the transmission depth not enough?01.jpg02.jpg

18 REPLIES 18
Message 2 of 19
lee_griggs
in reply to: 66175545

Have you enabled standard_surface.caustics? Also, try to ensure that there are no intersections and the normals are correct.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 3 of 19
66175545
in reply to: lee_griggs

Enabled standard_surface.caustics but the blacks seem to disappear when using arnold CPU rendering mode, I wonder if this is related to the arnold GPU limitation (flaw), also it's hard to avoid bubble interspersions when using c4d particles (is this a reasonable request for the user?). Is the suggestion to look at optimising the arnold GPU engine to solve the problem occurring, thus bringing better ease of use and friendliness?

Message 4 of 19
lee_griggs
in reply to: 66175545

It may be due to the particle shape. Try assigning the same shader to a sphere to see if it still renders black.

Lee Griggs
Arnold rendering specialist
AUTODESK
Message 5 of 19
66175545
in reply to: lee_griggs

Ok, thank you very much for your careful pointers, after trying to use arnold CPU mode to render the output image as below, where it is the same render depth setting as arnold GPU, and there is no black colour when projecting the small bubbles in CPU mode, to answer your question:I am giving them (particles) the same material sphere.01.jpg

Message 6 of 19
peterDTE7K
in reply to: 66175545

with GPU you need to dramatically increase specular ray depth to fully get rid of black patches on transmissive objects

Message 7 of 19
66175545
in reply to: peterDTE7K

Thanks for your reply, I tried again to modify (crank up) the render depth, but the result still comes out with black artefacts on the projected material, as shown.01.jpg02.jpg

Message 8 of 19
peterDTE7K
in reply to: 66175545

You need to increase specular ray depth not transmissive ray depth. Sorry I wasn't clear - 48 transmissive is way too much and the amount you need depends on scene, simple bubbles don't need such high amount.

 

Try this:

Increase specular ray depth to 20 and set transmission ray depth to 20. If it fixes your problem then decrease those values until you have result which you are still satisfied with.

 

Screenshot 2024-07-11 054711.png

Message 9 of 19
66175545
in reply to: peterDTE7K

Thank you very much for your careful guidance, I tried the GPU model under changing specular to set to 2 and 32 respectively and transmission to set to 48 and 32 respectively. is that they give me the same result in the output graph display.01.jpg

Message 10 of 19
wernienst
in reply to: 66175545

Maybe a glass material setting? Have you activated some of the surface effects like Coat (right half of my rendering)?

wernienst_0-1720695806560.png

 

 

Message 11 of 19
66175545
in reply to: wernienst

Thank you very much for your guidance, I packaged up my project (which uses c4d particles), if you would like to take the time to look at it.

Message 12 of 19
wernienst
in reply to: 66175545

Unfortunately, I don't have an Arnold licence for Cinema4D, so I tried to recreate your scene in 3dsMax as close as possible using the geometry provided and Tyflow for the bubbles. I get this:

wernienst_0-1720773804960.png

Here are the Render Settings:

wernienst_1-1720773911430.png

I've also added a Denoiser Oidn Imager.

Below is my bubbles material.

 

Message 13 of 19
66175545
in reply to: wernienst

Roger, thank you very much for your kind help, may I ask if you are using arnold[...] I am using DCC C4D + arnold CPU rendering mode does not show black shadows, but while testing arnold GPU I found this black shadow appearing problem, so I would like to optimise and demand help in arnold GPU mode.

Message 14 of 19
wernienst
in reply to: 66175545

For my scene I used Arnold (7.3.2.1, MaxToA 5.7.2.1) as Renderer in GPU mode and Standard Surface materials only. Have you tried my provided bubble material? (Just import the bubblemat.ass file above. Look here how to do it:

https://help.autodesk.com/view/ARNOL/ENU/?guid=arnold_for_cinema_4d_ci_Utilities_ci_Material_Import_...)

 

Message 15 of 19
66175545
in reply to: wernienst

Ok, thank you very much, I'm in the process of rendering a certain project, I'll render the files you've taken the time to help me with, thank you very much, and I'll report back to you with the results of my rendering after that (expected next Monday).

Message 16 of 19
66175545
in reply to: wernienst

Hello big guy, after testing (importing the ass file material you provided into the previous project and rendering it with arnold GPU), the result is as shown.01.jpg

Message 17 of 19
66175545
in reply to: wernienst

Hello big guy, after testing (importing the ass file material you provided into the previous project and rendering it with arnold GPU), the result is as shown.01.jpg

Message 18 of 19
wernienst
in reply to: 66175545

Sorry for not being helpful! Maybe someone with access to C4DToA may jump in now.

Message 19 of 19
66175545
in reply to: wernienst

Thank you very, very much for your patience and detailed help, our common goal is to help make the Arnold GPU renderer even better.

Can't find what you're looking for? Ask the community or share your knowledge.

Post to forums  

Technology Administrators


Autodesk Design & Make Report